LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-23-2006, 08:33 AM   #1
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Rep: Reputation: 0
K3B, DVD: mount : Not a directory - whats going on?


I have just installed a new DVD Philips DVD+RW 1660 also using Philips DVD+RW 4.7G media on my 2.4 Debian linux.

I burned the disks with K3B. Now, suddenly they are not accessible
I get

nautilus:/home/dave# mount /dev/dvd /media/dvd
mount: block device /dev/dvd is write-protected, mounting read-only
mount: Not a directory

They were previously accessible this way. I have not changed
anything on my setup. I took them over to an XP system and they are fine - what is going on and why can XP read it and linux cant?

Is there a bit in the iso header that is getting flipped or something? How can I make them readable/accessible under linux again?



----
nautilus:/home/dave# dmesg | grep -i dvd
hdd: PHILIPS DVDR1660P1, ATAPI CD/DVD-ROM drive
hdd: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, (U)DMA

nautilus:/home/dave# ls -l /dev/dvd
lrwxrwxrwx 1 root root 8 2006-07-12 14:11 /dev/dvd -> /dev/hdd
nautilus:/home/dave# ls -l /dev/hdd
brw-rw-rw- 1 root disk 22, 64 2005-02-27 23:37 /dev/hdd

nautilus:/home/dave# ls -ld /media/dvd
drwxr-xr-x 2 root root 4096 2006-07-12 15:45 /media/dvd
 
Old 07-23-2006, 09:44 AM   #2
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Original Poster
Rep: Reputation: 0
still broken

...or is there any control parameters or bits in the Philips flash firmware that has gotten flipped (even mischievously?) ....

I mean it is bad form that k3b/linux is so flaky on this Philips drive, since these guys invented cd/dvd.
 
Old 07-23-2006, 01:12 PM   #3
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Quote:
Originally Posted by dmoore0100-linuxqs
I have just installed a new DVD Philips DVD+RW 1660 also using Philips DVD+RW 4.7G media on my 2.4 Debian linux.

I burned the disks with K3B. Now, suddenly they are not accessible
I get

nautilus:/home/dave# mount /dev/dvd /media/dvd
mount: block device /dev/dvd is write-protected, mounting read-only
mount: Not a directory

They were previously accessible this way. I have not changed
anything on my setup. I took them over to an XP system and they are fine - what is going on and why can XP read it and linux cant?

Is there a bit in the iso header that is getting flipped or something? How can I make them readable/accessible under linux again?



----
nautilus:/home/dave# dmesg | grep -i dvd
hdd: PHILIPS DVDR1660P1, ATAPI CD/DVD-ROM drive
hdd: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, (U)DMA

nautilus:/home/dave# ls -l /dev/dvd
lrwxrwxrwx 1 root root 8 2006-07-12 14:11 /dev/dvd -> /dev/hdd
nautilus:/home/dave# ls -l /dev/hdd
brw-rw-rw- 1 root disk 22, 64 2005-02-27 23:37 /dev/hdd

nautilus:/home/dave# ls -ld /media/dvd
drwxr-xr-x 2 root root 4096 2006-07-12 15:45 /media/dvd

You may want to do a chown root:cdrom /dev/hdd as root to give the burner the proper permissions for access to anyone who is a member of the cdrom group which should be the default in Debian for normal user access. As for the /media/dvd you may want to use /media/cdrom to mount the disk you should already have permission on the directory.
 
Old 07-23-2006, 02:16 PM   #4
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Original Poster
Rep: Reputation: 0
fwi: root.cdrom made no difference anyways:-
>>They were previously accessible this way. I have not changed
>>anything on my setup.

Does anyone know anything about DVDs? ISO9660? etc.?
 
Old 07-24-2006, 07:33 AM   #5
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Original Poster
Rep: Reputation: 0
..bump -- still need some ideas here...
 
Old 07-24-2006, 08:03 AM   #6
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 161Reputation: 161
Quote:
Originally Posted by dmoore0100-linuxqs
nautilus:/home/dave# mount /dev/dvd /media/dvd
mount: block device /dev/dvd is write-protected, mounting read-only
You'll get that if you try mounting CDs/DVDs read-write. It simply cannot be done. You should add "-o ro" to your command. Refer to "man mount" for further info.
Quote:
Originally Posted by dmoore0100-linuxqs
I burned the disks with K3B. Now, suddenly they are not accessible
...
mount: Not a directory
What type of discs? And what is on them?

You can't mount an audio CD.
Quote:
Originally Posted by dmoore0100-linuxqs
They were previously accessible this way.
If you're 100% sure they're NOT audio CDs, try this:

Code:
# mount -t iso9660 -o ro /dev/hdd /media/dvd
Remember, the HOWTOs are your friend:

http://www.tldp.org/HOWTO/CDROM-HOWTO/

HTH

Quote:
Originally Posted by dmoore0100-linuxqs
..bump
Stop doing that. It's annoying.

Last edited by rkelsen; 07-24-2006 at 08:04 AM.
 
Old 07-24-2006, 08:24 AM   #7
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Hi,

...think you've somewhat missed the central point - my prior posts indicate that I created these disks using K3B and successfully mount and read back the data on several different occassions. Then 1,2 days later suddenly those exact same disks could not be accessed using the exact same procedures with the exact same setup. (I thought I'd already said all of this already? didn't i? wait a minute i'll just go back and read
my post to check. Oh yes I did say it already...

[fwiw.
nautilus:/home/dave# mount -t iso9660 -o ro /dev/hdd /media/dvd
mount: Not a directory
BTW: Obviously this problem has nothing to do with #mount/options/etc.. that is just
the smoking gun eg.
nautilus:/home/dave# dmesg | tail
ISOFS: unable to read i-node block
attempt to access beyond end of device
16:40: rw=0, want=9223372036854138736, limit=4590208

Don't think the howto is gonna cover this do you?

So anyone else with better ideas?


Regards.
 
Old 07-24-2006, 05:46 PM   #8
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
nautilus:/home/dave# mount /dev/dvd /media/dvd
mount: block device /dev/dvd is write-protected, mounting read-only
mount: Not a directory
nautilus:/home/dave# dmesg | tail
ISOFS: unable to read i-node block
attempt to access beyond end of device
16:40: rw=0, want=9223372036854138736, limit=4590208
But anyways there seems to be valid report of 4.7Gb worth of storage
on the disk so why is _mount_ generating a request for a block number
in the 9.2 Exabyte range (2^60) ?
 
Old 07-24-2006, 06:04 PM   #9
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 161Reputation: 161
Quote:
Originally Posted by dmoore0100-linuxqs
I thought I'd already said all of this already? didn't i? wait a minute i'll just go back and read
my post to check. Oh yes I did say it already...

...

Don't think the howto is gonna cover this do you?

So anyone else with better ideas?
Listen to me, silver tongue.

You're having a problem mounting the discs under Linux, but they work in Windows.

Therefore it stands to reason that you're doing something wrong in Linux.

Read the damn HOWTO and make sure that you follow it to the letter.

Come back if it still doesn't work.

And by the way - lose the attitude. People aren't paid to be here. If you're not happy, go back to Windows. Nobody here will miss you.
 
Old 07-24-2006, 08:37 PM   #10
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Listen to me, silver tongue.

You're having a problem mounting the discs under Linux, but they work in Windows.

Therefore it stands to reason that you're doing something wrong in Linux.

Read the damn HOWTO and make sure that you follow it to the letter.

Come back if it still doesn't work.

And by the way - lose the attitude. People aren't paid to be here. If you're not happy, go back to Windows. Nobody here will miss you.
My replies may be direct but they do not have attitude, nor did
I resort to calling anyone in this forum "names". Neither do I use
or own a single copy of Windows, all my work is currently
done using Linux.

Now I'd like to get back to trying to solve this problem.


howto>4.5. Mounting, Unmounting, and Ejecting Devices
howto>
howto>To mount a CD-ROM, insert a disc in the drive,
howto>and run the mount command as root (this assumes you created
howto>a symbolic link to your device file as recommended above and
howto>that an empty directory /mnt/cdrom exists):
howto>
howto># mount -t iso9660 -r /dev/cdrom /mnt/cdrom

nautilus:/home/dave# rm -rf /media/dvd
nautilus:/home/dave# mkdir /media/dvd
nautilus:/home/dave# mount -t iso9660 -r /dev/hdd /media/dvd
mount: Not a directory

howto>
howto>The CD can now be accessed under the directory /mnt/cdrom.

Negative.

howto>4.6. Troubleshooting
howto>
howto>If you still encounter problems after following the
howto>instructions in the HOWTO, here are some things to check.
howto>The checks are listed in increasing order of complexity.
howto>If a check fails, solve the problem before moving
howto>to the next stage.
howto>

howto>4.6.1. Step 1: Make sure you are really running the kernel
howto>you compiled
howto>
howto>You can check the date stamp on the kernel to see if you are
howto>running the one that you compiled with CD-ROM support. You
howto>can do this with the
howto>uname command:
howto>
howto>% uname -a
howto>Linux moe 2.4.4 #1 Sat Apr 28 10:30:45 EDT 2001 i686 unknown
howto>or by displaying the file /proc/version:
howto>
howto>% cat /proc/version
howto>Linux version 2.4.4 (root@moe) (gcc version 2.95.2 20000220
howto>(Debian GNU/Linux)) #1 Sat Apr 28 10:30:45 EDT 2001

Not really relevant since this is a stock install from a binary distribution but fwiw.

nautilus:/home/dave# cat /proc/version
Linux version 2.4.27-2-sparc64 (root@sunfire) (gcc version 3.3.5 (Debian 1:3.3.5-12)) #1 Sun Apr 3 05:21:36 UTC 2005


howto>4.6.2. Step 2: Make sure the proper kernel drivers are
howto>compiled in
howto>
howto>You can see what drivers are compiled in by looking at
howto>/proc/devices:
howto>
howto>% cat /proc/devices
howto>Character devices:
howto> 1 mem
howto> 2 pty
howto> 3 ttyp
howto> 4 ttyS
howto> 5 cua
howto> 7 vcs
howto>
howto>Block devices:
howto> 3 ide0
howto>22 ide1
howto>
howto>First look for your CD-ROM device driver. These are all
howto>block devices,
howto>in this case we can see that the idecd driver with major
howto>number 22 was present.

Also not that relevant for the same previous reason (stock kernel) - but fwiw.

nautilus:/home/dave# cat /proc/devices
Character devices:
1 mem
2 pty/m%d
3 pty/s%d
4 vc/0
5 ptmx
6 lp
7 vcs
10 misc
11 kbd
13 input
14 sound
29 fb
36 netlink
128 ptm
136 pts/%d
162 raw
180 usb

Block devices:
1 ramdisk
2 fd
3 ide0
22 ide1


looks good.


howto>Also make sure that ISO-9660 filesystem support was compiled
howto>in, by looking at /proc/filesystems:
howto>
howto>% cat /proc/filesystems
howto> ext2
howto>nodev proc
howto>nodev devpts
howto> vfat
howto> iso9660


nautilus:/home/dave# cat /proc/filesystems
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev tmpfs
nodev shm
nodev pipefs
ext2
cramfs
nodev ramfs
nodev devfs
nodev nfs
romfs
nodev devpts
nodev usbdevfs
nodev usbfs
ext3
iso9660

looks good.

howto>4.6.3. Step 3: Did the kernel detect your drive during
howto>booting?
howto>
howto>Make sure that the CD-ROM device was detected when the
howto>kernel booted.
howto>You should have seen a message on bootup. If the messages
howto>scrolled off the screen, you can usually recall them using
howto>the dmesg command:
howto>
howto>% dmesg


nautilus:/home/dave# dmesg | grep -i dvd
hdd: PHILIPS DVDR1660P1, ATAPI CD/DVD-ROM drive
hdd: ATAPI 94X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, (U)DMA

looks good.


howto>4.6.4. Step 4: Can you read data from the drive?
howto>
howto>Try reading from the CD-ROM drive. Typing the following
howto>command should
howto>cause the drive activity light (if present) to come on and
howto>no errors should be reported. Use whatever device file is
howto>appropriate for your drive and make sure a CD-ROM is
howto>inserted; use Control-C to exit.
howto>
howto># dd if=/dev/cdrom of=/dev/null bs=2048
howto>^C
howto>124+0 records in
howto>124+0 records out
howto>
howto>If this works, then the kernel is communicating with the
howto>drive and you
howto>can move on to step 5.
howto>
howto>If not, then a possible cause is the device file. Make sure
howto>than the device file in the /dev directory has the correct
howto>major and minornumbers the device file allow reading and
howto>writing.


nautilus:/home/dave# dd if=/dev/hdd of=/dev/null bs=2048 count=16
16+0 records in
16+0 records out
32768 bytes transferred in 4.077675 seconds (8036 bytes/sec)

looks good.

howto>4.6.5. Step 5: Can you mount the drive?
howto>
howto>If you can read from the drive but cannot mount it, first
howto>verify that you compiled in ISO-9660 file system support by
howto>reading/proc/filesystems
howto>, as described previously.
howto>
howto>Make sure you are mounting the drive with the "-t iso9660"
howto>and "-r"
howto>options and that a known good ISO-9660 CD-ROM (not AudioCD)
howto>is inserted
howto>in the drive. You normally must mount drives as user root.
howto>
howto>Make sure that the mount point exists and is an empty
howto>directory.
howto>

Negative.


Any ideas then?
 
Old 07-24-2006, 09:34 PM   #11
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 161Reputation: 161
Quote:
Originally Posted by dmoore0100-linuxqs
Any ideas then?
OK. This one's a toughie.

Sorry if I bit your head off.
Quote:
Originally Posted by dmoore0100-linuxqs
I have just installed a new DVD Philips DVD+RW 1660 also using Philips DVD+RW 4.7G media on my 2.4 Debian linux.

I burned the disks with K3B. Now, suddenly they are not accessible
So, you burned the discs then installed a new drive and now they aren't mounting anymore? Could you clarify this?

Obviously, being recognised as hdd means that the drive is set up as a slave and plugged into ide1 on your motherboard. Is there another drive on the same cable? If not, you could try changing the jumper on the drive to "master" and connecting the drive to the first connector on the cable.

Last edited by rkelsen; 07-24-2006 at 09:38 PM.
 
Old 07-25-2006, 04:11 AM   #12
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Hi,

Yes the drive is set hdd and jumpered on cable select and it is also 100% operational
as I can mount lots of "other", "product" disks right now. Also I burned and use to mount these disks in this drive in this configuration and I'd like to get these disks
mounted again in this configuration without going to a new one (drive on master).

Like I said they just stopped mounting in the filesystem one day for some reason. I can however still look at them right now in the drive if I do this

nautilus:/home/dave# isoinfo -d -i /dev/hdd
CD-ROM is in ISO 9660 format
System id: LINUX
Volume id: K3b data project
Volume set id:
Publisher id:
Data preparer id: K3b - Version 0.11.20
Application id: K3B THE CD KREATOR VERSION 0.11.20 (C) 2003 SEBASTIAN TRUEG ANDTHE K3B TEAM
Copyright File id:
Abstract File id:
Bibliographic File id:
Volume set size is: 1
Volume set sequence number is: 1
Logical block size is: 2048
Volume size is: 1928645
NO Joliet present
Rock Ridge signatures version 1 found


And also,

#isodump -i /dev/hdd
136 [ 1] 1b23b7 2048 02/*. [SP,RR=1,PX=6,TF,CE=[1b242f,0,237][ER102 [ 1] 1b23b7 2048 02/*.. [RR=1,PX=2,TF]
112 [ 1] 1b23c3 6144 02/*MP3 [RR=1,NM=mp3,PX=f,TF]
116 [ 1] 1b23e8 6144 02/*MP3_2 [RR=1,NM=mp3-2,PX=10,TF]
116 [ 1] 1b240d 4096 02/*MP3_3 [RR=1,NM=mp3-3,PX=a,TF]
116 [ 1] 1b23b8 2048 02/*MP3_4 [RR=1,NM=mp3-4,PX=6,TF]

Zone, zone offset: 1b23b7 000000000000

Which allows me to navigate the correct Linux directory structure on the disk and see
all the filenames.

But now I do a:-

nautilus:/home/dave# mount -t iso9660 -r /dev/hdd /media/dvd
mount: Not a directory

nautilus:/home/dave# dmesg | tail

attempt to access beyond end of device
16:40: rw=0, want=9223372036854138736, limit=4590208
ISOFS: unable to read i-node block

So unless someone here can come up a solid technical explanation I think some joker has
been messing with my system.
 
Old 07-25-2006, 11:16 AM   #13
dmoore0100-linuxqs
LQ Newbie
 
Registered: Jul 2006
Posts: 9

Original Poster
Rep: Reputation: 0
Here's the disk that was created and use to mount under linux but now
gives the error "mount: Not a directory"

Even though pretty much everything else can still see and read
this disk, eg.

# isoinfo -p -f -i /dev/hdd

/MP3/BUGGE_WESSELTOFT/MOVING/CHANGE.MP3;1
/MP3/BUGGE_WESSELTOFT/MOVING/GARE_DU_NORD.MP3;1
/MP3/BUGGE_WESSELTOFT/MOVING/HEIM.MP3;1
/MP3/BUGGE_WESSELTOFT/MOVING/LONE.MP3;1
/MP3/BUGGE_WESSELTOFT/MOVING/MOVING.MP3;1
/MP3/BUGGE_WESSELTOFT/MOVING/YELLOW_IS_THE_COLOUR.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/ENDLESS.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/MODULAR.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/MY_STREET.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/NEW_CONCEPTION_OF_JAZZ.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/NEW_CONCEPTION_OF_JAZZ_2.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/POEM.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/SOMEWHERE_IN_BETWEEN.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/SPECTRE_SUPREME.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/TRIO.MP3;1
/MP3/BUGGE_WESSELTOFT/NEW_CONCEPTION_OF_JAZZ/TROUBLE.MP3;1
[listing truncated more follows...]

I also reburned 4+GB across 5 sessions on a new media, remounting it
for inspection each time and all was ok.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount as a device: mount dvd-iso file in /dev/dvd sadarax Linux - General 21 02-02-2011 11:59 PM
DVD won't mount until I run K3B BinFarteen Suse/Novell 5 02-11-2006 09:28 AM
mount:not a directory. Suse dvd mount problem tzanis Linux - General 8 11-06-2005 11:30 AM
k3b burns dvd+r but cant mount.... edong23 Linux - Software 3 11-02-2005 12:00 AM
LG DVD+-RW/RAM won't mount after writing DVD (growisofs/k3b) jaws_tas Linux - Hardware 1 03-25-2005 01:52 AM


All times are GMT -5. The time now is 03:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration