LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-27-2001, 01:06 PM   #1
Will
Member
 
Registered: Aug 2001
Posts: 73

Rep: Reputation: 15
Java pluggin and Mozilla 0.96


Could anybody tell if they have the Java pluggin working on Moz 0.96. I had it working on 0.94 but I can't get it to work 0.96.

If I now go to a java site I get prompted to the NS Java download site but on clicking to download the plugging it doesn't do anything.

Using a symbolic link in the pluggings directory as per the instructions I get prompted to download the pluggin at any java site.

Using a hard link on the other hand, on arriving at a java site mozilla just closes without warning.


If you have it working did you.

1. Download it from the NS site using Moz and did it auto install without problems. I have never been able to do it that way.

2. Did you downoad it from Sun site and use the bin file to install it then creating a symbolic link to Moz's pluggin directory.

2a. Did you use the NS4 pluggin or the NS6 pluggin for Moz 0.96.
 
Old 11-27-2001, 05:16 PM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
I started by going here


http://home.netscape.com/plugins/manager.html


choose the binary


used http download from sun for bin file



mkdir /usr/local/java

mv j2r* /usr/local/java

cd /usr/local/java


chmod a+x j2r*


./j2r*


[root@Alpha ns600]# ls
libjavaplugin_oji.so

[root@Alpha ns600]# pwd
/usr/local/java/jre1.3.1_01/plugin/i386/ns600

[david@Alpha david]$ slocate /mozilla/plugins
/usr/lib/mozilla/plugins


[root@Alpha ns600]# ln -s /usr/local/java/jre1.3.1_01/plugin/i386/ns600/libjavaplugin_oji.so /usr/lib/mozilla/plugins/libjavaplugin_oji.so


[root@Alpha ns600]# ln -s /usr/local/java/jre1.3.1_01/plugin/i386/ns4/javaplugin.so /usr/lib/netscape/plugins/javaplugin.so

Last edited by DavidPhillips; 11-27-2001 at 05:24 PM.
 
Old 11-28-2001, 10:47 AM   #3
Will
Member
 
Registered: Aug 2001
Posts: 73

Original Poster
Rep: Reputation: 15
Thats what I did and thats what I've got but it doesn't work as i'm also using the plugin that I used with 0.9.4 so I know it works.

The only thing I can think of is that something possibly got broken when I upgraded to 0.9.6.

Can you think of anything else?
 
Old 11-28-2001, 01:45 PM   #4
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,694

Rep: Reputation: 45
there was a plugin problem with .9.6 , plugger wasn't working either. the fix has been checked into the trunk builds but i'm not sure when/if it will be included in the .9.6 branch. make sure it's libjavaplugin_oji.so and it's the only javaplugin in the moz/plugins directory and it's a symlink from some other directory. i had to install netsape6 from my distro disks just so i could symlink to the plugin.
 
Old 11-28-2001, 04:54 PM   #5
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,154

Rep: Reputation: 56
Also the real player plugin was a little funky.

I did it about the same way with the rpnp.so file
 
Old 11-29-2001, 10:28 AM   #6
Will
Member
 
Registered: Aug 2001
Posts: 73

Original Poster
Rep: Reputation: 15
Thank folkes, I guess my only course of action left is to revert back to 0.94 set up the plugging and then upgrade to 0.9.6 and see if it is actually 0.9.6 causing the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to install java pluggin to firefox walterbyrd Linux - Software 7 03-21-2005 04:03 PM
having trouble with java pluggin for firefox, using debian walterbyrd Debian 5 08-28-2004 12:35 PM
Java for Mozilla and Mozilla-firebird Problem, Please help londonboi Linux - General 5 01-08-2004 05:07 AM
Mozilla java plugin no go kills Mozilla skinpainting Red Hat 13 11-30-2003 11:30 AM
JAVA and MOZILLA, mozilla just shuts off!! jcrapps Linux - Newbie 7 02-04-2003 10:11 PM


All times are GMT -5. The time now is 06:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration