LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-18-2008, 04:09 AM   #1
Omnutia
LQ Newbie
 
Registered: Jun 2006
Distribution: Ubuntu 7.10
Posts: 16

Rep: Reputation: 0
IRQ-18 consuming a lot of CPU power after installing PulseAudio


Hello everyone,
Yesterday I installed Pulseaudio on my laptop running ubuntu 7.10 and after changing a few thing got it to work. I was testing some of the settings when I looked at Conky and it was telling me that a process called IRQ-18 was taking up between 30-70% of the CPU. I have tried all versions of Kill on this process and it won't die. I also noticed that gnome system monitor seems not to recognize the processing power taken up by IRQ-18 and gives the current CPU load as being about 40% lower than Conky (though I think Conky is correct as the effect on system performance is quite noticeable.).
Any advice on how to stop this process overheating my laptop would be gratefully received. Thank you.

Last edited by Omnutia; 02-18-2008 at 04:52 AM.
 
Old 02-18-2008, 07:01 PM   #2
Omnutia
LQ Newbie
 
Registered: Jun 2006
Distribution: Ubuntu 7.10
Posts: 16

Original Poster
Rep: Reputation: 0
Update: I have discovered that IRQ-18 was using all that power to send huge amounts of interrupt requests to my CPU.
Code:
 18:   16622131   IO-APIC-fasteoi   sata_sil, HDA Intel
using "sudo pkill pulseaudio" stops the interrupts but not for long.
I'm looking into various additions to the boot line to try and fix this.

Last edited by Omnutia; 02-18-2008 at 07:03 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache is consuming all CPU resources romeo_tango Solaris / OpenSolaris 6 01-04-2008 05:43 AM
printer consuming 100% cpu jonfa Solaris / OpenSolaris 8 05-18-2007 04:34 PM
openSUSE 10.1 Xorg 6.9 consuming CPU and crashing jturning Suse/Novell 4 02-25-2007 03:30 PM
udevd consuming lot of CPU svangati Linux - Software 4 06-30-2006 01:03 PM
udevd consuming lot of CPU svangati Linux - General 3 05-15-2006 04:11 PM


All times are GMT -5. The time now is 09:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration