LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-04-2002, 11:52 AM   #1
_stef_
Member
 
Registered: Apr 2002
Location: Bosnia and Herzegovina
Distribution: Debian&M$Win*
Posts: 38

Rep: Reputation: 15
Thumbs down ircd-hybrid server installing problems


Can't install damn thing! It reports me that I'm not instal ZLIB but it there is installed latest version in /usr/lib

version is 1.1.4


this is error code from make program

make[1]: Entering directory `/usr/src/ircd-hybrid-6.3.1/adns'
gcc -I../include -g -O2 -DNDEBUG -c check.c
In file included from internal.h:37,
from check.c:32:
../include/config.h:991: #error ZIP_LINKS defined put ZLIB not found. Undef ZIP_LINKS or install ZLIB
make[1]: *** [check.o] Error 1
make[1]: Leaving directory `/usr/src/ircd-hybrid-6.3.1/adns'
Building src
make[1]: Entering directory `/usr/src/ircd-hybrid-6.3.1/src'
gcc -I../include -g -O2 -DNDEBUG -c adns.c
In file included from ../include/res.h:10,
from adns.c:9:
../include/config.h:991: #error ZIP_LINKS defined put ZLIB not found. Undef ZIP_LINKS or install ZLIB
make[1]: *** [adns.o] Error 1
make[1]: Leaving directory `/usr/src/ircd-hybrid-6.3.1/src'
Building tools
make[1]: Entering directory `/usr/src/ircd-hybrid-6.3.1/tools'
gcc -g -O2 -DNDEBUG -I../include -c viconf.c
In file included from viconf.c:14:
../include/config.h:991: #error ZIP_LINKS defined put ZLIB not found. Undef ZIP_LINKS or install ZLIB
make[1]: *** [viconf.o] Error 1
make[1]: Leaving directory `/usr/src/ircd-hybrid-6.3.1/tools'

 
Old 05-04-2002, 06:09 PM   #2
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Do "./configure --help" and see if there is an option to pass the location of zlib to configure, it should be something like "./configure --with-zlib=path-to-zlib".
 
Old 05-07-2002, 07:10 AM   #3
_stef_
Member
 
Registered: Apr 2002
Location: Bosnia and Herzegovina
Distribution: Debian&M$Win*
Posts: 38

Original Poster
Rep: Reputation: 15
Thumbs down

Fixed!

Problem was not in configure script and also no need to configure --with-*! It was problem with my ZLIB. There was old version and new version. There were some sym links linked to old ZLIB so it confused configure and also make.

I deleted old lib and sym links and now it works.

Thanx any way for support, may be someone will face the same problem so I write this to serve future generations...

 
Old 06-25-2002, 04:07 PM   #4
Fuss
LQ Newbie
 
Registered: Jun 2002
Location: Belgium
Distribution: RH7.3
Posts: 1

Rep: Reputation: 0
Hi.

_stef_ (or anybody else) could you please tell me where to find those symlinks?
I've got the same problems...
I tried /usr/local/lib/ but everything seemed ok to me.

Thanks in advance!
 
Old 06-26-2002, 09:12 AM   #5
_stef_
Member
 
Registered: Apr 2002
Location: Bosnia and Herzegovina
Distribution: Debian&M$Win*
Posts: 38

Original Poster
Rep: Reputation: 15
Thumbs down

You should search in /usr/lib or in /usr/local/lib

Do not forget to say
ls -al
to list you all the files and to see where sym links are pointing

Also, you should check to see, in my case file (mentionel lib) was corrupted from some reason. In that case, I deleted lib and then installed it from the beggining.

I have to mention that I did it in Slackware Linux so this may be can cause some damages in other distro.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IRCd and hybserv problems ironhacker Linux - Software 0 02-06-2005 09:03 AM
Problems with IRCD on Mandrake, cant connect to the box. Knuckles10 Linux - Networking 2 10-03-2004 02:17 AM
hybrid 7 ircd Crunch Linux - General 14 07-21-2004 08:32 AM
hybrid network problems BigCdaAnswer3 Linux - Networking 1 05-04-2004 09:39 PM
problems with installing a mandrake 8.0 server format_c Linux - Newbie 1 10-02-2001 02:46 PM


All times are GMT -5. The time now is 08:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration