LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 12-06-2002, 05:09 PM   #1
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Rep: Reputation: 30
invalid compressed format (error=1)


i get this error from lilo everytime i load linux with my 2.4.20 kernel, then it stops dead. what needs to be enabled in the kernel to stop this crap?
 
Old 12-06-2002, 05:49 PM   #2
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
did you make it with make bzImage and copy bzImage to /
 
Old 12-07-2002, 12:53 AM   #3
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
i do

make mrproper
make clean
make dep
make clean
make bzImage
make modules
make modules_install
cp arch/i386/boot/bzImage /boot/vmlinuz-new
cp System.map /boot/System.map

edit: then i edit lilo and run lilo
i know that would come up if i didnt mention it.

Last edited by Goatdemon; 12-07-2002 at 12:54 AM.
 
Old 12-07-2002, 06:17 PM   #4
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
anyone?
 
Old 12-07-2002, 07:58 PM   #5
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
sounds like it does not have support for your filesystem

I have seen this error on a root disk with the kernel not configured right
 
Old 12-08-2002, 03:39 PM   #6
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
my fs is ext3 and i enabled it and reiser fs just to be sure. (i set it to yes) i guess ill just wipe the system and start over again...
 
Old 12-08-2002, 04:42 PM   #7
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
do you have ext2 support?

I saw something about a bad download of the kernel that caused the same problem
 
Old 12-09-2002, 02:12 PM   #8
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
i didnt see anything that said enable ext2 support, anyway i have an ext3 fs.
 
Old 12-09-2002, 02:29 PM   #9
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
This could be a problem with your zlib. If I were you, I would try and reinstall zlib ( your gz utilities ) and try a make bzImage again.

BTW, you dont need more that one make clean and you would need a make menuconfig or make xconfig before you make dep. Is that what you intended to say in your kernel compilation steps above?
 
Old 12-09-2002, 02:50 PM   #10
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
It's called Second extended fs support and it must be built-in
 
Old 12-09-2002, 03:04 PM   #11
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
I do this

make mrproper
make menuconfig
make dep
make clean
make
make bzImage
make modules
make modules_install
cat arch/i386/boot/bzImage > /boot/vmlinuz-2.4.19-lq4
cp System.map /boot/System.map-2.4.19-lq4
ln -sf /boot/System.map-2.4.19-lq4 /boot/System.map
cp .config /boot/config-2.4.19-lq4
echo "image=/boot/vmlinuz-2.4.19-lq4" >> /etc/lilo.conf
echo " root = /dev/hda2" >> /etc/lilo.conf
echo " label = Linux-lq4" >> /etc/lilo.conf
echo " read-only" >> /etc/lilo.conf
lilo


also there is initrd which I do not have on this system, but I would add

root@slacker:/usr/src/linux-2.4.19-lq# ls /lib/modules
2.4.18/ 2.4.19-lq4/

mkinitrd /boot/initrd-2.4.19-lq4.img 2.4.19-lq4

echo " initrd = /boot/initrd-2.4.19-lq4.img" >> /etc/lilo.conf

lilo

Last edited by DavidPhillips; 12-09-2002 at 03:08 PM.
 
Old 12-09-2002, 11:06 PM   #12
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
i totally wiped my slack drive and reinstalled with the same errors, i need to recompile to get sound! this sucks!

ill try the ext2 thing and ill add make before make bzimage.
 
Old 12-09-2002, 11:54 PM   #13
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
ok, this is pissing me off. i've recompiled my kernel numerous times but all of the sudden i keep running into a friggin wall!

with the 2.4.18 kernel i get mouse errors saying that x cannot open /dev/input/mice and that it doesn't exist. it works on the install when i choose the usb.i kernel but when i recompile to get sound, even recompile and just change sound to yes and enable my soundcard, i get that error. i did do the necessary xf86config file modifications (protical IMPS/2) (device /dev/input/mice).

with 2.4.20 i get the invalid compressed format (error=1) or kernel panic, tried to kill init.

im posting my kernelconfig files on a website ill be tinkering with soon for 2.4.18 and 2.4.20, ive got no idea what's wrong. and i did have ext2 enabled. http://home.earthlink.net/~goatdemon/data/
 
Old 12-10-2002, 12:33 AM   #14
DavidPhillips
Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
are you sure you need to recompile to get sound, I would think that you could load modules, slack comes configured with pretty much all modules built

what is the sound card

you could try to modprobe some drivers in /lib/modules/2.4.18/kernel/drivers/sound
for mine I just went and saw ac97 so I did

modprobe ac97
then modprobe sb


usually if you try to load one and there is no error it is one you can use

then you would set it up to load on boot in /etc/rc.d/rc.modules



Last edited by DavidPhillips; 12-10-2002 at 12:35 AM.
 
Old 12-10-2002, 03:00 PM   #15
Goatdemon
Member
 
Registered: May 2002
Location: The good 'ol USofA
Distribution: ArchLinux - Slackware 8.1
Posts: 398

Original Poster
Rep: Reputation: 30
well i tried to do that but when i did modprobe soundcore it said no such module yadda yadda and plus my soundcard uses the chipset that is 3rd down from the top in the sound menue, ill give ya the name later... it starts with a c.... and im almost positive that it is by default set to off and not module.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
invalid compressed format (err=1) typul Fedora - Installation 1 11-06-2005 12:12 AM
invalid compressed format (err=1) voyager2 Linux - Newbie 2 01-27-2005 12:19 PM
invalid compressed format (err=2) mikeyjoon Linux - Software 1 08-20-2003 08:17 PM
invalid compressed format (err=1) shameless Linux - General 1 08-16-2003 12:15 PM
Invalid compressed format..... ceh383 Slackware 3 05-25-2003 12:08 AM


All times are GMT -5. The time now is 09:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration