LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-29-2001, 03:10 PM   #1
ugge
Senior Member
 
Registered: Dec 2000
Location: Gothenburg, SWEDEN
Distribution: OpenSUSE 10.3
Posts: 1,028

Rep: Reputation: 45
Unhappy


I need to install rpm-4 because all rpm's today is packaged using rpm-4. When I try to install it with rpm-3, wich is on my system, it won't work. Same error as for all other rpm-4 packed files: this version of rpm only handles package version <=3.

How am I supposed to fix this ;-)
 
Old 01-29-2001, 04:36 PM   #2
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 10,401

Rep: Reputation: 2626Reputation: 2626Reputation: 2626Reputation: 2626Reputation: 2626Reputation: 2626Reputation: 2626Reputation: 2626Reputation: 2626Reputation: 2626Reputation: 2626
The latest version of 3.x supports the new db format.
 
Old 02-13-2001, 06:30 PM   #3
Sinister
LQ Newbie
 
Registered: Feb 2001
Posts: 24

Rep: Reputation: 15
I'm not sure if that's true, I think only 3.0.5 works, but I could be wrong

ftp://ftp.suse.com/pub/suse/i386/7.0...0.5-0.i386.rpm

[Edited by Sinister on 02-13-2001 at 10:18 PM]
 
Old 03-04-2001, 11:50 PM   #4
webboss
Member
 
Registered: Feb 2001
Location: Badlapur, INDIA
Distribution: debian 6
Posts: 81

Rep: Reputation: 15
Question RPM upgrade problem

I too have installed RH Linux 6.1 And with most of the packages installation as well as while installing a new RPM 4.0.7 I get "this version of rpm only handles package version <=3" error when I give command
rpm -ivh rpm4.0.7.rpm
or
rpm -Uivh rpm4.0.7.rpm

Can any body suggest some remedy to this problem.
Thanks
 
Old 04-07-2001, 11:45 AM   #5
adam882001
LQ Newbie
 
Registered: Apr 2001
Posts: 1

Rep: Reputation: 0
Question How does one install RPM v4?

Hi there ugge

I too am having the same problem. I do hope that someone replies to you soon because I'm like a fish on a hook. I can't install anything because I can't figure out how do install the lastest RPM manager.

I dl the lastest rpm tarball and did the usually tar zxvf rpm-4.04.tar.gz and it goes happily along and does its thing but when i do a rpm --version is still says 3.0

What part of the procedure am I missing?
 
Old 04-09-2001, 12:43 AM   #6
webboss
Member
 
Registered: Feb 2001
Location: Badlapur, INDIA
Distribution: debian 6
Posts: 81

Rep: Reputation: 15
Re: How does one install RPM v4?

I upgraded to 6.2 version of RH Linux and my problem is solved now. Most of the newer versions of software can be installed properly now.
Also as adam882001 is having the same problem I will suggest him to upgrade to 3.0.5 version of rpm first then try higher of that and so on. It solves the problem of showing older version number.
Thanks.

Quote:
Originally posted by adam882001
Hi there ugge

I too am having the same problem. I do hope that someone replies to you soon because I'm like a fish on a hook. I can't install anything because I can't figure out how do install the lastest RPM manager.

I dl the lastest rpm tarball and did the usually tar zxvf rpm-4.04.tar.gz and it goes happily along and does its thing but when i do a rpm --version is still says 3.0

What part of the procedure am I missing?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing from rpm the_imax Linux - General 2 04-22-2005 05:53 PM
installing an RPM trempel Linux - Newbie 6 02-25-2005 02:03 AM
Installing from RPM the_imax Red Hat 1 01-10-2005 12:52 PM
installing from rpm zexter Linux - Software 4 11-02-2003 09:22 PM
installing with rpm darkstar518 Linux - Newbie 1 10-07-2003 07:56 PM


All times are GMT -5. The time now is 02:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration