LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-05-2003, 08:51 PM   #1
saidin
LQ Newbie
 
Registered: Feb 2003
Posts: 3

Rep: Reputation: 0
Question Installing ATI Drivers


I am trying to install the ati drivers. I am following the instructions that are on the ati site but I am gettting errors that I cannot figure out.
=====================================================================
ATI Technologies
=====================================================================
Checking which OS you're running...
uname reports 'Linux' version '2.4.20', architecture 'i686'.
Object format is 'ELF'.
libc version is '6.2'.

XFree86 Version 4.1.0.1 is installed.

Binary package name is 'fglrx-glibc22-X41.tgz'

That is what I have....(running the Check.sh)
==================================================
I follow all the directions for installing them, but at the last step
go to /lib/modules/fglrx and run ./make_install i get this error message I got:
- creating symlink
- recreating module dependency list
depmod: *** Unresolved symbols in /lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o
- trying a sample load of the kernel module
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol create_proc_entry_R4d0f06df
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol remove_proc_entry_R90c0e991
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol __free_pages_Rf11c193a
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol register_chrdev_Ra1cd9834
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol add_wait_queue_R541d9a1a
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol init_mm_R74806390
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol remove_wait_queue_R800c1721
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol zone_table_R3f71d1d1
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol unlock_page_Rd67c87e6
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol mem_map_Re67065c0
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: unresolved symbol _alloc_pages_R70ce3ed4
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: insmod /lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o failed
/lib/modules/2.4.20/kernel/drivers/char/drm/fglrx.o: insmod fglrx failed
failed.

Please hellp!!!!!
 
Old 02-06-2003, 04:13 AM   #2
Noerr
Member
 
Registered: May 2002
Location: Dalec, HU
Distribution: Redhat 7.3
Posts: 696

Rep: Reputation: 30
Check your "Hint" It says straightforward
 
Old 02-06-2003, 05:54 AM   #3
saidin
LQ Newbie
 
Registered: Feb 2003
Posts: 3

Original Poster
Rep: Reputation: 0
okay, well I am kind of new to the linux game. And why I understand some things clearly other things I am still working out....ie this problem here:

Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

I have no idea how to fix this problem with the hint given? Please help!
 
Old 02-06-2003, 06:05 AM   #4
Noerr
Member
 
Registered: May 2002
Location: Dalec, HU
Distribution: Redhat 7.3
Posts: 696

Rep: Reputation: 30
not much more to add to the the hint, I don't think you can fix it on your own if it is a GPL license problem, Read documentation with ATI and ask their support about it
 
Old 02-06-2003, 06:37 AM   #5
saidin
LQ Newbie
 
Registered: Feb 2003
Posts: 3

Original Poster
Rep: Reputation: 0
okay, well thank you for your help, but I do not understand why a driver would be released that would not work with the licsensing system . I must be doing something wrong in the install.
BTW: I am running Debian with a custom complied kernel (2.4.20)

Last edited by saidin; 02-06-2003 at 07:01 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing ati drivers morpheus83 Linux - Newbie 2 09-11-2005 04:32 PM
Installing ATI Drivers midgcool Linux - Software 5 12-04-2004 03:24 AM
Installing ATI drivers for X 4.3.0 Elliot Linux - Newbie 2 07-30-2004 03:23 AM
Installing ATI Drivers. black hole sun Linux - Software 13 07-28-2004 11:13 PM
Installing ATI GL drivers michael_mead Red Hat 2 09-04-2003 01:31 PM


All times are GMT -5. The time now is 04:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration