LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Installed nVidia, now everything is huge (http://www.linuxquestions.org/questions/linux-general-1/installed-nvidia-now-everything-is-huge-853657/)

hsiu 01-02-2011 01:01 AM

Installed nVidia, now everything is huge
 
EDIT, 3 January 2010: SOLVED: In fact, it was the fonts that were being rendered larger and pushing everything out. Altering DPI in xorg.conf solved the problem, see details at bottom.

ORIGINAL POST:

Hello,

I used jockey-kde to activate the nVidia (closed-source) driver in order to fix some full-screen problems I was having.

It has fixed that, but now everything is really big. I have my resolution set to 1680x1050 but it appears to be lower than it was before - the K menu, for instance, takes up about 1/6 of the screen when I open it. I took a screenshot here:

http://i.imgur.com/94lyN.jpg

I know this isn't much information, but can anyone tell me why - while the desktop appears to be larger with a higher resolution - applications are actually appearing as though the resolution is lower?

Larry Webb 01-02-2011 07:48 AM

The things on your desktop are staying at the same resolution. The higher you set your monitor resolution the smaller fixed size objects will appear. That is the reason we older people usually set our resolution at 1280 x 768. Look at it as a boat on a small pond or the same boat on the ocean.

hsiu 01-02-2011 01:20 PM

Well, that's why I don't understand why things are appearing _bigger_.

I have _in_creased the resolution to 1680x1050, and yet the stuff on my desktop, such as the K menu, now appears ridiculously _large_ - larger than before, when my screen resolution was set lower. It _should_ be the opposite way.

Larry Webb 01-02-2011 02:48 PM

I can not understand what you are trying to say.

pickarooney 01-02-2011 05:20 PM

It's hard to see the problem from the screenshot without a 'before' shot to compare with but the KMenu does look like it's needlessly large.

Does this help at all?
http://www.linuxquestions.org/questi...u-size-402558/

Drakeo 01-02-2011 05:44 PM

nvidia-xconfig or jockey to settings and click display and adjust it.

hsiu 01-03-2011 03:04 AM

I inactivated the nVidia driver and took another screenshot. On second look, it appears that what's really bigger is all the fonts. This is pushing everything out, including the KMenu, firefox tabs, etc.

http://i.imgur.com/rYzBQ.jpg

Does this give anybody an idea?

Quote:

Originally Posted by Larry Webb (Post 4210600)
I can not understand what you are trying to say.

Resolution, as used in the context of computer displays, is usually expressed as a ratio of display width in pixels to display height in pixels. When the resolution is increased, the available real-estate on the display is expected to also increase. Things - such as application windows - which used to take up a quarter of the screen might now only take up an 8th of the screen, because the fixed amount of pixels they require can be rendered in a smaller space.

I have _in_creased the resolution on my screen. The expected consequence of this is that things - such as application windows - should appear _smaller_. They should take up less of the desktop, as the desktop has been made bigger (in terms of it's dimensions as a matrix of pixels).

Nonetheless, in my particular case, increasing the resolution has made rendered objects appear bigger - the desktop has less open space than it did before. If you look at my screenshot, I think you'll see that things are much larger than they should be - in Amarok barely anything can be displayed (the first two letters of a song title, the list of artists in my library is probably half of what it should be) because everything is larger than it should be. When I login, the dots used to obscure the password don't even fit inside the textfield - the bottom quarter of the circle falls below the visible space. I am certain that this was not the case before.

I'm wondering what might have caused this, and how I can get my screen's real estate back. My resolution (as set in system settings > display and monitor) is 1680x1050 - a fairly high resolution that should give me a nice big desktop to work with. Instead, the desktop appears to be even smaller than it was before I installed this driver and upped the resolution. If I lower the resolution in this menu, as expected, the screen real-estate gets even less than it was before.

Quote:

Originally Posted by pickarooney

That may work for my Kmenu, but not the larger problem, unfortunately. Most things are still ludicrously large. Trying to read anything on the net, for example, is frustrating.

Quote:

Originally Posted by Drakeo
nvidia-xconfig or jockey to settings and click display and adjust it.

I didn't see anything in jockey to edit settings - only a single pane to select and activate/inactivate drivers.

I tried using vnidia-xconfig and nvidia-settings to no avail. As I said above, it seems like the font is what's bigger, and the bigger windows (or more crowded windows) are a consequence of that. Any idea why the fonts have gotten bigger, or how to set them smaller?

hsiu 01-03-2011 04:55 AM

Solved
 
Alright, after reading these links:

http://http.download.nvidia.com/XFre...ppendix-y.html
Specifying DPI for NVIDIA Cards

I was able to more or less solve the problem by editing my /etc/X11/xorg.conf, within Section "Monitor", and adding:
Code:

    Option        "UseEdidDpi" "FALSE"
    Option        "DPI" "100 x 100"

to force the DPI to 100 rather than letting it be calculated.

Using the formula (widthResolution ^ 2 + heightResolution ^ 2) / (screenDiameter), I should be able to get 128 DPI, though I don't know if that's a valid number and when I try setting DPI to 128, or 120, or 110 it doesn't work and goes back to the original one that was causing this in the first place. So, while 100 is not _quite_ as fine as it was originally, it's a big improvement and I'll stick with it for now.

Thank you all for your help!


All times are GMT -5. The time now is 07:14 PM.