LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Installation Failed (http://www.linuxquestions.org/questions/linux-general-1/installation-failed-385761/)

karunesh 11-23-2005 04:59 AM

Installation Failed
 
Hi All..

Today I was trying to install Gaim (gaim-1.5.0-0rh9.i386.rpm) on my notebook which is having CentOS 4.2 installed. When I run the RPM installtion I got the failed dependencies error..

Quote:

[root@ksnb]# rpm -ivh gaim-1.5.0-0rh9.i386.rpm
error: Failed dependencies:
libpspell-modules.so.1 is needed by gaim-1.5.0-0rh9.i386
libpspell.so.4 is needed by gaim-1.5.0-0rh9.i386
Then I downloded the RPM (pspell-0.12.2-16.1.i386.rpm) and tried installing this, but then there was another error..

Quote:

[root@ksnb]# rpm -ivh pspell-0.12.2-16.1.i386.rpm
warning: pspell-0.12.2-16.1.i386.rpm: V3 DSA signature: NOKEY, key ID 025e513b
Preparing... ########################################### [100%]
file /usr/bin/pspell-config from install of pspell-0.12.2-16.1 conflicts with file from package aspell-0.50.5-3.fc3
So now I am stuck what to do as aspell is already installed there and I can not remove this as it required by lots of other applications..

Quote:

[root@ksnb]# rpm -qa | grep spell
aspell-en-0.51-11
aspell-0.50.5-3.fc3
gtkspell-2.0.7-2
openoffice.org-spellcheck-2.0.0-3
gnome-spell-1.0.5-9
[root@ksnb]# rpm -e aspell
error: Failed dependencies:
libaspell.so.15 is needed by (installed) php-4.3.9-3.8.i386
libaspell.so.15 is needed by (installed) gtkspell-2.0.7-2.i386
libaspell.so.15 is needed by (installed) gnome-spell-1.0.5-9.i386
libaspell.so.15 is needed by (installed) kdelibs-3.3.1-3.11.i386
libaspell.so.15 is needed by (installed) gedit-2.8.1-4.i386
libpspell.so.15 is needed by (installed) php-4.3.9-3.8.i386
aspell >= 0.50 is needed by (installed) aspell-en-0.51-11.i386
So now how to proceed :scratch: ?. Any suggestions..

reddazz 11-23-2005 05:24 AM

Why don't you setup dags yum rpm repo?

karunesh 11-23-2005 05:47 AM

:(..I tried that but there is againn some error..

Quote:

[root@ksnb ~]# yum install gaim
Setting up Install Process
Setting up repositories
Cannot open/read repomd.xml file for repository: update
failure: repodata/repomd.xml from update: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from update: [Errno 256] No more mirrors to try.

reddazz 11-23-2005 06:49 AM

Ok, I have seen were your problem is. You are trying to install a Redhat 9 rpm on a newer distro and this may not work right. I installed CentOS 4.2 yesterday and it has a version of gaim that works fine, so why don't you use that. If you still want the latest version, download the source rpm and build it for your system.


All times are GMT -5. The time now is 12:40 PM.