LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-05-2013, 10:42 AM   #1
farfattou
Member
 
Registered: Oct 2011
Posts: 66

Rep: Reputation: Disabled
install ns2.33 under ubuntu 11.04


hi,
I'm trying to install ns2.33 under ubuntu 11.04 (I have already the ns2.34 installed)
I get this error:
ld: libotcl.so: hidden symbol `__stack_chk_fail_local' isn't defined
ld: final link failed: Bad value
make: *** [libotcl.so] Erreur 1
otcl-1.13 make failed! Exiting ...

any help plz
 
Old 02-05-2013, 10:54 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,622

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
Ns-allinone-2.33 :
Please use the "gcc41-compat / g++41-compat compiler for 11.04".

Post # 17 here
http://www.linuxquestions.org/questi...571/page2.html
→ sudo dpkg -i gcc41-compat-4.1.2_i386.deb g++41-compat-4.1.2_i386.deb
.. Then reboot, and the binaries gcc41, g++41 are ready for use.

You may have to start from scratch, if the gcc/g++ version 4.5 was used.
I.e.: tar xvf ns-allinone-2.33.tar.gz && export CC=g++41 CXX=g++41 && ./install

.. Or do a 'make clean' in tcl8*/unix/, tk8*/unix/, otcl*/,
and delete the Makefile's if still present.

-

Last edited by knudfl; 02-05-2013 at 10:58 AM.
 
Old 02-05-2013, 11:16 AM   #3
farfattou
Member
 
Registered: Oct 2011
Posts: 66

Original Poster
Rep: Reputation: Disabled
hi,
I already have the gcc41 and ...

now I have got this error:


/home/../ns-allinone-2.33./tcl8.4.18/unix/../generic/regc_locale.c:216: attention : ‘punctRangeTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:228: attention : ‘punctCharTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:242: attention : ‘spaceRangeTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:248: attention : ‘spaceCharTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:256: attention : ‘lowerRangeTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:269: attention : ‘lowerCharTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:316: attention : ‘upperRangeTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:329: attention : ‘upperCharTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:376: attention : ‘graphRangeTable’ defined but not used
/home/../ns-allinone-2.33/tcl8.4.18/unix/../generic/regc_locale.c:498: attention : ‘graphCharTable’ defined but not used
make: *** [regcomp.o] Erreur 1
tcl8.4.18 make failed! Exiting .


Last edited by farfattou; 02-05-2013 at 11:31 AM.
 
Old 02-05-2013, 11:58 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,622

Rep: Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527Reputation: 2527
#3 : Don't know. A corrupt 'ns-allinone-2.33.tar.gz' ? (Or a corrupt OS ?)
I have never seen errors at "tcl8.4.18 make".

.. And I get no errors in the required libraries on Ubuntu 11.04 with ...
tar xvf ns-allinone-2.33.tar.gz && export CC=g++41 CXX=g++41 && ./install

( Nam fails, but who cares, with already one 'nam' executable in /usr/local/bin/ ).

Did you start from scrath as suggested ?

-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install ns2 in ubuntu 11.10 miu Linux - Networking 20 10-31-2013 02:50 PM
how to install both ns2.28 and ns2.34 versions on ubuntu 10.04? popoaung Linux - Software 3 06-10-2013 04:52 PM
install ns2.34 on ubuntu 10.10 mohadeseh_mohammadi Linux - Newbie 4 10-24-2012 09:49 AM
how to install ns2 in ubuntu 12.04 beta ?? trpraveen Linux - Software 2 04-26-2012 08:53 AM
How to install ns2 2.33 in ubuntu 10.04 andolby Linux - Software 1 03-21-2011 10:48 PM


All times are GMT -5. The time now is 09:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration