LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Install cd doesn't find cd-rom or sata disks. (http://www.linuxquestions.org/questions/linux-general-1/install-cd-doesnt-find-cd-rom-or-sata-disks-653418/)

nio 07-03-2008 03:58 PM

Install cd doesn't find cd-rom or sata disks.
 
Intro:
So I'm very happy with my new pc, containing an Asus P5Q-E motherboard, with two sata harddrives and one pata dvd/cd drive attached to it.
Oh, and it's got the P45 chipset if you're interested.

The problem:
Installing Debian-based os'es from cd-rom results in one of the two scenario's:
1.) The installer gives the message "No common cd-rom drive was detected.", after which no further progress seems possible. It does detect the harddrives in this case, as I can see from the dmesg report. The dmesg does not show any detected cd-rom drives.
2.) The installer loads fine, until the partitioner arrives and can't find any harddrives at all. In this case dmesg indeed does not show any detected harddrives.

I've found and read literally dozens of webpages about this problem, but found no working solution for me yet.

It seems it has to do with the combination of sata, ide pata cd-rom drives, and newer hardware.
As posted in http://www.debianhelp.org/node/7048#comment-23928 :
"Several people have seen this problem because
some new motherboards are using some kind of SATA to IDE bridge that
leaves a CD unavailable between initial boot and the point when CD
drivers are later installed by the kernel. I think the installer falls
into the gap there and fails as a result.
"

So I end up with no mountable cd-rom but available harddrives, or the other way around.

What I've tried:
1.) Changed the BIOS SATA setting to Enhanced mode
2.) Changed the BIOS SATA setting to Compatible mode
3.) Tried cd's with Ubuntu 7.10, 8.04, 8.10(alpha), Debian Lenny Beta2, and a few other Debian-based distro's, all with the same results.
4.) manually loaded the ata_piix module before the install
5.) manually unloaded the ata_piix module before install
6.) Booted the installer in expert mode, which with no single distro allowed me to load or unload any ata related modules or in fact any module other than usb_storage.
7.) banged head against desk (didn't help)
8.) added "ata_piix.blacklist=yes" to the kernel parameters on boot
9.) ??? (forgot what else I've tried in the past 5 or so hours..)

All of these attempts had no noticable effect at all, the problem stayed the same.

So, any suggestions?
I hope it's still readable for you guys, I've tried to keep it clear..)

stress_junkie 07-03-2008 04:02 PM

How about using a SATA DVD drive? I put a new Samsung SATA DVD into a computer that I just built. I have a different chip set so I don't know if this will fix your problem. (Asus P5N-D with Nvidia chips)

nio 07-03-2008 04:09 PM

Quote:

Originally Posted by stress_junkie (Post 3203301)
How about purchasing a SATA DVD drive?

An (external) SATA or USB drive would probably help, yes, though it's not really a solution to the problem, more a workaround.

I'll go look for one tomorrow, as it's pretty handy for my other pc's and laptops as well.

Still, I've been spending hours on this problem and now I dangit want to fix it too, can't let such a problem get the better of me.. :)
That, and that there's probably dozens of others with the same problem as well..)

stress_junkie 07-03-2008 04:12 PM

Quote:

Originally Posted by nio (Post 3203308)
An (external) SATA or USB drive would probably help, yes, though it's not really a solution to the problem, more a workaround.

I say solution; you say workaround. In the end if it gets the machine running well then it's a good thing. :)

You could try upgrading the motherboard BIOS. My P5N-D was a bit flaky until I flashed the BIOS to the latest version. I got that off of the Asus web site.

nio 07-04-2008 07:28 PM

I just performed a Debian Lenny Beta2 install from a usb stick. It was remarkably easy. It didn't show the cd-rom in dmesg but I thought I'd solve that later.
Partitioning the harddrives and installing everything went fine, no problems at all.

Until I rebooted..
Now when I boot the pc, even when I select the harddrive to boot from, using F8, it just shows the blinking cursor on a black screen and that's it. No harddisk activity, no messages from any bootloader at all, just a blank screen..

So now one problem solved, on to the next, bwegh.

Anyway, I've read some 60 webpages about the cd-rom/sata problem today and made a list of possible solutions to that problem. I'll post it tomorrow. Maybe it will help someone with a similar problem.

For now it's time for bed, I've had enough of these stubborn computer problems for today.. :)

nio 07-05-2008 12:04 PM

As promised, the list of possible solutions I found:

- Run Live CD and use debootstrap?
http://www.debian-administration.org/articles/426
-- Debootsrap howto: http://www.debian-administration.org/articles/426
- Install from USB?
-- Debian: http://math.umh.ac.be/an/D820/
-- Debian: http://wiki.gacq.com/index.php/Debia...e_un_drive_USB
(very short)
-- Debian: http://www.debian.org/releases/stabl...h04s04.html.en
(just about as short, yet clear)
- AHCI module?
- Install via network?
- generic.all_generic_ide=1 boot parameter?
- (For Debian):
1 - boot:
expert BOOT_DEBUG=3

2 - In the shell:
nano /etc/modprobe.conf

add the line:
options libata atapi_enabled=1
save & quit
exit from the shell

3 - Continue the installation. After choosing your language and keyboard you
can go to the shell (Alt+F2) and verify that you CDROM is there:

cat /proc/scsi/scsi

-------------------------------
Found this in a bug report:
http://bugs.debian.org/cgi-bin/bugre...=345999;msg=75
- at boot: install libata.enableatapi=1 (only works for kernels
2.6.13 and above)
- at boot: install libata.atapi_enabled=1 (only works for kernels
2.6.13 and above)
- set SATA mode in BIOS to Enhanhed
- set SATA mode in BIOS to AHCI
- add noacpi to kernel parameters
- Map the SATA Devices to SATA0 and SATA1 in the BIOS, instead of IDE
- Upgrade BIOS
- Before cd detection: unload ata_piix and maybe others, load
(ide-)generic (ide_generic?), ide-cd and isofs. sata modules
will be loaded at a later stage.
- Add hdb=cdrom to kernel parameters?
- mount the cdrom manually with "mount /dev/cdroms/cdrom0 /cdrom/"
- try booting Lenny Beta1 with 'hw-detect/load-ide=true'
- add "irqpoll" (including quotes?) to kernel parameters
- add all-generic-ide irqpoll to kernel parameters

More info and solutions:
- http://www.thinkwiki.org/wiki/Proble...A_on_DVD_drive


I am most certain that there is actually a working boot record and OS installed on my drive now, so the problem that my system doesn't boot it must be something else.
When booting I see something with "no harddisk" flash by, so maybe that's it.

Either way, that's not what this topic is about so I won't bother you guys with that, for now..)

zipz 07-13-2008 06:55 PM

I have same motherboard as you. My SATA-DVD isn't found so I can't install either. I hope you find a solution to the problem :)

nio 07-14-2008 03:50 AM

Quote:

Originally Posted by zipz (Post 3213397)
I have same motherboard as you. My SATA-DVD isn't found so I can't install either. I hope you find a solution to the problem :)

To be honest, I haven't looked at this problem since I succesfully installed Debian using the two steps described at http://wiki.gacq.com/index.php/Debia...e_un_drive_USB .

But feel free to try the list of possible solutions I found and posted above. That list is the result of a few hours of browsing and searching the web and looking at about a hundred pages on this problem, so surely one of them must work..)


P.P. I have bought an external USB DVD drive casing, hooked it up to the computer and.. nothing. Dmesg doesn't even notice the darn thing. So if you're in a hurry and don't mind using Debian, I'd go for the USB stick solution, if that's an option. :)

zipz 07-14-2008 06:58 PM

Lennybeta2 found my SATA DVD and HD but it seems like there isn't any ethernet driver so I'm still stuck. It's Atheros GigaBit Lan on the motherboard.

willow_jones 07-28-2008 04:52 AM

Any kind of PC problems look in for PC Repair Experts have a look by yourself i hope you won't be disappointed because one of my friend referred me this site and by that time i am with this site and recommending others

mahesh.saga 07-28-2008 05:18 AM

hi nio,
i think ur cd has problem.
do one thing.
reboot the system and enter into the bios change the boot option to cd-rom.
save the changes.
try it.

T1000 08-24-2008 03:26 AM

Just bought myself a P5Q motherboard last week and having a similar problem with Ubuntu not seeing my SATA HD's. Don't have a SATA DVD though, just an IDE DVD.

For anyone interested, I found my answer on Wikipedia when looking up AHCI. Got my SATA HD's working without any problems... so far.

However, I still have the same problem as you, zipz, in that Linux doesn't recognise my Atheros GigaBit port either. No other information is discernible, either physically looking at the MB, reading the manual, looking in BIOS or otherwise.

Any ideas would be appreciated.

mahesh.saga 08-30-2008 03:11 AM

hi,
this is mahesh.
i faced this problem once.
but i solved that one.
i am saying what did i do to solve my problem.
so, follow this try in your machine,send me the result to saga.mahesh@gmail.com.

**press "del" key when your mahcine power on(switch on).it will show the boot order and select the "cd-rom" press "Enter(Return)".
if it will not work

**go to BIOS by pressing corresponding key(del,f1,f10..).and go to "Device COnfiguration" in "Storage Option" and select harddisk type(IDE/SATA) press (Enter/Return).then Select "Transaction Mode" is "Automatic" by using Arrow Buttons.
and press "del" key when your mahcine power on(switch on).it will show the boot order and select the "cd-rom" press "Enter(Return)".

i hope it will work properly.


bye,
Have a Nice Day,


Regards,
Mahesh Saga,

mahesh.saga 08-30-2008 03:11 AM

Solution
 
hi,
this is mahesh.
i faced this problem once.
but i solved that one.
i am saying what did i do to solve my problem.
so, follow this try in your machine,send me the result to saga.mahesh@gmail.com.

**press "del" key when your mahcine power on(switch on).it will show the boot order and select the "cd-rom" press "Enter(Return)".
if it will not work

**go to BIOS by pressing corresponding key(del,f1,f10..).and go to "Device COnfiguration" in "Storage Option" and select harddisk type(IDE/SATA) press (Enter/Return).then Select "Transaction Mode" is "Automatic" by using Arrow Buttons.
and press "del" key when your mahcine power on(switch on).it will show the boot order and select the "cd-rom" press "Enter(Return)".

i hope it will work properly.


bye,
Have a Nice Day,


Regards,
Mahesh Saga,

mahesh.saga 08-30-2008 03:12 AM

hi,
this is mahesh.
i faced this problem once.
but i solved that one.
i am saying what did i do to solve my problem.
so, follow this try in your machine,send me the result to saga.mahesh@gmail.com.

**press "del" key when your mahcine power on(switch on).it will show the boot order and select the "cd-rom" press "Enter(Return)".
if it will not work

**go to BIOS by pressing corresponding key(del,f1,f10..).and go to "Device COnfiguration" in "Storage Option" and select harddisk type(IDE/SATA) press (Enter/Return).then Select "Transaction Mode" is "Automatic" by using Arrow Buttons.
and press "del" key when your mahcine power on(switch on).it will show the boot order and select the "cd-rom" press "Enter(Return)".

i hope it will work properly.


bye,
Have a Nice Day,


Regards,
Mahesh Saga,


All times are GMT -5. The time now is 04:01 AM.