LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-15-2011, 07:52 AM   #1
Gerwar
LQ Newbie
 
Registered: Dec 2010
Location: Cancun
Distribution: Slackware 13.37-x86_64
Posts: 27

Rep: Reputation: 0
initializing run level 4 at inittab default level


hello everyone, im having a problem when my computer enters in the run level 4 as the default when i start slackware. The strange thing is that it not seems that is a X window problem, it looks like more like a configuration problem in some part of the kde script to initialize the log in, because if i manually start the X service it works fine, i dont know what is the source. Thank you in advance for the help.
 
Old 01-16-2011, 04:00 AM   #2
disturbed1
Senior Member
 
Registered: Mar 2005
Location: USA
Distribution: Slackware
Posts: 1,133
Blog Entries: 6

Rep: Reputation: 223Reputation: 223Reputation: 223
What exactly is it doing, not doing, and what is expected? Any logs? Error messages? My magic eightball told me to ask again later
Sometimes you can ctrl-alt-F1 to get to VT 1 and hopefully theres a tid bit of information spewed out for you.

Try restoring the default /etc/kde/kdm/* files. Perhaps you inadvertently changed one of those, and set an incompatible setting. I believe they are from the kdebase-workspace package (for KDE 4.x).
 
Old 01-17-2011, 09:36 AM   #3
Gerwar
LQ Newbie
 
Registered: Dec 2010
Location: Cancun
Distribution: Slackware 13.37-x86_64
Posts: 27

Original Poster
Rep: Reputation: 0
i will try to restore /etc/kde/kdm/* files, thank you for the advice.
What i like to archive is: when i start my linux distro (which is slackware 13) i would like to start from the beginning the X window environment, and to prompt me with the log-in window.
What is doing right now: it only appears a black screen and a flashing "_" character, if i try to change to the tty 6, it let me change there, and there isn't any problem, also if i want to startx from run level 3, there isn't any problem. The problem is that if i want to start from the beginning the run level 4 (by changing the /etc/inittab -> "...4:initdefault") nothing happen.
 
Old 01-17-2011, 04:38 PM   #4
Gerwar
LQ Newbie
 
Registered: Dec 2010
Location: Cancun
Distribution: Slackware 13.37-x86_64
Posts: 27

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by disturbed1 View Post
What exactly is it doing, not doing, and what is expected? Any logs? Error messages? My magic eightball told me to ask again later
Sometimes you can ctrl-alt-F1 to get to VT 1 and hopefully theres a tid bit of information spewed out for you.

Try restoring the default /etc/kde/kdm/* files. Perhaps you inadvertently changed one of those, and set an incompatible setting. I believe they are from the kdebase-workspace package (for KDE 4.x).
Ok i copy the files from the kdebas-workspace to the /etc/kde/kdm/ directory and the thing get worst it only freeze at at the last line wrote in the the terminal that runs kde, but again i can switch to another terminal (tty6). I manage to restore it when i was before, to the black screen with the "_" character flashing. It appears to be something related to other files, i dunno what could it be, i will keep trying different things.
 
  


Reply

Tags
inittab, kde, runlevel, slackware13, software


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
set your default run level so you will boot to a default run level - vga console Adam555 Linux - Newbie 1 01-21-2008 04:55 PM
Default Run Level custangro Solaris / OpenSolaris 4 05-01-2007 11:31 PM
emacs in run level 3 then switch to X (level 7) then back to level 3 dsoliver Slackware 3 09-01-2006 03:31 AM
Why Run Level 2 by Default? aquaboot Ubuntu 4 08-24-2005 07:50 PM
Setting default run level blacktempest07 Linux - Newbie 2 03-03-2004 12:47 AM


All times are GMT -5. The time now is 05:43 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration