LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-09-2008, 01:18 PM   #1
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Rep: Reputation: 51
Icewm: how to avoid the black screen to come after 15minutes?


Hi,

Then I have to press a key to reput the sort of blakc screen saver away...
Any ideas?

thanks !
Happy Tux
 
Old 09-09-2008, 01:56 PM   #2
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,977

Rep: Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672
Quote:
Originally Posted by frenchn00b View Post

Then I have to press a key to reput the sort of blakc screen saver away...
Any ideas?
Your 'question' makes no sense. Please try to write clearly. Are you asking as to why you have to press a key, to make the screen wake up after 15 minutes?

You probably have power-management turned on, which will put your monitor to sleep after 15 minutes or so. Pressing a key wakes it up. Either you can press the key, or disable that.
 
Old 09-09-2008, 02:25 PM   #3
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Original Poster
Rep: Reputation: 51
Quote:
Originally Posted by TB0ne View Post
Your 'question' makes no sense. Please try to write clearly. Are you asking as to why you have to press a key, to make the screen wake up after 15 minutes?

You probably have power-management turned on, which will put your monitor to sleep after 15 minutes or so. Pressing a key wakes it up. Either you can press the key, or disable that.
sorry
the X puts the monitor blakc, then I have to press a key to reactivate it
 
Old 09-09-2008, 02:50 PM   #4
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 14,977

Rep: Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672Reputation: 2672
Quote:
Originally Posted by frenchn00b View Post
sorry
the X puts the monitor blakc, then I have to press a key to reactivate it
Still not making sense. What "X puts the monitor blakc"??
 
Old 09-10-2008, 02:56 PM   #5
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Original Poster
Rep: Reputation: 51
I know

it is xset !!

please how to avoid xset to run in background?
I looked in google, but didnt find it

happy tux
 
Old 09-10-2008, 03:51 PM   #6
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Actually, it's an option in xorg called "DPMS". It has nothing to do with IceWM.

You change it by editing your /etc/X11/xorg.conf. You'll find a line in the Monitor section like this:

Option "DPMS"

Comment out this line by putting a "#" in front of it:

# Option "DPMS"

Then quit IceWM and restart X. If you're using a graphical login manager like GDM, then you can restart X with ctrl-alt-backspace.
 
Old 09-10-2008, 03:53 PM   #7
IsaacKuo
Senior Member
 
Registered: Apr 2004
Location: Baton Rouge, Louisiana, USA
Distribution: Debian 4.0 Etch
Posts: 1,349

Rep: Reputation: 49
Oh, the above assumes you are using Debian Etch. With Debian Lenny, I think the option "DPMS" is turned on by default even if there's no line in xorg.conf referencing it. For Lenny, I added a line like this:

Option "DPMS" "off"

...which seems to work. I think. I'm not as familiar with Lenny.
 
Old 09-16-2008, 01:55 PM   #8
frenchn00b
Senior Member
 
Registered: Jun 2007
Location: E.U., Mountains :-)
Distribution: Debian, Etch, the greatest
Posts: 2,546

Original Poster
Rep: Reputation: 51
Quote:
ot a strange question at all and it is completely possible. There is a utility called "xset" which is built for the purpose of tweaking X.

Quick list of what it does:
xset s Reset to standard settings
xset s 600 Activate after 10 minutes
xset s blank Use blank screen
xset s off Deactivate screensaver
xset s on Switch on screensaver
xset s activate Activate screensaver immediately
xset q Display current settings
xset +dpms Enable power saving
xset -dpms Disable power saving

So for you to enable:
CODE
xset +dpms
xset s on
xset s activate


And to disable:
CODE
xset s off
xset -dpms


You can use cron to enable at a time.. and disable at a time.
should work I guess
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen resolution not taking up the hole screen leaving black edges spaje Linux - Laptop and Netbook 9 04-01-2010 11:24 PM
Log in screen won-t show up, I get a black screen and mouse pinter on waiting mode Nis2k Linux - General 1 03-26-2008 10:32 PM
Booting CentOS 5, logo screen appears, stuff initializes, then screen goes black ctman Linux - Newbie 6 09-22-2007 09:36 AM
Help! Black screen instead of login screen! Intel integrated graphics coolblue Suse/Novell 10 05-03-2007 06:30 PM
XF86Config: how to avoid black frame : Suse 8.2 + new nvidia driver muellla Linux - Laptop and Netbook 3 08-09-2003 11:21 AM


All times are GMT -5. The time now is 05:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration