LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-12-2009, 09:15 AM   #1
ddeeks
LQ Newbie
 
Registered: May 2009
Posts: 11

Rep: Reputation: 0
I updated my Fedora 10 using YUM now I get ERROR with rpm_check_debug vs depsolve


FULL ERROR SHOWN BELOW:


ERROR with rpm_check_debug vs depsolve:
NetworkManager-vpnc conflicts with NetworkManager-1:0.7.1-1.fc10.i386
NetworkManager-openvpn conflicts with NetworkManager-1:0.7.1-1.fc10.i386
libnm-util.so.0 is needed by NetworkManager-vpnc-1:0.7.0-0.11.svn4229.fc10.i386
libnm-util.so.0 is needed by NetworkManager-openvpn-1:0.7.0-16.svn4229.fc10.i386
Please report this error at http://yum.baseurl.org/report

What do I do to resolve these conflicts?

Also I tried reporting this error to YUM but I could not find my way to the submission page!
 
Old 05-12-2009, 09:41 AM   #2
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
which repositories are you using?

Disable testing

# yum clean all

#yum update
 
Old 05-13-2009, 09:19 AM   #3
ddeeks
LQ Newbie
 
Registered: May 2009
Posts: 11

Original Poster
Rep: Reputation: 0
I ran:
#yum clean all
#yum update


Now getting error:


"Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
svnkit is needed by (installed) eclipse-svnkit-1.2.3-2.fc10.noarch
Not removing old transaction files"

See below:

[root@dt-nhibackup-08 ddeeks]# yum update
Loaded plugins: refresh-packagekit
fedora | 2.8 kB 00:00
fedora/primary_db | 6.6 MB 01:05
updates | 3.0 kB 00:00
updates/primary_db | 3.5 MB 00:26
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package NetworkManager.i386 1:0.7.1-1.fc10 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.1-1.fc10 set to be updated
---> Package NetworkManager-gnome.i386 1:0.7.1-1.fc10 set to be updated
---> Package alsa-utils.i386 0:1.0.20-1.fc10 set to be updated
---> Package anthy.i386 0:9100h-4.fc10 set to be updated
---> Package cups.i386 1:1.3.10-5.fc10 set to be updated
---> Package cups-libs.i386 1:1.3.10-5.fc10 set to be updated
---> Package curl.i386 0:7.19.4-5.fc10 set to be updated
---> Package libcurl.i386 0:7.19.4-5.fc10 set to be updated
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 1:0.7.0.99-1
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 1:0.7.0.99-1
--> Finished Dependency Resolution
1:NetworkManager-0.7.1-1.fc10.i386 from updates has depsolving problems
--> NetworkManager conflicts with NetworkManager-vpnc
1:NetworkManager-0.7.1-1.fc10.i386 from updates has depsolving problems
--> NetworkManager conflicts with NetworkManager-openvpn
Error: NetworkManager conflicts with NetworkManager-vpnc
Error: NetworkManager conflicts with NetworkManager-openvpn





This resulted in a error that I should run
#yum-complete-transaction

I ran this and got the output:


oot@dt-nhibackup-08 ddeeks]# yum-complete-transaction
Loaded plugins: refresh-packagekit
There are 2 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 74 elements left to run
Package xml-commons-resolver-1.1-2.14.fc10.i386 already installed and latest version
Package xerces-j2-2.7.1-10.2.fc10.i386 already installed and latest version
Package jakarta-commons-codec-1.3-9.4.fc10.i386 already installed and latest version
Package jakarta-oro-2.0.8-4.2.fc10.i386 already installed and latest version
Package regexp-1.5-2.2.fc10.i386 already installed and latest version
Package bcel-5.2-5.1.fc10.i386 already installed and latest version
Package jakarta-commons-digester-1.7-7.3.fc10.i386 already installed and latest version
Package 1:xmldb-api-0.1-0.2.20011111cvs.1.3.fc10.i386 already installed and latest version
Package 1:jakarta-commons-httpclient-3.1-0.3.fc10.i386 already installed and latest version
Package antlr-2.7.7-2.fc10.i386 already installed and latest version
Package ganymed-ssh2-210-6.fc9.i386 already installed and latest version
Package lucene-2.3.1-3.4.fc10.i386 already installed and latest version
Package jakarta-commons-el-1.0-9.4.fc10.i386 already installed and latest version
Package jakarta-commons-pool-1.3-10.5.fc10.i386 already installed and latest version
Package jakarta-commons-dbcp-1.2.1-11jpp.4.fc10.i386 already installed and latest version
Package lucene-contrib-2.3.1-3.4.fc10.i386 already installed and latest version
Package 1:xmldb-api-sdk-0.1-0.2.20011111cvs.1.3.fc10.i386 already installed and latest version
Package bsf-2.3.0-13.fc10.i386 already installed and latest version
Package 1:jakarta-commons-discovery-0.4-3.2.fc10.i386 already installed and latest version
Package jakarta-commons-launcher-1.1-2.4.fc10.i386 already installed and latest version
Package jdepend-2.6-7.4.fc10.i386 already installed and latest version
Package 1:jakarta-commons-fileupload-1.0-7.3.fc10.i386 already installed and latest version
Package libreadline-java-0.8.0-22.fc10.i386 already installed and latest version
Package ws-commons-util-1.0.1-10.fc10.i386 already installed and latest version
Package 1:hsqldb-1.8.0.10-1.fc10.i386 already installed and latest version
Package jzlib-1.0.7-5.3.fc10.i386 already installed and latest version
Package jakarta-commons-lang-2.3-2.3.fc10.i386 already installed and latest version
Package wsdl4j-1.5.2-5.4.fc10.i386 already installed and latest version
Package jsch-0.1.39-1.1.fc10.noarch already installed and latest version
Package ws-jaxme-0.5.1-2.4.fc10.noarch already installed and latest version
Package jakarta-commons-net-1.4.1-4.3.fc10.noarch already installed and latest version
Package objectweb-asm-3.1-5.1.fc10.noarch already installed and latest version
Package java-1.5.0-gcj-devel-1.5.0.0-23.fc10.i386 already installed and latest version
Package java-1.5.0-gcj-javadoc-1.5.0.0-23.fc10.i386 already installed and latest version
Package ant-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-nodeps-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-bsf-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-oro-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-resolver-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-log4j-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-commons-logging-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-bcel-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-regexp-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-junit-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-jsch-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-jdepend-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-trax-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-antlr-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-commons-net-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-javamail-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-swing-1.7.1-7.2.fc10.i386 already installed and latest version
Package axis-1.2.1-4.1.fc10.i386 already installed and latest version
Package 1:mx4j-3.0.1-7.8.fc10.i386 already installed and latest version
Package jakarta-commons-modeler-2.0-4.3.fc10.i386 already installed and latest version
Package geronimo-specs-1.0-2.M2.fc10.i386 already installed and latest version
Package geronimo-specs-compat-1.0-2.M2.fc10.i386 already installed and latest version
Package 1:mysql-connector-java-3.1.12-6.fc10.i386 already installed and latest version
Package jython-2.2.1-0.1.Release_2_2_1.1.2.fc10.i386 already installed and latest version
Package fedora-usermgmt-shadow-utils-0.10-2.fc10.noarch already installed and latest version
Package fedora-usermgmt-0.10-2.fc10.noarch already installed and latest version
Package jetty-5.1.14-1.6.fc10.i386 already installed and latest version
Package 1:eclipse-platform-3.4.1-5.fc10.i386 already installed and latest version
Package 1:eclipse-jdt-3.4.1-5.fc10.i386 already installed and latest version
Package 1:eclipse-cdt-5.0.1-2.fc10.i386 already installed and latest version
Package 1:eclipse-changelog-2.6.6-1.fc10.i386 already installed and latest version
Package eclipse-mylyn-3.0.3-3.fc10.noarch already installed and latest version
Package matching eclipse-subclipse-1.2.4-12.fc10.noarch already installed. Checking for update.
Package 1:eclipse-pydev-1.4.2-1.fc10.i386 already installed and latest version
Package eclipse-rpm-editor-0.4.0-5.fc10.i386 already installed and latest version
Package eclipse-mylyn-java-3.0.3-3.fc10.noarch already installed and latest version
Package 1:eclipse-pde-3.4.1-5.fc10.i386 already installed and latest version
--> Running transaction check
---> Package java_cup.i386 1:0.10k-1 set to be updated
---> Package sinjdoc.i386 0:0.5-7.fc10 set to be updated
---> Package svnkit.i386 0:1.1.4-4.fc10 set to be updated
--> Finished Dependency Resolution

===================================================================================================
Package Arch Version Repository Size
===================================================================================================
Installing:
java_cup i386 1:0.10k-1 fedora 175 k
sinjdoc i386 0.5-7.fc10 fedora 786 k
svnkit i386 1.1.4-4.fc10 fedora 2.3 M

Transaction Summary
===================================================================================================
Install 3 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 3.2 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): java_cup-0.10k-1.i386.rpm | 175 kB 00:01
(2/3): sinjdoc-0.5-7.fc10.i386.rpm | 786 kB 00:05
(3/3): svnkit-1.1.4-4.fc10.i386.rpm | 2.3 MB 00:15
---------------------------------------------------------------------------------------------------
Total 145 kB/s | 3.2 MB 00:22
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
svnkit is needed by (installed) eclipse-svnkit-1.2.3-2.fc10.noarch
Not removing old transaction files
 
Old 05-13-2009, 11:56 AM   #4
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,758

Rep: Reputation: Disabled
exclude eclipse-svnkit while doing the complete transaction ...

you may need to exclude a few more

see

#man yum
 
Old 05-13-2009, 01:55 PM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,595

Rep: Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677Reputation: 1677
did you by chance use "upgrade" from fedora 9 to 10 . that can cause all kinds of problems

also the full command to clean the yum and rpm database is this -- give it a try
Code:
su -
yum clean all 
rpm --rebuilddb
yum update
 
Old 05-13-2009, 02:59 PM   #6
ddeeks
LQ Newbie
 
Registered: May 2009
Posts: 11

Original Poster
Rep: Reputation: 0
appears to be a conflict

I ran the
#yum clean all
#yum rpm --rebuilddb
#yum update

The #yum update as shown below,
completed with errors with the same
error:


[root@dt-nhibackup-08 ddeeks]# yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.
--> Running transaction check
---> Package NetworkManager.i386 1:0.7.1-1.fc10 set to be updated
---> Package NetworkManager-glib.i386 1:0.7.1-1.fc10 set to be updated
---> Package NetworkManager-gnome.i386 1:0.7.1-1.fc10 set to be updated
---> Package alsa-utils.i386 0:1.0.20-1.fc10 set to be updated
---> Package anthy.i386 0:9100h-4.fc10 set to be updated
---> Package cups.i386 1:1.3.10-5.fc10 set to be updated
---> Package cups-libs.i386 1:1.3.10-5.fc10 set to be updated
---> Package curl.i386 0:7.19.4-5.fc10 set to be updated
---> Package libcurl.i386 0:7.19.4-5.fc10 set to be updated
--> Processing Conflict: NetworkManager conflicts NetworkManager-openvpn < 1:0.7.0.99-1
--> Processing Conflict: NetworkManager conflicts NetworkManager-vpnc < 1:0.7.0.99-1
--> Finished Dependency Resolution
1:NetworkManager-0.7.1-1.fc10.i386 from updates has depsolving problems
--> NetworkManager conflicts with NetworkManager-vpnc
1:NetworkManager-0.7.1-1.fc10.i386 from updates has depsolving problems
--> NetworkManager conflicts with NetworkManager-openvpn
Error: NetworkManager conflicts with NetworkManager-vpnc
Error: NetworkManager conflicts with NetworkManager-openvpn
[root@dt-nhibackup-08 ddeeks]# yum-complete-transaction
Loaded plugins: refresh-packagekit
There are 2 outstanding transactions to complete. Finishing the most recent one
The remaining transaction had 74 elements left to run
Package xml-commons-resolver-1.1-2.14.fc10.i386 already installed and latest version
Package xerces-j2-2.7.1-10.2.fc10.i386 already installed and latest version
Package jakarta-commons-codec-1.3-9.4.fc10.i386 already installed and latest version
Package jakarta-oro-2.0.8-4.2.fc10.i386 already installed and latest version
Package regexp-1.5-2.2.fc10.i386 already installed and latest version
Package bcel-5.2-5.1.fc10.i386 already installed and latest version
Package jakarta-commons-digester-1.7-7.3.fc10.i386 already installed and latest version
Package 1:xmldb-api-0.1-0.2.20011111cvs.1.3.fc10.i386 already installed and latest version
Package 1:jakarta-commons-httpclient-3.1-0.3.fc10.i386 already installed and latest version
Package antlr-2.7.7-2.fc10.i386 already installed and latest version
Package ganymed-ssh2-210-6.fc9.i386 already installed and latest version
Package lucene-2.3.1-3.4.fc10.i386 already installed and latest version
Package jakarta-commons-el-1.0-9.4.fc10.i386 already installed and latest version
Package jakarta-commons-pool-1.3-10.5.fc10.i386 already installed and latest version
Package jakarta-commons-dbcp-1.2.1-11jpp.4.fc10.i386 already installed and latest version
Package lucene-contrib-2.3.1-3.4.fc10.i386 already installed and latest version
Package 1:xmldb-api-sdk-0.1-0.2.20011111cvs.1.3.fc10.i386 already installed and latest version
Package bsf-2.3.0-13.fc10.i386 already installed and latest version
Package 1:jakarta-commons-discovery-0.4-3.2.fc10.i386 already installed and latest version
Package jakarta-commons-launcher-1.1-2.4.fc10.i386 already installed and latest version
Package jdepend-2.6-7.4.fc10.i386 already installed and latest version
Package 1:jakarta-commons-fileupload-1.0-7.3.fc10.i386 already installed and latest version
Package libreadline-java-0.8.0-22.fc10.i386 already installed and latest version
Package ws-commons-util-1.0.1-10.fc10.i386 already installed and latest version
Package 1:hsqldb-1.8.0.10-1.fc10.i386 already installed and latest version
Package jzlib-1.0.7-5.3.fc10.i386 already installed and latest version
Package jakarta-commons-lang-2.3-2.3.fc10.i386 already installed and latest version
Package wsdl4j-1.5.2-5.4.fc10.i386 already installed and latest version
Package jsch-0.1.39-1.1.fc10.noarch already installed and latest version
Package ws-jaxme-0.5.1-2.4.fc10.noarch already installed and latest version
Package jakarta-commons-net-1.4.1-4.3.fc10.noarch already installed and latest version
Package objectweb-asm-3.1-5.1.fc10.noarch already installed and latest version
Package java-1.5.0-gcj-devel-1.5.0.0-23.fc10.i386 already installed and latest version
Package java-1.5.0-gcj-javadoc-1.5.0.0-23.fc10.i386 already installed and latest version
Package ant-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-nodeps-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-bsf-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-oro-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-resolver-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-log4j-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-commons-logging-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-bcel-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-apache-regexp-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-junit-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-jsch-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-jdepend-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-trax-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-antlr-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-commons-net-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-javamail-1.7.1-7.2.fc10.i386 already installed and latest version
Package ant-swing-1.7.1-7.2.fc10.i386 already installed and latest version
Package axis-1.2.1-4.1.fc10.i386 already installed and latest version
Package 1:mx4j-3.0.1-7.8.fc10.i386 already installed and latest version
Package jakarta-commons-modeler-2.0-4.3.fc10.i386 already installed and latest version
Package geronimo-specs-1.0-2.M2.fc10.i386 already installed and latest version
Package geronimo-specs-compat-1.0-2.M2.fc10.i386 already installed and latest version
Package 1:mysql-connector-java-3.1.12-6.fc10.i386 already installed and latest version
Package jython-2.2.1-0.1.Release_2_2_1.1.2.fc10.i386 already installed and latest version
Package fedora-usermgmt-shadow-utils-0.10-2.fc10.noarch already installed and latest version
Package fedora-usermgmt-0.10-2.fc10.noarch already installed and latest version
Package jetty-5.1.14-1.6.fc10.i386 already installed and latest version
Package 1:eclipse-platform-3.4.1-5.fc10.i386 already installed and latest version
Package 1:eclipse-jdt-3.4.1-5.fc10.i386 already installed and latest version
Package 1:eclipse-cdt-5.0.1-2.fc10.i386 already installed and latest version
Package 1:eclipse-changelog-2.6.6-1.fc10.i386 already installed and latest version
Package eclipse-mylyn-3.0.3-3.fc10.noarch already installed and latest version
Package matching eclipse-subclipse-1.2.4-12.fc10.noarch already installed. Checking for update.
Package 1:eclipse-pydev-1.4.2-1.fc10.i386 already installed and latest version
Package eclipse-rpm-editor-0.4.0-5.fc10.i386 already installed and latest version
Package eclipse-mylyn-java-3.0.3-3.fc10.noarch already installed and latest version
Package 1:eclipse-pde-3.4.1-5.fc10.i386 already installed and latest version
--> Running transaction check
---> Package java_cup.i386 1:0.10k-1 set to be updated
---> Package sinjdoc.i386 0:0.5-7.fc10 set to be updated
---> Package svnkit.i386 0:1.1.4-4.fc10 set to be updated
--> Finished Dependency Resolution

================================================================================
Package Arch Version Repository Size
================================================================================
Installing:
java_cup i386 1:0.10k-1 fedora 175 k
sinjdoc i386 0.5-7.fc10 fedora 786 k
svnkit i386 1.1.4-4.fc10 fedora 2.3 M

Transaction Summary
================================================================================
Install 3 Package(s)
Update 0 Package(s)
Remove 0 Package(s)

Total download size: 3.2 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): java_cup-0.10k-1.i386.rpm | 175 kB 00:00
(2/3): sinjdoc-0.5-7.fc10.i386.rpm | 786 kB 00:04
(3/3): svnkit-1.1.4-4.fc10.i386.rpm | 2.3 MB 00:17
--------------------------------------------------------------------------------
Total 133 kB/s | 3.2 MB 00:24
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
svnkit is needed by (installed) eclipse-svnkit-1.2.3-2.fc10.noarch
Not removing old transaction files
 
  


Reply

Tags
error


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Yum giving ERROR with rpm_check_debug vs depsolve repeatedly ajaygoeslinux Linux - Software 5 05-10-2009 10:15 AM
Updated Fedora 9 And I Now Get A Yum Error jc_cpu Linux - Software 2 12-13-2008 03:48 PM
YUM haven't updated for a month? guest Linux - Newbie 1 03-31-2005 06:31 PM
FC2 yum updated to 2.1.11 need new yum.conf? peregrine2 Linux - Newbie 1 12-02-2004 07:14 AM


All times are GMT -5. The time now is 09:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration