LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   I seem to be able to make new LVM-partitions. (http://www.linuxquestions.org/questions/linux-general-1/i-seem-to-be-able-to-make-new-lvm-partitions-4175421576/)

kevinbenko 08-11-2012 12:00 PM

I seem to be able to make new LVM-partitions.
 
I seem to be able to make new LVM-partitions.

I have already used duckduckgo and google and have failed to my particular problem. I have been using LVM since 2006, and have never seem this particular error, and I have already made several LVM-partitions. I have been making a simple LVM-partiton.

I am using:

"lvcreate LVM+group --size 10G --name somename"

The LVM-partition is created, but I unable to create (format) a new partition.

The error involved:

"failed to set a proper state for notification by cookie value ${decimal and octal values} to initialize waiting for incoming notification"

I have also seen the following error:

"command failed with status code 5"

That you for any available error or fix.

deadeyes 08-12-2012 07:50 AM

Was "lvcreate LVM+group --size 10G --name somename" the literal command you used?

Could you paste output of lvs?

kevinbenko 08-12-2012 08:36 AM

command line
 
the actual command was:

lvcreate LVM+group --size 10G --name pirate

deadeyes 08-13-2012 06:34 AM

Quote:

Originally Posted by kevinbenko (Post 4752287)
the actual command was:

lvcreate LVM+group --size 10G --name pirate

Maybe some issue with the + you use in the VG name?
You could try using quotes

kevinbenko 08-13-2012 07:56 AM

Except that written, the lvcreate command string has always worked before.
It seems to me that something has broken LVM, and we need to fix the underlying problem:

"command failed with status code 5"
and
"failed to set a proper state for notification by cookie value ${decimal and octal values} to initialize waiting for incoming notification"

---------- Post added 2012-08-13 at 05:56 ----------

Except that written, the lvcreate command string has always worked before.
It seems to me that something has broken LVM, and we need to fix the underlying problem:

"command failed with status code 5"
and
"failed to set a proper state for notification by cookie value ${decimal and octal values} to initialize waiting for incoming notification"

deadeyes 08-14-2012 03:53 AM

What you could try is using the -v(vv) switch to give extra verbosity.
That might shed some light on this.


All times are GMT -5. The time now is 08:15 AM.