LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-24-2002, 10:45 AM   #1
Vlad_M
Member
 
Registered: Aug 2002
Location: Cape Town, South Africa
Distribution: Red Hat 8.0 (Home), Red Hat 8.0 (Work)
Posts: 388

Rep: Reputation: 30
I know I am lazy but...


Can someone tell me in short what I need to do to enable my machine at work to accept ssh logins? At the moment I can not log in from anywhere else, it just says connection refused. I am using RH7.3, and I didn't configure any firewalls or anything, although I may be going through a firewall of the university. I am pretty sure that it is a local setting on the machine though. Where would it be?
 
Old 09-24-2002, 10:52 AM   #2
nxny
Member
 
Registered: May 2002
Location: AK - The last frontier.
Distribution: Red Hat 8.0, Slackware 8.1, Knoppix 3.7, Lunar 1.3, Sorcerer
Posts: 771

Rep: Reputation: 30
ps -ax | grep sshd

If sshd is not running, do a
/etc/rc.d/init.d/sshd start
or even
service sshd start

see man pages of sshd and sshd_config. It is amazingly well-documented.
 
Old 09-24-2002, 10:56 AM   #3
born4linux
Senior Member
 
Registered: Sep 2002
Location: Philippines
Distribution: Slackware, RHEL&variants, AIX, SuSE
Posts: 1,127

Rep: Reputation: 49
check your connection first. ping your remote machine and see if your local machine can reach the remote one. It is possible that the firewall is blocking all incoming connections to your remote machine.
 
Old 09-24-2002, 12:48 PM   #4
Vlad_M
Member
 
Registered: Aug 2002
Location: Cape Town, South Africa
Distribution: Red Hat 8.0 (Home), Red Hat 8.0 (Work)
Posts: 388

Original Poster
Rep: Reputation: 30
I did that already, it was also my first thought. But I can ping the machine no problem, so it is the way that my machine is configured that is blocking all the ssh connections.

Any idea where I can change that?
 
Old 09-24-2002, 01:46 PM   #5
NSKL
Senior Member
 
Registered: Jan 2002
Location: Rome, Italy ; Novi Sad, Srbija; Brisbane, Australia
Distribution: Ubuntu / ITOS2008
Posts: 1,207

Rep: Reputation: 46
Edit /etc/hosts.allow and hosts.deny. If you know what you are doing then you can put ALL:ALL in hosts.deny and add SSHD:<yourhost> to hosts.allow or else, if you are not sure then leave hosts deny how it is and just edit hosts.allow adding your IP to SSHD. or just ALL:<yourhost> to be able to access all services form <yourhost>
There are man pages for these files as well i beleive.
Hope that helps
-NSKL
 
Old 09-24-2002, 04:00 PM   #6
Vlad_M
Member
 
Registered: Aug 2002
Location: Cape Town, South Africa
Distribution: Red Hat 8.0 (Home), Red Hat 8.0 (Work)
Posts: 388

Original Poster
Rep: Reputation: 30
Thanks mate, will try it tomorrow, I have left the office already. I'll let you know what happens.

Cheers.
 
Old 09-24-2002, 04:47 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,974
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Quote:
Originally posted by Vlad_M
I did that already, it was also my first thought. But I can ping the machine no problem, so it is the way that my machine is configured that is blocking all the ssh connections.

Any idea where I can change that?
Gidday!

Check whether your xinetd has ssh enabled = true :}

Cheers,
Tink

p.s.: Redhat and Mandrake suck :}
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Does Debian make you lazy? R00ts Debian 7 09-27-2005 09:11 PM
Lazy 2nd CPU circusbug Linux - Hardware 5 06-19-2005 01:19 AM
Stupid and lazy questions... againstms Linux - Newbie 2 01-18-2005 07:44 AM
What's so great about grekellm (too lazy to look up spelling) Squall Linux - Software 3 04-20-2004 08:41 AM
Boy, am I the lazy one; even in Linux! Seph64 General 2 03-28-2003 03:06 AM


All times are GMT -5. The time now is 09:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration