LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 07-17-2004, 05:05 PM   #1
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
i have no /dev/hdc or /dev/hdd


hey guys.

whats the module i have to modporbe to get ide CD drives to show up in /dev/ ?

i have IDE cd-roms attached to secondry slave, and secondry master.

i know my kernel supports them, but they dont seem to be there.

or is my problem the /dev/make_devices script ?

Quote:
chris@lfs:~$ find /lib/modules/2.6.7/ | grep cdrom
chris@lfs:~$ find /lib/modules/2.6.7/ | grep ide
/lib/modules/2.6.7/kernel/drivers/video
/lib/modules/2.6.7/kernel/drivers/video/console
/lib/modules/2.6.7/kernel/drivers/video/console/mdacon.ko
/lib/modules/2.6.7/kernel/drivers/video/riva
/lib/modules/2.6.7/kernel/drivers/video/riva/rivafb.ko
/lib/modules/2.6.7/kernel/drivers/video/sis
/lib/modules/2.6.7/kernel/drivers/video/sis/sisfb.ko
/lib/modules/2.6.7/kernel/drivers/video/vga16fb.ko
/lib/modules/2.6.7/kernel/drivers/video/vgastate.ko
/lib/modules/2.6.7/kernel/drivers/video/nvidia.ko
/lib/modules/2.6.7/kernel/drivers/media/video
/lib/modules/2.6.7/kernel/drivers/media/video/v4l1-compat.ko
/lib/modules/2.6.7/kernel/drivers/media/video/v4l2-common.ko
/lib/modules/2.6.7/kernel/drivers/media/video/videodev.ko
if i do need a kernel module, i cant find it

im using the same kernel version and config i used to compile for slackware 10, which worked perfectly...

(ohh, forgot to mention, im working on a little known distro called LFS)

Last edited by qwijibow; 07-17-2004 at 05:08 PM.
 
Old 07-17-2004, 06:15 PM   #2
avarus
Member
 
Registered: Apr 2004
Location: Oxford, UK
Distribution: Ubuntu, Debian, various
Posts: 230
Blog Entries: 5

Rep: Reputation: 32
And dmesg says what?
 
Old 07-17-2004, 10:35 PM   #3
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
oh yeah... dmesg says exactly what is has always done....

Quote:
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
SIS5513: IDE controller at PCI slot 0000:00:02.5
SIS5513: chipset revision 208
SIS5513: not 100% native mode: will probe irqs later
SIS5513: SiS735 ATA 100 (2nd gen) controller
ide0: BM-DMA at 0xff00-0xff07, BIOS settings: hdaMA, hdbMA
ide1: BM-DMA at 0xff08-0xff0f, BIOS settings: hdcMA, hddMA
hda: FUJITSU MPB3064ATU E, ATA DISK drive
hdb: ST36421A, ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
hdc: HITACHI DVD-ROM GD-2500, ATAPI CD/DVD-ROM drive
hdd: SAMSUNG CD-R/RW SW-408B, ATAPI CD/DVD-ROM drive
hdd: set_drive_speed_status: status=0x51 { DriveReady SeekComplete Error }
hdd: set_drive_speed_status: error=0x04
ide1 at 0x170-0x177,0x376 on irq 15
hda: max request size: 128KiB
hda: 12672450 sectors (6488 MB), CHS=13410/15/63, UDMA(33)
hda: hda1 hda2
hdb: max request size: 128KiB
hdb: 12596850 sectors (6449 MB) w/256KiB Cache, CHS=13330/15/63, UDMA(33)
hdb: hdb1
hdc: ATAPI 24X DVD-ROM drive, 512kB Cache, DMA
Uniform CD-ROM driver Revision: 3.20
hdd: ATAPI 32X CD-ROM CD-R/RW drive, 2048kB Cache, DMA
ide-floppy driver 0.99.newide
hdc and hdd apear to be detected correctly.
the driver is compiled into the kernel (not as a module)

i cant work out whats wrong
 
Old 07-18-2004, 06:25 AM   #4
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Original Poster
Rep: Reputation: 47
ahh, the cd section was hashed out in my dake_devices script.
i unhashed and re-ran it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mount /dev/hdc /dev/cdrom doesn't work ShrikesHarvest Linux - Newbie 10 02-21-2009 08:05 AM
I cannot access EITHER CD drive! And there's no /dev/hdc or /dev/hdd or /dev/cdrom! Dmalic Linux - Hardware 13 11-18-2005 08:11 PM
ln: creating symbolic link `/dev/dvd' to `/dev/hdc': Permission denied qazwsx27 Fedora 3 06-14-2005 03:09 PM
no /dev/hdc or /dev/cdrom bobr Linux - General 3 02-18-2005 11:30 AM
/dev/cdrom & /dev/hdc missing! Lord_Devi Slackware 4 06-25-2004 10:17 AM


All times are GMT -5. The time now is 04:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration