LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-21-2003, 02:10 AM   #1
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Rep: Reputation: 45
I get mount: /dev/cdrom: can't read superblock, How to fix?


Hi guys, I know it must be some dumb mistake I did, but when I'm trying to mount my drives, they say

mount: /dev/cdrom: can't read superblock

I just compiled my new 2.4.21 kernel, how can I fix this?

thanks for the help,
 
Old 08-21-2003, 03:33 AM   #2
kev82
Senior Member
 
Registered: Apr 2003
Location: Lancaster, England
Distribution: Debian Etch, OS X 10.4
Posts: 1,263

Rep: Reputation: 50
have you got isofs built into the kernel or as a module, if its a module try modprobing it before you mount, also might be worth a check where /dev/cdrom points to
 
Old 08-21-2003, 03:40 AM   #3
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Original Poster
Rep: Reputation: 45
ehmm, well, it works with my previous kernel, why won't it work with this one?, did I forget something, or what?

I'll check the isofs thing, thanks.
 
Old 08-21-2003, 03:44 AM   #4
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Original Poster
Rep: Reputation: 45
yes, ISO file system for CD-ROM's is built into the kernel.

what can I do next?, need more help, thank you
 
Old 08-21-2003, 04:03 AM   #5
kev82
Senior Member
 
Registered: Apr 2003
Location: Lancaster, England
Distribution: Debian Etch, OS X 10.4
Posts: 1,263

Rep: Reputation: 50
does the output of cat /proc/filesystems contain either isofs or iso9660
 
Old 08-21-2003, 10:59 AM   #6
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Original Poster
Rep: Reputation: 45
OKay, I did that command, and YES, it is in there man. Thanks, any other thoughts?


cat /proc/filesystems
nodev rootfs
nodev bdev
nodev proc
nodev sockfs
nodev tmpfs
nodev shm
nodev pipefs
nodev binfmt_misc
ext3
ext2
cramfs
nodev ramfs
minix
msdos
msdos
vfat
iso9660
vxfs
nodev nfs
ntfs
efs
nodev autofs
nodev devpts
nodev usbdevfs
nodev usbfs
 
Old 08-21-2003, 11:03 AM   #7
kev82
Senior Member
 
Registered: Apr 2003
Location: Lancaster, England
Distribution: Debian Etch, OS X 10.4
Posts: 1,263

Rep: Reputation: 50
what does your /etc/fstab say? specifically the line with /mnt/cdrom in it?
 
Old 08-21-2003, 11:15 AM   #8
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Original Poster
Rep: Reputation: 45
here's the Fstab:

LABEL=/ / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
none /dev/pts devpts gid=5,mode=620 0 0
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
/dev/hda5 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0
/dev/cdrom1 /mnt/cdrom1 iso9660 noauto,owner,kudzu,ro 0 0
 
Old 08-21-2003, 11:21 AM   #9
Mathieu
Senior Member
 
Registered: Feb 2001
Location: Montreal, Quebec, Canada
Distribution: RedHat, Fedora, CentOS, SUSE
Posts: 1,403

Rep: Reputation: 46
zLinuxz,
Are you getting the same errors you were getting when you posted this thread ?
...... just kidding

(For those you want to understand this joke, refer to this thread.
http://www.linuxquestions.org/questi...threadid=84028
)

I had a similar problem where my two NICs were switched when I recompiled my kernel.
Perhaps something similar occurred with your CD-ROMs.

Did you check the /dev/cdrom and the /dev/cdrom1 soft links to make sure they point to the correct devices.

Last edited by Mathieu; 08-21-2003 at 11:23 AM.
 
Old 08-21-2003, 11:27 AM   #10
zLinuxz
Senior Member
 
Registered: Feb 2002
Location: Shanghai, CHINA
Distribution: RH 5.0,5.1 6.0,6.1 7.0,7.1,7.2,7.3.,8.0,9.0, RH Enterprise, Fedora C1, C2
Posts: 1,216

Original Poster
Rep: Reputation: 45
hey, hehhe,
yes, I did, and I even tried mounting them directly from /dev to /mnt, and still I get the Can't read SuperBlock error....it's frustating,

zLinuxz
 
Old 08-21-2003, 11:38 AM   #11
kev82
Senior Member
 
Registered: Apr 2003
Location: Lancaster, England
Distribution: Debian Etch, OS X 10.4
Posts: 1,263

Rep: Reputation: 50
i have pretty much no expertise with scsi so i'll end my contribution to this thread with this silly question: have you tried other cd's in the drive, cos it could be scratched cd?
 
Old 08-21-2003, 02:07 PM   #12
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
Hmm... Try it by not using the symlinks...

Find out if the cdrom drive is hdc, hdd, hde, whatever...

mount -t iso9660 /dev/hdc /mnt/cdrom

Are you getting specifically, "can't read superblock"
or is it the usual
"bad superblock, too many filesystems mounted, or wrong filesystem" etc... ?

You're sure the drive is OK, right? If not, try booting from a bootable cd and see what happens.

-Shade
 
Old 06-18-2008, 02:42 AM   #13
Drone4four
Member
 
Registered: Feb 2006
Distribution: Ubuntu, Slackware. Gentoo
Posts: 188

Rep: Reputation: 30
I'm trying to mount my DVD drive to /dvdrom. I tried the commands prescribed to zLinuxz. Here is the error message I get:

Code:
bash-3.1# mkdir /dvdrom
bash-3.1# mount -t iso9660 /dev/hdc /dvdrom
mount: block device /dev/hdc is write-protected, mounting read-only
mount: wrong fs type, bad option, bad superblock on /dev/hdc,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so
And here is dmesg |tail as the above error message suggests:

Code:
bash-3.1# dmesg | tail
hdc: command error: status=0x51 { DriveReady SeekComplete Error }
hdc: command error: error=0x54 { AbortedCommand LastFailedSense=0x05 }
ide: failed opcode was: unknown
ATAPI device hdc:
  Error: Illegal request -- (Sense key=0x05)
  Illegal mode for this track or incompatible medium -- (asc=0x64, ascq=0x00)
  The failed "Read 10" packet command was: 
  "28 00 00 00 00 10 00 00 01 00 00 00 00 00 00 00 "
end_request: I/O error, dev hdc, sector 64
isofs_fill_super: bread failed, dev=hdc, iso_blknum=16, block=16
bash-3.1# exit
exit
bash-3.1$
Here is my fstab:

Code:
/dev/hda5        swap             swap        defaults         0   0
/dev/hda1        /                ext3        defaults         1   1
/dev/hdb1        /home/ntfs       ntfs-3g     umask=000        1   0
/dev/cdrom      /mnt/cdrom       auto        noauto,owner,ro  0   0
/dev/fd0         /mnt/floppy      auto        noauto,owner     0   0
devpts           /dev/pts         devpts      gid=5,mode=620   0   0
proc             /proc            proc        defaults         0   0
tmpfs            /dev/shm         tmpfs       defaults         0   0
Here are the contents of /mnt/cdrom:

Code:
bash-3.1# cd /mnt/cdrom
bash-3.1# ls
bash-3.1# exit 
exit
bash-3.1$
Here is mount if interested:

Code:
bash-3.1# mount
/dev/hda1 on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hdb1 on /home/ntfs type fuseblk (rw,nosuid,nodev,noatime,allow_other,blksize=4096)
tmpfs on /dev/shm type tmpfs (rw)
bash-3.1#
I installed a new PSU, which means I was playing with the power cord connected to the DVD rom bay, however the bay opens and closes easily, allowing me to insert and audio disk.

I am btw running Slackware 12.1 stock kernel.

Last edited by Drone4four; 06-18-2008 at 02:44 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error mounting ext3 filesystem... mount: /dev/hdd1: can't read superblock versaulis Linux - Software 5 11-26-2006 08:34 PM
mount: /dev/cdrom: can't read superblock raynmune Linux - Hardware 7 07-09-2005 04:02 PM
mount: wrong fs type, bad option, bad superblock on /dev/cdrom, Adil_uk Linux - Hardware 9 02-16-2005 05:50 PM
/dev/sda1 - 'Can't read superblock' dickmobbis Fedora 1 12-02-2004 04:06 PM
...bad superblock on /dev/cdrom ... waxiem Linux - Newbie 1 02-26-2003 08:20 AM


All times are GMT -5. The time now is 06:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration