LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-09-2004, 11:38 AM   #1
alaios
Senior Member
 
Registered: Jan 2003
Location: Aachen
Distribution: Opensuse 11.2 (nice and steady)
Posts: 2,133

Rep: Reputation: 45
Exclamation i don't want the login program


Hi! I have a program (called zebra).
When i need to execute it i only write "telnet localhost 2601" and the login prompt appears...
I want instead of the classic login prompt in my slack distro the zebra's login prompt to appear.......
I have tried the following command as the agetty's manual says
agetty -n - l "telnet localhost 2601" 38400 tty2

The problem i face is that the second console... shows nothing at all. I can write what i want but there is no answer for the zebra program,...
can u suggest me something?
I was searching for some documentation in the google but i haven't find something interesting at all.
Canu suggest me something?
BTW: If i put the speed below or above 38400 what will that inflict?
Thx
 
Old 08-09-2004, 01:04 PM   #2
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,013

Rep: Reputation: 83
Sounds like your telnet client has local echo turned off

You should be able to toggle local echo by sending a [Ctrl]+[shift]+[e] signal

looks like ^E

see the following link:

http://www.scit.wlv.ac.uk/cgi-bin/mansec?1+telnet
 
Old 08-09-2004, 01:57 PM   #3
alaios
Senior Member
 
Registered: Jan 2003
Location: Aachen
Distribution: Opensuse 11.2 (nice and steady)
Posts: 2,133

Original Poster
Rep: Reputation: 45
Unhappy thxz

for your reply........ I am really confused with your reply... I was wandering if the program has the echo off. ... I works properly when it is not invoked form the agetty command... I tried the ^E but it didn't work anyway


Any other suggestion?
 
Old 08-09-2004, 02:59 PM   #4
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,013

Rep: Reputation: 83
Sorry, I missunderstood the problem.

I have in the past had a problem with telnet not echoing back, and so suggested that.

Have you tried taking the -n option out of the command?

from the man page on agetty this appears to stop user interaction at login??
 
Old 08-09-2004, 03:38 PM   #5
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,013

Rep: Reputation: 83
Ok, please ignore my previous replies.

I have installed zebra and I concur that when you telnet to localhost on port 2601 you get the zebra login prompt.

When you use agetty it just sits there twiddling it's thumbs.

... I will read up on zebra and let you know if I get anywhere
 
Old 08-10-2004, 01:29 PM   #6
alaios
Senior Member
 
Registered: Jan 2003
Location: Aachen
Distribution: Opensuse 11.2 (nice and steady)
Posts: 2,133

Original Poster
Rep: Reputation: 45
i do not know if u have something new about these thing... I wandering if it is possible at all or not
 
Old 08-10-2004, 02:09 PM   #7
Disillusionist
Senior Member
 
Registered: Aug 2004
Location: England
Distribution: Ubuntu
Posts: 1,013

Rep: Reputation: 83
So far,

the only thing I have found is about writing a wrapper to run telnet through ssh

Example, through the URL below:
http://pilot.org.ua/zebra/securing.html

I can't find any reference to using zebra through agetty.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
execute program only once during login tcma Linux - General 6 11-03-2004 08:55 AM
How to start program on X login donbellioni Linux - General 11 07-28-2004 04:45 PM
login program source code czarherr Linux - Software 2 07-16-2004 03:01 PM
A program not working in one login Sharko Red Hat 2 03-19-2004 09:26 AM
Autostarting a program upon login... Thymox Linux - General 3 02-07-2002 11:05 AM


All times are GMT -5. The time now is 09:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration