LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 10-04-2002, 12:44 PM   #1
Beav
LQ Newbie
 
Registered: Sep 2002
Distribution: Slackware 8.1
Posts: 19

Rep: Reputation: 0
HUGE problems with RTCW and Quake 3


I just tried to install both RTCW and Quake 3 from the Windows CDs and with the Linux binaries on the net. Quake 3 isnt as much of a problem as RTCW. Although I cant run either from X (my screen just changes size and the top half is blacked out)I have to run both from the console (I have to use "startx /path/to/game") I can learn to live with that(although launching from a console would be nice ). Quake 3 does the whole "CD skipping" routine where the sound skips and my keyboard/mouse dont respond. This has always happened right after I beat Crash and it shows the screen where both characters are standing side by side and if you got any awards (accuracy for example) they would appear here. All I can do is kill X with CTRL+ALT+BACKSPACE and that works fine except after that I cant see my text when I type. I have to #exit and re-log in and then its back to normal. RTCW I can even get past the menu. I set up my video and controls and then when I select the difficulty it gets to about halfway loaded -then I get kicked to the console where it shows "loading demomap.bsp (not sure if thats the exact name but its a .bsp file with "demo" in the name) and then once again my console text is invisible. Heres my system specs:
AMD K-7 900MHZ
128MB RAM
Nvidia GeForce 4 MX420 (latest drivers from nvidia -nvcheck says everythings ok)
VIA 686a onboard sound
Any ideas on what to fix -Iv looked around on various gaming boards (but im not really a hard-core gamer so im not sure where to look really)but cant seem to find a fix. PLEASE dont make me re-install windows again just to play these 2 games . I know its possible to get this working correctly just need a bit of help -If anyone knows what to try or where to look im be very grateful.
P.S. I was thinking about using WINE but im not sure of performance hits seeing how my system isnt really a "gaming rig" as they call it
P.S#2 -Thought I would mention I have tried both games as normal and root so I dont think its a problem with premissions -as usual i(the user) am the problem
sorry bout the length -and thanks for any help
 
Old 10-05-2002, 02:04 AM   #2
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
I would bet it has to do with video drivers. You have to be very careful with the setup. Additionally, I would check for conflicts between the nVidia drivers and the BIOS you are using. Some chipsets don't like the nVidia default divers. The ALi1541 chipset for example does not play nice with the AGP support built into the nVidia drivers.

Try using AGPgart rather than the nVidia built in AGP support.

If that doesn't solve it, it may be the video resolutions settings. If the games work from X with the settings set to the same resolution as X generally, but not alternate resolutions, it's probably this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
RTCW installer checksum problems LavaDevil94 Linux - Games 2 01-22-2005 07:40 AM
Mandrake 10 and RTCW problems.. wax Linux - Games 1 04-17-2004 12:11 PM
RTCW sound problems Viper168 Linux - Games 4 03-30-2004 12:36 AM
Kickstart Problems need huge help Xris718 Linux - General 0 11-11-2003 02:50 PM
RTCW - Graphics problems under Linux... Thymox Linux - General 12 01-19-2002 10:13 AM


All times are GMT -5. The time now is 06:28 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration