LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 09-25-2005, 02:56 PM   #1
MJatIFAD
LQ Newbie
 
Registered: Aug 2003
Posts: 28

Rep: Reputation: 15
Howto disable automount feature in Mandrake 10.1


Until today I never had a problem with mounting my USB drive at the mount point I desired. Suddenly Mandrake 10.1 automounts the thing at /mnt/removable. I tried to change my fstab but something is adding the problem again in the background.

This line is always added no matter what I do:
/dev/sda1 /mnt/removable auto user,iocharset=iso8859-1,sync,kudzu,codepage=850,noauto,exec,users 0 0

It is also wrong because it is not an iso8859-1 filesystem and I can not see my files correctly.

I disabled supermount and it looks off in the systems control.

It probably has something to do with an update last week but I did not have the problem until today. Maybe the problem has something to do with the new USB printer I set up today?

I can not figure this one out despite many searches on the Web and it is a feature that really is annoying me right now, so I would really appreciate if anyone could give me a helping hand.

I'll promise to light a candle for the savior...
 
Old 09-25-2005, 08:46 PM   #2
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
Quote:
I tried to change my fstab but something is adding the problem again in the background.
Stop and disable the hotplug service.

Quote:
It is also wrong because it is not an iso8859-1 filesystem and I can not see my files correctly.
Its not saying that its an 'iso8859-1' file system is saying that is what the character set for the file names is. The filesystem is listed as 'auto' in that entry, which sould work.
 
Old 09-26-2005, 03:46 AM   #3
MJatIFAD
LQ Newbie
 
Registered: Aug 2003
Posts: 28

Original Poster
Rep: Reputation: 15
According to the system control center the hotplug service is stopped. How can I otherwise verify/disable this?

Quote:
Its not saying that its an 'iso8859-1' file system is saying that is what the character set for the file names is. The filesystem is listed as 'auto' in that entry, which sould work.
Excuse my poor formulation. I actually meant that the filename characters I use is utf-8. However, this should be solved once I turn this hotplug thing off.
 
Old 09-26-2005, 04:38 AM   #4
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
Well it says in the control centre thing wether its stopped or running. If its still doing it automatically stop the haldaemon also.
 
Old 09-26-2005, 02:59 PM   #5
MJatIFAD
LQ Newbie
 
Registered: Aug 2003
Posts: 28

Original Poster
Rep: Reputation: 15
I have no haldaemon installed, so this is not the problem. It seems that hotplug is a script that is invoked by the kernel when an USB device is discovered. This script initiates a lot of things and this is where the magic somehow happens. I have until now not been able to find a work around and disabling the script causes failures during system bootso this is probably not a good idea. I somehow need to configure hotplug to do what I want but this seems complicated to figure out. I am trying to make sense of the hotplug homepage documentation but it has not enlighted me so far. Any suggestions?
 
Old 09-26-2005, 06:54 PM   #6
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
Are you sure its not installed? Does
Code:
ls -l /etc/init.d/haldaemon
show that there's a file there? Do you have the hal RPM installed
Code:
rpm -q hal
.
 
Old 09-27-2005, 04:26 AM   #7
MJatIFAD
LQ Newbie
 
Registered: Aug 2003
Posts: 28

Original Poster
Rep: Reputation: 15
No, it is not there. However, somehow it miraculously worked with a simple fstab entry. I could not make it work in similar previous experiments. I just added the line:

/dev/sda1 /data ext3 noauto 0 0

In previous attempts the hotplug always added its own line later, which changed the mountpoint spontaneously. Before I actually did the above I also tried booting the same line with auto instead of noauto. The system failed to locate the device during boot but it automounted it correctly later and it kept stable this way. Now it also works with noauto. However, I recall that I had some other options in my previous experiments but I do not remember exactly what they were. I simply experimented with the line hotplug added. I also found a related discussion where they were mentioning that this kudzu option could be the source of evil.

Now I hope that the problem stays away. Many thanks for the help, you really gave me some important leads even though the solution turned out to be surprisingly simple.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to disable showdetails feature in RHGB m.harshavardhan Linux - Software 5 07-15-2005 02:07 AM
temporarily disable automount bnj Linux - Newbie 4 06-26-2005 09:41 AM
Disable the Mandrake automount feature pinoez Linux - Newbie 6 06-10-2005 09:41 AM
How to disable automount in Mandrake 10.1 deathbyswiftwin Linux - Hardware 3 04-11-2005 03:54 AM
Disable automount zokik Linux - General 5 12-07-2003 07:59 AM


All times are GMT -5. The time now is 10:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration