LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 01-20-2006, 08:35 AM   #1
jumpingguy
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
how to set the watiing time of bringing up network device when system is booting?


I am using FC4.
I have a network card but I don't want to connect it to any network when booting the system.
However, i have to wait about 1 min for "failed" to bring all connection up, then proceed.
how do I setting the waiting time?
 
Old 01-21-2006, 04:05 AM   #2
berbae
Member
 
Registered: Jul 2005
Location: France
Distribution: Arch Linux
Posts: 540

Rep: Reputation: Disabled
Hi umpingguy
I don't use Fedora Core 4 but SUSE Linux, so I can only tell you what works in SUSE:
in the file '/etc/sysconfig/network/config' there is a variable named WAIT_FOR_INTERFACES which contains the waiting time for all mandatory interfaces to come up and 'If empty no wait occurs.'
Try to adapt this to your distribution.
Bye.
 
Old 01-21-2006, 06:00 AM   #3
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86; Gentoo PPC; Gentoo Sparc64; FreeBSD; OS X; Solaris
Posts: 3,731
Blog Entries: 4

Rep: Reputation: 65
Quote:
I have a network card but I don't want to connect it to any network when booting the system.
So instead of setting a timeout, why not just disable automatic network startup?
 
Old 01-21-2006, 08:51 AM   #4
jumpingguy
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Original Poster
Rep: Reputation: 0
i have no idea about turn off the auto network startup......
help me ...
let me know in which file/dir the setting file is
 
Old 01-21-2006, 07:52 PM   #5
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
As root user ( su - ) edit the file for that nic. If you don't want eth0 to try connect at startup time, then edit /etc/sysconfig/network-scripts/ifcfg-eth0

Change the line ONBOOT=yes to ONBOOT=no
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to set and sync system time with time server?? servnov Linux - Newbie 6 12-03-2013 07:55 PM
set system time xushi Slackware 3 03-31-2005 08:56 AM
Bringing up ETH0 decrease time djcham Linux - Software 2 02-15-2005 07:19 PM
Erm, how do I set my system date/time? vasudevadas Slackware 4 09-14-2004 03:40 PM
how set system time by command prompt? yenonn Linux - Newbie 9 08-25-2003 06:40 PM


All times are GMT -5. The time now is 03:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration