LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 01-12-2004, 04:26 PM   #1
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Rep: Reputation: 15
How to set the default WM


I'm trying to lock down a machine that will be used as an internet kiosk at school. I'm running LTSP 4.0 on Fedora.

I've got it to automatically login, but it automatically logs into KDE. I've pretty much got the lockdown on IceWM, so I was trying to get gdm to automatically go into Ice.

What part of GDM do I edit if I wanted to change the default login?

Also, how do I set it so the "languages" button is disabled, and so tha the only option for "sessions" is Ice?

Thanks in advance!
 
Old 01-12-2004, 07:57 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,950
Blog Entries: 11

Rep: Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860Reputation: 860
I don't use gdm, but I'd assume that the
little program by the name gdmconfig
might prove helpful :) (No, I don't have it
installed).


Cheers,
Tink
 
Old 01-15-2004, 07:08 PM   #3
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
Thanks for the advice. Here's what I did since the last post:

I've already tried gdmconfig (or gdmsetup).

I also read up on some of the documentation on how to configure gdm.conf manually.

Now, when turn on timed login, gdm automatically logs in, but into KDE.

But when I type in my test username/password, then it goes into IceWM. I want it to auto-login to Ice.


Any gdm experts out there to help?

Oh, by the way, i figured out how to disable the language and session buttons, by the way. I editted the default gdm theme and got rid of the buttons from there. . .
 
Old 01-15-2004, 10:12 PM   #4
Lost Penguin
Member
 
Registered: Feb 2003
Location: Orlando, FL
Distribution: 2.6.1-1.131smp on Fedora Core 1
Posts: 31

Rep: Reputation: 15
Quote:
Originally posted by beajedi
Thanks for the advice. Here's what I did since the last post:

I've already tried gdmconfig (or gdmsetup).

I also read up on some of the documentation on how to configure gdm.conf manually.

Now, when turn on timed login, gdm automatically logs in, but into KDE.

But when I type in my test username/password, then it goes into IceWM. I want it to auto-login to Ice.


Any gdm experts out there to help?

Oh, by the way, i figured out how to disable the language and session buttons, by the way. I editted the default gdm theme and got rid of the buttons from there. . .
I am not a gdm guru (IANAGG) <g>

Ok, for starters you will need the button you got rid of, we will get them back the easy way, we will change gdm themes;


gdmsetup : choose the themes tab; pick another theme.
while still in gdmsetup, choose the General tab:
turn off:
"log in a user automatically after a specified number of seconds"
and turn off:
"login a user automatically at boot"
close gdmsetup
log out


Now we will set the user you want to run ICEwm

at the gdm login screen:
type the name of the user set for KDE you wish to change:
choose the sessions button; choose ICEwm or whatever.
type the users password and login.
The system will ask if you would like to make this the default for this user, choose "yes"


Now we will set gdmsetup to autologin your user of choice

after login:
run:
gdmsetup
Give the root password when asked.
choose the "log in a user automatically after a specified number of seconds":
choose the user you have set to run ICEwm
set the time to 5 seconds (if you set this time too low you will regret it, trust me <g>)

now everytime someone logs out, in 5 seconds later it will login again as this user in ICEwm.

If this is NOT the effect you want.
choose "login a user automatically at boot":
choose the user you have set to run ICEwm

Change the gdm theme back to the one you "fixed" to not have a session button.
close gdmsetup

On mine I use:
"login a user automatically at boot"
and
"log in a user automatically after a specified number of seconds" (15 Seconds)

This logs me in at bootup, and will relogin as me if i logout and do not login as another user. (I am the only user)
 
Old 01-20-2004, 06:14 PM   #5
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
Ok, I will try that. Thanks a lot!




--edit--

it did not work

the default session has already been set to Icewm. When I log in with the username/password, it will get into Ice.

changing the session to Icewm during the countdown still goes into KDE.


Last edited by beajedi; 01-20-2004 at 07:01 PM.
 
Old 01-28-2004, 05:23 PM   #6
beajedi
Member
 
Registered: Jan 2003
Distribution: Slackware 9.1
Posts: 67

Original Poster
Rep: Reputation: 15
^^



Sorry for the doublepost.

I guess I'd rather doublepost than make a new thread.

Anyways, Ice is finally the default WM for the user account. I also disabled the "language" and the "session" buttons by editting the theme.

But the "F10" key still works, and that still allows a person to choose a session/language.

How do you disable te F keys in gdm/linux in general?

-- Thanks in advance!
 
Old 02-20-2004, 02:17 PM   #7
gljoe
LQ Newbie
 
Registered: Jul 2003
Posts: 10

Rep: Reputation: 0
Hello, I'm having a similar issue just getting a default session set to IceWM.

How did you accomplish that? What file holds the magic switch?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I tell what my default gateway is currently set as? abefroman Linux - Networking 6 09-10-2005 12:15 PM
How do I set up default kernel?10.0 akihandyman Mandriva 1 07-20-2004 08:05 PM
Is there a way to set up the default look for all new users? HGeneAnthony Linux - General 1 03-17-2003 04:29 AM
How to set WinXP as default OS ? Jimmyscab Linux - General 7 12-06-2002 11:15 AM
How can I set the default resolution? DFrey Linux - Newbie 5 11-19-2001 02:33 AM


All times are GMT -5. The time now is 06:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration