Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 02-06-2002, 11:25 PM   #1
LQ Newbie
Registered: Jan 2002
Posts: 9

Rep: Reputation: 0
How To Open Port 443 On RedHat 7.1

Hi, I'm running apache on redhat 7.1. When I install the redhat, I customize the firewall configuration to allow incoming on port 80, but I forgot to open port 443. I did ran a probing port test, and I was right. Port 80 is open, and port 443 is closed.

Anybody know how to open port 443 on redhat?

Old 02-06-2002, 11:34 PM   #2
Registered: Jan 2002
Location: Kansas City
Distribution: RedHat 7.2 Kernel 2.4.17
Posts: 250

Rep: Reputation: 30
If you're using the built in RH setup for firewall - just type 'setup' at the command prompt and it will have an option for FW config.
Old 02-07-2002, 01:03 AM   #3
LQ Newbie
Registered: Jan 2002
Posts: 9

Original Poster
Rep: Reputation: 0
Hey, It worked. Thank you.

I have one more question. How can I configure it without going to setup? Is there any other way that is more general to linux? Thanks again.

Old 02-07-2002, 10:22 AM   #4
Registered: Jan 2002
Location: Kansas City
Distribution: RedHat 7.2 Kernel 2.4.17
Posts: 250

Rep: Reputation: 30
Yes - if you go back into setup and disable the firewall. The go back to the console - you can use the program ' iptables ' to create your firewall rule set. It's easier to just do a 'man iptables' than for me to try and discuss the syntax.

To other programs you'll want to know about are 'iptables-save' and 'iptables-restore' - because the system will lose your settings after a reboot.

After you're done creating your rule set type 'iptables-save > /etc/firewall.conf' and it will save your configuration to that file in the /etc directory.

Then edit your /etc/rc.d/rc.local file and append 'iptables-restore < /etc/firewall.conf' to the end, which will restore your settings each time upon boot.

At least this is how I do it.. there maybe more than one way to skin a horse, but this works for me.
Old 02-07-2002, 10:40 AM   #5
LQ Guru
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,155

Rep: Reputation: 56
the file is /etc/sysconfig/iptables

edit the file and when you get it like you want it run this

/etc/rc.d/init.d/iptables restart

try that

also the same command for stop, and start

don't run lokkit or it will rewrite the script.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache Port 443 Verbal Kint Linux - Software 0 10-04-2005 04:07 AM
access using port 443 gtoerner Linux - Security 3 07-14-2005 06:48 PM
turn off http port 80, keep https port 443 lothario Linux - Networking 6 02-11-2005 05:06 AM
ssh over port 443 pupton Linux - Software 18 10-08-2004 08:15 AM
Getting SSL onto PORT 443 kuso Linux - Software 6 03-11-2004 12:41 AM

All times are GMT -5. The time now is 04:44 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration