LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-01-2013, 01:54 PM   #1
georgesjeandenis
LQ Newbie
 
Registered: May 2013
Distribution: Red Hat 4.4.7-3
Posts: 3

Rep: Reputation: Disabled
How to install sharedhostffmpeg on a host running redhat linux while not being root?


I'm on a shared host that is running on Red Hat 4.4.7-3.

All these packages have successfully installed: - presetup.sh, autoconf.sh, automake.sh, libtool.sh, libiconv.sh, libpng.sh, libjpeg.sh, zlib.sh, libwmf.sh, freetype.sh, gettext.sh, gd.sh, ruby.sh, flvtool2.sh, lame.sh, codecs.sh, libogg.sh, libvorbis.sh, vorbis-tools.sh, libtheora.sh, amrnb.sh, amrwb.sh, liba52.sh, facc.sh, faad2.sh.

That's exactly all the files just before ffmpeg itself!

I know the error has to do with a library. However, I'm not familiar with libraries. The error message says:

/usr/bin/ld: /home/xxxxx/lib/libz.a(compress.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC /home/xxxxx/lib/libz.a: could not read symbols: Bad value

BUT, when I look at my zlib log file(sharedhostffmpeg.1.0.2.log.15939), no errors show up.

Does anyone know how to recompile with fPIC?
 
Old 05-01-2013, 02:46 PM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,944
Blog Entries: 54

Rep: Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731Reputation: 2731
Quote:
Originally Posted by georgesjeandenis View Post
Does anyone know how to recompile with fPIC?
Run 'export CFLAGS="-fPIC"; export LDFLAGS="-shared";' before you ./configure and recompile Zlib. BTW http://stackoverflow.com/questions/9...ith-fpic-error suggests you may also need "--enable-shared" or "--shared" ./configure switches and if so you probably need to recompile everything if the switches were needed but not added...
 
Old 05-06-2013, 05:54 AM   #3
georgesjeandenis
LQ Newbie
 
Registered: May 2013
Distribution: Red Hat 4.4.7-3
Posts: 3

Original Poster
Rep: Reputation: Disabled
Thank you so much unSpawn.

I did what you told me to:

export CFLAGS=`-fPIC`
export LDFLAGS=`shared`
+

./configure --prefix=$HOME --enable-shared

in the "zlib.sh" shell script. It seemed to work well.

However this time I get:

cp zlib.h zconf.h /home/xxx/include
chmod 644 /home/xxx/include/zlib.h /home/xxx/include/zconf.h
cp libz.a /lib
cp: cannot create regular file `/lib/libz.a': Read-only file system
make: *** [install] Error 1

I understand a bit :
It's trying to make the libz.a file in the regular script files for the system. But keep in mind that this is a shared host on a web hosting company.
They hosting company don't want to help.

Is their a way to make it create that lib script in another location and still make it work?
And if so, do you know how?
 
Old 05-06-2013, 07:02 AM   #4
georgesjeandenis
LQ Newbie
 
Registered: May 2013
Distribution: Red Hat 4.4.7-3
Posts: 3

Original Poster
Rep: Reputation: Disabled
People say they solve library issues like mine using symlinks.

Does that make sense?

1 exemple I kept : http://www.linuxquestions.org/questi...-lxext-365646/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install Samba on VMWare running Ubuntu 10.10 as guest OS & XP as host pawan613 Linux - Virtualization and Cloud 3 11-29-2011 06:47 AM
LXer: How To Install Railo 3.2 Under OpenSUSE 11.3 Running Apache2 Tomcat 6 Virtual Host LXer Syndicated Linux News 0 02-23-2011 03:40 PM
[SOLVED] How can I install a Wifi Host Driver on uclinux running on skyeye blink182 Linux - Embedded & Single-board computer 1 10-08-2010 02:05 AM
try install host ; bind9-host uninstalled , how to undo sudo apt-get install host? shojaru Linux - Newbie 0 06-11-2009 12:45 AM
ssh and nfs connections refused by Linux host running RedHat 9.0 and having 2 NIC erinduffy Linux - Networking 1 01-21-2005 11:13 AM


All times are GMT -5. The time now is 11:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration