LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 08-28-2004, 11:02 PM   #1
deh6
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Rep: Reputation: 0
How to get rid of 30 sec delay "loading grub stage2"?


I added a DVD/CD-RW to the system. Afterwards when booting, there is a 30 sec delay during which there is a blank screen, except for the upper left hand corner displaying, “loading Grub stage 2.” After the delay, the grub splash screen comes up and everything works OK. Suse 9.1. I would like to get rid of the delay.

When I added a DVD/CD drive my linux drive changed from hdc to hdd. (Primary master: windows hd; slave: CD reader; Secondary master: DVD/CD-RW, slave: linux hd). The cables aren’t long enough to swap the master/slave so that the linux drive remains the secondary master, and the BIOS only uses the cable selection, so I seem to be stuck with the CD/drive master/slave arrangement.

To make the installation work I had to change ‘fstab’ and the grub ‘menu.lst’ to reflect the change. I also reinstalled the boot from YAST. The installation works just fine, but it would be nice not to have the 30 sec additional boot time.

My guess is that the initial boot code is trying the DVD/CD as if it were a hd, then timing out, and going on to the correct drive. Someplace there should be a way to by-pass that. ‘device.map’ is correct, so that doesn’t appear to be the problem.

Don
 
Old 08-29-2004, 12:13 AM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
in the /boot/grub directory is a file called

menu.lst

the delay time should be there..........
 
Old 08-29-2004, 03:08 AM   #3
short101
Member
 
Registered: May 2004
Location: Aust.
Distribution: Debian
Posts: 424

Rep: Reputation: 30
Or when you boot and you have a choice of kernels or op systems, I think you can press e or something and it comes up there.
 
Old 08-29-2004, 03:18 AM   #4
Dark_Helmet
Senior Member
 
Registered: Jan 2003
Posts: 2,786

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
You could try removing the CDROM entry from your device map entirely. I don't know if that would have the desired effect, but it's worth a try. Grub can't very well probe a device it doesn't know exists...

Unfortunately, I don't know all the ins-and-outs of Grub configuration to know if there is a bypass option or not. So I'm not much use there... sorry.
 
Old 08-29-2004, 05:20 AM   #5
Not now, John!
Member
 
Registered: Jul 2004
Distribution: LFS 5.1
Posts: 161

Rep: Reputation: 30
I think that could be motherboard problem.
I have ASUS A7V8X-MX motherboard, and it works fine when I boot form IDE-0.
But when I change to IDE-1 it takes a very long time to boot.
(My both HDs are bootable.)
 
Old 08-29-2004, 08:29 PM   #6
deh6
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
320mb,

The delay occurs before the ‘menu.lst’ time delay. Changing the delay in ‘menu.lst’ only changes the duration it wait for the op to make a selection.

Dark_Helmet,

If you are referring to ‘device.map’ the cd drives don’t appear in it. It shows:
(hd0) /dev/hda
(hd1) /dev/hdd
(fd0) /dev/fd0

Not now, John!,

The motherboard being the cause seems unlikely, since before I added the DVD-CDW the linux hd was on the secondary IDE and there was no delay. It was master, however. Nevertheless the mother board could be invovled. The board is an Intel 865GLCL with a P4. It is a recent model and has “everything” integrated on the board.

Oh,well, maybe it's something I'll just have to live with.

Don
 
Old 08-30-2004, 01:54 AM   #7
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,691

Rep: Reputation: 286Reputation: 286Reputation: 286
The BIOS determines which devices, and their order, will be checked for a bootable OS. Check your BIOS for a timeout/timedelay of some kind.
 
Old 08-30-2004, 07:38 AM   #8
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
No, I think that the cable select is a bit confused, and is taking that time to determine what has changed and where what it's looking for really is now.

Did you jumper the DVD/CD-RW unit for Cable Select when you installed it?
 
Old 08-30-2004, 02:24 PM   #9
deh6
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
bigrigdriver,

The time delay is after the initial boot with the bios, and the screen is showing “Loading grub stage 2”. This means that stage 1 (in the mbr on hda) has loaded.

motub,

I tried all combinations of jumper settings. The bios only has cable select option. Bios only recognizes the drives when the jumpers are in master/slave settings that match the cable, or of course, cable select positions.

Don
 
Old 08-30-2004, 03:53 PM   #10
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
Yes, I understand, but what I'm thinking is that Loading grub stage 2 happens when the first stage is looking for the location of stage 2 as already set in the MBR. Stage 2 is a tarball in your /boot/grub folder. If the discovery is not happening fast, it suggests that your drives aren't where they're expected to be in some fashion, and Grub is having to look for them (for 30 seconds, which I would imagine is being spent in asking "are you hdd?" "are you?"), which is why I wanted to look at this issue of cable detection.

But wait... why is the floppy drive appearing in your device.map? I rather think that the 30 second delay might well be probing the floppy, as that takes a really long time.

If you don't intend to boot from a floppy (meaning that if you don't have a grub stage 2 install on a floppy disk, what good does it do to be looking there), maybe you could remove that line (device.map can be edited in a text editor), and see if that helps.

You can always put it back, since you have printed the original config here for posterity in case you forget .
 
Old 08-30-2004, 07:49 PM   #11
deh6
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
motub,

Removing fd0 in the device.map made no difference.
 
Old 09-22-2004, 10:32 AM   #12
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
re-install GRUB...
when you install grub it porbles for hardware.... not that your hardware has changed it may be confused...

[code]grub-install --root-directory=/ /dev/hda[/code[

replace /dev/hda with the bootable hard drive device.
 
Old 09-22-2004, 04:26 PM   #13
deh6
LQ Newbie
 
Registered: Aug 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks for the post.

I have tried reinstalling grub, and even did a clean re-format disk install, but the problem remains.
 
Old 09-07-2005, 09:48 AM   #14
ttgamage
LQ Newbie
 
Registered: Sep 2005
Location: Missouri, USA
Distribution: Ubuntu
Posts: 8

Rep: Reputation: 0
Unhappy pls help

i have some prob in dual boot XP with FC4. i want to install the boot loader to the first sector of the boot partition(not to mbr) and my ext3 partition is hda9 with swap deing hda10. the windows partition is hda1
after installation i used the linux rescue feature and got the .bin file using dd if=/dev/hda9 bs=512 count=1 of=/dev/fd0/linux.bin and did the nesessary modifications in windows boot.ini too. but now when i try to login to fedora the screen displays GRUB loading stage2.......and nothing happens can some one please help me since i'm desperate to use fedora for some software development.

also anyone having good links to serial port programming in java? pls
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4: "GRUB Loading Stage2... read error" at startup Kropotkin Fedora 2 12-01-2005 05:29 PM
GRUB Loading stage2 Error, hard-disk broken ??? jdevitt Fedora 5 09-15-2005 08:54 AM
Boot problem: "GRUB Loading stage2read Error" after installing PCI Ethernet card nsyng Fedora - Installation 1 06-06-2005 06:53 AM
When "function pointer" meets "template"... I can't get rid of this compiling er cyu021 Linux - Software 3 12-17-2004 07:52 PM
Install stops at "Calibrating delay loop" eam Linux - General 0 07-23-2004 07:39 PM


All times are GMT -5. The time now is 10:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration