LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-24-2011, 05:31 AM   #1
pawan613
LQ Newbie
 
Registered: Sep 2011
Posts: 23

Rep: Reputation: Disabled
Angry How to enable ACL support on ext4 ?


Hello there.
I'm using Ubuntu 10.10 on ext4 file system and have exported a directory "/home/dbs/exp1/" through Samba on Windows(on VirtualBox).
I need to modify the acls for the files in the above directory both from Ubuntu and Windows.
For linux, I'm using setfacl utility to modify ACLs, but it says that "Operation is not supported". From google I got to know that acl and user_xattr support has to be enabled at the mount point to modify the ACLs
So, can anyone tell me clearly, what should I do to enable ACL support?

I tried:
sudo mount /home/dbs/exp1 -o remount,acl

but it says:
mount: can't find /home/dbs/exp1 in /etc/fstab or /etc/mtab

My /etc/fstab looks like:

# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda5 during installation

UUID=66eeee3e-b860-41b0-abf7-074c0e08420e / ext4 errors=remount-ro 0 1

#Entry for /dev/sda2 :
UUID=2080E92980E905DE /media/Data ntfs defaults,uid=dbs,gid=dbs,umask=000,windows_names 0 0

#Entry for /dev/sda1 :
/dev/sda1 /media/Windows_XP ntfs defaults,uid=dbs2,gid=dbs2,umask=000,windows_names 0 0


Please help me!
Thanks in advance.
 
Old 11-24-2011, 06:23 AM   #2
Nominal Animal
Senior Member
 
Registered: Dec 2010
Location: Finland
Distribution: Xubuntu, CentOS, LFS
Posts: 1,723
Blog Entries: 3

Rep: Reputation: 942Reputation: 942Reputation: 942Reputation: 942Reputation: 942Reputation: 942Reputation: 942Reputation: 942
You need to remount the mount point -- in this specific case, the root / filesystem, not just the desired directory. In other words, try
Code:
sudo mount -o remount,acl /
For future, change the line in /etc/fstab to
Code:
UUID=66eeee3e-b860-41b0-abf7-074c0e08420e / ext4 relatime,acl,errors=remount-ro 0 1
and POSIX ACL's will be enabled for you even after a reboot.

(The relatime option relaxes file access time (atime) updates; it reduces writes to disks when you are just reading from it.)
 
1 members found this post helpful.
Old 11-24-2011, 06:31 AM   #3
pawan613
LQ Newbie
 
Registered: Sep 2011
Posts: 23

Original Poster
Rep: Reputation: Disabled
Bingo!!
Thank you thank you Nomial Animal.
It's working now.
Thanks a ton!
 
  


Reply

Tags
acl, fstab, setfacl


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
enable-arp-acl squid starting error krish.kittu7 Linux - Server 6 06-28-2011 03:45 AM
[SOLVED] Enable ACL in RHEL 5 yamujanu Linux - Security 2 05-26-2011 06:24 AM
How to enable ACL in /dev (udev) file system aldo_mozzi Linux - Newbie 1 03-11-2008 10:22 PM
How can I enable Posix ACL in Debian HGeneAnthony Linux - Security 6 04-01-2006 07:15 PM


All times are GMT -5. The time now is 07:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration