LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 09-03-2009, 03:11 AM   #1
Zoot
LQ Newbie
 
Registered: Mar 2009
Distribution: Debian Squeeze
Posts: 8

Rep: Reputation: 0
How to Disable the Terminal Beep when running the Shutdown command?


I've used the following script here:
http://ubuntuforums.org/showthread.php?t=1046137
to upgrade Alsa to 1.0.21 in Ubuntu 8.04.

Now whenever I run:
Code:
sudo shutdown -h <time> or sudo reboot
from the terminal I get a rather annoying beep sound. What's even more annoying is if I use the shutdown command to specify a time I get a beep every 10 minutes or so.
I've tried disabling the terminal beep in the terminal profile, disabling the beep in System/Preferences/Sound, adding "blacklist pcspkr" to /etc/modprobe.d/blacklist, and running gconf-editor from the terminal and setting /desktop/gnome/peripherals/keyboard/bell_mode to 'off' rather than 'on'.

This is rather annoying considering I use the shutdown command a lot when watching movies/TV series.
Anyone got any ideas on how to turn this thing off?

Last edited by Zoot; 09-03-2009 at 03:12 AM.
 
Old 09-03-2009, 04:58 AM   #2
mdg
Member
 
Registered: Sep 2003
Distribution: Slackware
Posts: 626

Rep: Reputation: 37
If the beep is coming from the pc-speaker, you could physically disable it on the motherboard.
 
Old 09-03-2009, 10:16 AM   #3
Zoot
LQ Newbie
 
Registered: Mar 2009
Distribution: Debian Squeeze
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks but it's a Laptop (Dell XPS M1530), and the beep comes from the PC speakers.

Anyway I've done a bit of digging, and it seems there's a mixer option for the PC Speaker in Alsa 1.0.21. I've also learned of a little app called GShutdown which I guess is just a GUI for the shutdown command. I'll try it later and post back the results.
 
Old 09-03-2009, 10:19 AM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
To disable the beep
Code:
sudo modprobe -r pcspkr
To make it permanent
Code:
echo "blacklist pcspkr" | sudo tee -a /etc/modprobe.d/blacklist
 
Old 09-03-2009, 12:04 PM   #5
Zoot
LQ Newbie
 
Registered: Mar 2009
Distribution: Debian Squeeze
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
To disable the beep
Code:
sudo modprobe -r pcspkr
To make it permanent
Code:
echo "blacklist pcspkr" | sudo tee -a /etc/modprobe.d/blacklist
Already tried that, no joy... Thanks anyway.

However what did work was muting the "PC Beep" in the Gnome ALSA Mixer. I think the Mixer option for that was only added with Alsa 1.0.21.

Either way, problem solved.
 
Old 09-03-2009, 01:16 PM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Slackware 14.0
Posts: 8,464

Rep: Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877Reputation: 877
Quote:
Either way, problem solved.
If you want you can mark the thread solved.
 
Old 09-03-2009, 02:06 PM   #7
Zoot
LQ Newbie
 
Registered: Mar 2009
Distribution: Debian Squeeze
Posts: 8

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by repo View Post
If you want you can mark the thread solved.
Done. Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable System Beep Darth Cupcake Linux - Kernel 2 10-23-2008 02:44 PM
disable reboot/shutdown beep yiang Linux - Newbie 13 04-26-2006 11:47 PM
How to disable the warning sound "beep, beep" ICO Red Hat 1 04-04-2006 01:59 AM
How to disable beep in command line Backstander Linux - General 6 09-12-2004 02:11 PM
running a terminal command from a link nebula_nirvana Linux - Newbie 1 06-07-2004 09:08 AM


All times are GMT -5. The time now is 07:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration