LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   How to disable beep in command line (http://www.linuxquestions.org/questions/linux-general-1/how-to-disable-beep-in-command-line-229106/)

Backstander 09-10-2004 07:37 PM

How to disable beep in command line
 
You know the annoying PC speaker beeps you get in linux when you hit backspace too many times or hit tab to autocomplete something and there's either multiple or no matches or when you type shutdown -h now (or whatever)? I was wondering if there was a way to disable this "beep on error" cuz i'm fixing to go crazy and rip that darn PC speaker right outta my case! :D

I'm not talking about in the GUI using xterm or konsole. I know how to do that.
Use this command to turn off beeping in general in X:

xset b 0

Does anyone out there know this? I'd be much obliged. :cool:

sether 09-10-2004 07:50 PM

http://www.linuxquestions.org/questi...hreadid=224554 someone had the same problem.

Backstander 09-10-2004 08:59 PM

Awesome!!! Here's how I disabled it:

I added the line "set bell-style none" to the file ~/.inputrc then logged out and back in and it worked right away. But you'll have to add this to every account you want to disable it for.

Adding it to /etc/inputrc didn't work for me. I think because I'm using Red Hat Linux 5.2 (kernel 2.0.34) on here.

Thanks sether for pointing me in the right direction thou ;)

Backstander 09-10-2004 09:09 PM

Sorry to post twice but you can also use "set bell-style visible"

sether 09-10-2004 09:18 PM

if there's a /etc/profile file in linux (i don't know because i'm on FreeBSD at the moment), that usually would work for something like that on a system-wide scale.

Backstander 09-12-2004 02:29 PM

Yeah there is a /etc/profile but didn't seem to work for me. May work for newer linux version. I think /etc/inputrc is system-wide implementation as such but didn't work for me either. I even tryed them with a full system reboot without luck.

zz9pluralzalpha 09-12-2004 03:11 PM

I have the PC speaker compiled as a kernel module rather than having it compiled in. I've never had a reaon to load it.


All times are GMT -5. The time now is 03:29 AM.