LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-14-2004, 02:30 AM   #1
icoming
Member
 
Registered: Feb 2004
Posts: 96

Rep: Reputation: 15
how to change the default language of the system


when i installed my Linux, I installed two languages ,Chinese and English,and Chinese is the default language.
But now i want change the default language to English.
i have tried using /usr/bin/redhat-config-language to make the change ,
but it doesn't work.When i restart X,the language is still Chinese.
what should i do to change the default language?
And my Linux is Redhat.
 
Old 05-14-2004, 04:06 AM   #2
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
type
redhat-config-language

in a shell prompt to launch the Language Configuration Tool. If you are not root, it will prompt you for the root password to continue. This should work. At least that is what the RH 9.0 official guide says.
 
Old 05-14-2004, 04:11 AM   #3
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
mm..try this one out:

1) check what your current locale says; open a terminal/console and type

locale

you should get a list. all the lines should have the same locale name at the end of them, something like "en_US.UTF-8" (this depends on the locale _you_ have, but it's in the same format). you may write that down, in case you wish to switch back to the old locale after this. now let's change the default language, or, to say it better, let's change either LC_LANG or LC_ALL. difference between them is that LC_LANG sets the language used but leaves everything else as it is (the way dates and currencies are shown etc.), but LC_ALL means that every locale is set to the new one...I guess you should try LC_ALL, so do like this (in terminal/console):

Code:
locale -a | more
(now you'll get a list of locales, choose the one that fits you, like en_US.iso885915. put the one you want into the next LC_ALL= -command like on the example below..)
Code:
LC_ALL=en_US.iso885915
export LC_ALL
now restart your X and see if anything has changed if it did, you've succeeded. if it didn't, something's wrong...anyway, if you want to switch back to the old locale (the one you wrote down from after locale command), just do

Code:
LC_ALL=the_old_locale_name_you_wrote_down
export LC_ALL
I'm not sure whether this stuff is "saved" so that when you reboot it will be the new locale you set up, or the old one. if after reboot your language-settings are reverted back to chinese, put the code

Code:
LC_ALL=en_US.iso885915
export LC_ALL
(or put anything you just want instead of en_US.iso885915) into some bootscript, like /etc/rc.local or then into your /home/username/.bash_profile.

hopefully this helped at least a bit..
 
Old 05-14-2004, 11:08 AM   #4
icoming
Member
 
Registered: Feb 2004
Posts: 96

Original Poster
Rep: Reputation: 15
it doesn't work.
i change the language with the below code:
LC_ALL=en_US.iso885915
export LC_ALL
it only made the Chinese filename display uncorrectly,but the terminal can still display in Chinese.
and what i want is to let every thing display in English,including menu terminal ,and so.


Quote:
Originally posted by b0uncer
mm..try this one out:

1) check what your current locale says; open a terminal/console and type

locale

you should get a list. all the lines should have the same locale name at the end of them, something like "en_US.UTF-8" (this depends on the locale _you_ have, but it's in the same format). you may write that down, in case you wish to switch back to the old locale after this. now let's change the default language, or, to say it better, let's change either LC_LANG or LC_ALL. difference between them is that LC_LANG sets the language used but leaves everything else as it is (the way dates and currencies are shown etc.), but LC_ALL means that every locale is set to the new one...I guess you should try LC_ALL, so do like this (in terminal/console):

Code:
locale -a | more
(now you'll get a list of locales, choose the one that fits you, like en_US.iso885915. put the one you want into the next LC_ALL= -command like on the example below..)
Code:
LC_ALL=en_US.iso885915
export LC_ALL
now restart your X and see if anything has changed if it did, you've succeeded. if it didn't, something's wrong...anyway, if you want to switch back to the old locale (the one you wrote down from after locale command), just do

Code:
LC_ALL=the_old_locale_name_you_wrote_down
export LC_ALL
I'm not sure whether this stuff is "saved" so that when you reboot it will be the new locale you set up, or the old one. if after reboot your language-settings are reverted back to chinese, put the code

Code:
LC_ALL=en_US.iso885915
export LC_ALL
(or put anything you just want instead of en_US.iso885915) into some bootscript, like /etc/rc.local or then into your /home/username/.bash_profile.

hopefully this helped at least a bit..
 
Old 05-14-2004, 11:12 AM   #5
icoming
Member
 
Registered: Feb 2004
Posts: 96

Original Poster
Rep: Reputation: 15
i had used redhat-config-language.
but it didn't work.
i used it to change the default language,and it told me to restart X,but when i started X, its default language is still Chinese,and nothing is changed.I launch redhat-config-language again,and it still told me the default language is Chinese.

Quote:
Originally posted by LinuxLala
type
redhat-config-language

in a shell prompt to launch the Language Configuration Tool. If you are not root, it will prompt you for the root password to continue. This should work. At least that is what the RH 9.0 official guide says.
 
Old 05-14-2004, 01:28 PM   #6
LuggerHouse
Member
 
Registered: May 2004
Location: Montreal,QC,Canada
Distribution: Fedora Core 7
Posts: 208

Rep: Reputation: 30
Just to make sure... You do that as root...
 
Old 05-15-2004, 03:29 AM   #7
icoming
Member
 
Registered: Feb 2004
Posts: 96

Original Poster
Rep: Reputation: 15
when I use redhat-config-language , if I wasn't root, it would ask me for password.
and i type the password
 
Old 06-01-2004, 09:42 AM   #8
lphlee
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
Sorry but I actually selected the default to be english during the installation progress.
But now, I found that the system hide all the files that has been named in chinese...
i.e., i cant access any file which has been named with a chinese file name....

Is there anyway to amend this bit? I stil want to retain the system interface to be in English.
Thz..
 
Old 06-01-2004, 01:06 PM   #9
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
perhaps your system "hides" the files whose names it can't display...if it uses english and the names are in chinese, then it may get problems so it simply puts them aside (only an assumption).

if you change locales, then the one you need to change is LC_CTYPE I think. it manages just the charsets, like if I use english language but want to use some scandinavian charset, I use some scandinavian LC_CTYPE and english LC_LANG etc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Change default language Slackware 10.2 RockmanExe Slackware 8 11-11-2005 01:50 PM
How to change system default dbus to version 0.23??? okeyla Linux - Newbie 0 10-27-2005 02:31 AM
how to change default operating system boot-up malb Linux - Newbie 5 07-26-2005 01:22 PM
How can I re-set up default language for my system? backpacker Linux - Newbie 6 06-28-2005 04:07 AM
default system desktop ? how to change? hvinelinux Fedora 5 01-27-2005 02:27 PM


All times are GMT -5. The time now is 02:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration