LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 12-19-2005, 12:08 PM   #1
sepetar
LQ Newbie
 
Registered: Dec 2005
Location: Banja Luka
Distribution: Slackware 10.2
Posts: 5

Rep: Reputation: 0
How to change KDE default Ctrl+Alt+K for changing language into Alt+Shift


The default KDE configuration creates a lot of problems, when jumping from en_us to serbian_cyrillic...
I tried to solve this problem but i failed...
I used xev,xmodmap...
Does someone have time to check this?
Thanks
 
Old 12-20-2005, 08:37 AM   #2
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Rep: Reputation: 33
Go to kcontrol, you can change any short cut key there.
You have KDE default config cause problems, what kind of problems are they
 
Old 12-21-2005, 09:35 AM   #3
sepetar
LQ Newbie
 
Registered: Dec 2005
Location: Banja Luka
Distribution: Slackware 10.2
Posts: 5

Original Poster
Rep: Reputation: 0
when i change language to serbian_cyrillic then shortcut Ctrl+Alt+K isn't working anymore.

If i want to change shortcut from kcontrol i must use combination Alt+Shift+something

Can i change it to Alt+Shift only?
 
Old 12-22-2005, 05:36 AM   #4
TruongAn
Member
 
Registered: Dec 2004
Location: Vietnam (Việt Nam)
Distribution: Gentoo (desktop), Arch linux (laptop)
Posts: 728

Rep: Reputation: 33
Sorry, No
But you can change it to Alt+F1 -> Alt+F9
 
Old 12-22-2005, 05:50 AM   #5
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,950

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
You can change this from your xorg.conf. At the "keyboard" section add (or edit, if they exist) the following options:
Code:
Option "XkbLayout"  "us,sr"
Option "XkbOptions" "grp:alt_shift_toggle"
I think "sr" is the identifier for serbian. If it's not then change it accordingly.
 
Old 12-22-2005, 02:37 PM   #6
sepetar
LQ Newbie
 
Registered: Dec 2005
Location: Banja Luka
Distribution: Slackware 10.2
Posts: 5

Original Poster
Rep: Reputation: 0
bathory
Thanks
 
Old 12-28-2005, 05:06 AM   #7
sepetar
LQ Newbie
 
Registered: Dec 2005
Location: Banja Luka
Distribution: Slackware 10.2
Posts: 5

Original Poster
Rep: Reputation: 0
when i've posted here last time i didn't actually
try bathory's answer.
it's not working...
after editing xorg.conf the only thing that has changed ->
when i press Alt+Shift it's not asking for some other key anymore. I got something like this string into the field for changing shortcut

ISO Prev_Group
 
Old 12-28-2005, 09:12 AM   #8
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,950

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Did you disable the kxkb? It's the kde application you use to change languages by clicking the appropriate flag icon on the bottom right.
 
Old 01-04-2006, 06:35 AM   #9
sepetar
LQ Newbie
 
Registered: Dec 2005
Location: Banja Luka
Distribution: Slackware 10.2
Posts: 5

Original Poster
Rep: Reputation: 0
i did this ->

i've changed /root/.kde/.../kxkbrc

USE=true into USE=false


after logging off (or after restart) nothing has changed

Did i disable kxkb? If not, what do i need to do?
 
Old 01-04-2006, 07:06 AM   #10
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,950

Rep: Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341Reputation: 1341
Since I don't use KDE, I did a little search and found this.:
Quote:
It seems that kxkb (the "International Keyboard" KDE application that docks into the panel) overrides the xmodmap changes. So the best is to simply disable kxkb (there is a checkbox in its control module). Or run xmodmap ~/.Xmodmap from a terminal before use, but every keymap-switching in kxkb will lose this.
Hope that helps
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ctrl-Alt-Backspace Disabled by default - why?!? brother.sand Debian 4 09-28-2005 03:32 PM
changing the keyboard with alt-shift in KDE dvm Linux - Software 3 05-23-2005 05:47 PM
How do you press Ctrl,Alt and shift? littertiger Programming 4 05-17-2005 04:00 AM
dark screen when pressing Ctrl + Alt + Backspace or Ctrl + Alt F1-F6 in Gnome or KDE trinoo Slackware 5 01-28-2005 09:13 AM
X freezes when changing screens (pressing CTRL+ALT+*1-7) Glover Linux - General 1 06-28-2002 04:50 PM


All times are GMT -5. The time now is 10:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration