LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   How to change KDE default Ctrl+Alt+K for changing language into Alt+Shift (http://www.linuxquestions.org/questions/linux-general-1/how-to-change-kde-default-ctrl-alt-k-for-changing-language-into-alt-shift-394523/)

sepetar 12-19-2005 11:08 AM

How to change KDE default Ctrl+Alt+K for changing language into Alt+Shift
 
The default KDE configuration creates a lot of problems, when jumping from en_us to serbian_cyrillic...
I tried to solve this problem but i failed...
I used xev,xmodmap...
Does someone have time to check this?
Thanks

TruongAn 12-20-2005 07:37 AM

Go to kcontrol, you can change any short cut key there.
You have KDE default config cause problems, what kind of problems are they

sepetar 12-21-2005 08:35 AM

when i change language to serbian_cyrillic then shortcut Ctrl+Alt+K isn't working anymore.

If i want to change shortcut from kcontrol i must use combination Alt+Shift+something

Can i change it to Alt+Shift only?

TruongAn 12-22-2005 04:36 AM

Sorry, No
But you can change it to Alt+F1 -> Alt+F9

bathory 12-22-2005 04:50 AM

You can change this from your xorg.conf. At the "keyboard" section add (or edit, if they exist) the following options:
Code:

Option "XkbLayout"  "us,sr"
Option "XkbOptions" "grp:alt_shift_toggle"

I think "sr" is the identifier for serbian. If it's not then change it accordingly.

sepetar 12-22-2005 01:37 PM

bathory
Thanks

sepetar 12-28-2005 04:06 AM

when i've posted here last time i didn't actually
try bathory's answer.
it's not working...
after editing xorg.conf the only thing that has changed ->
when i press Alt+Shift it's not asking for some other key anymore. I got something like this string into the field for changing shortcut

ISO Prev_Group

bathory 12-28-2005 08:12 AM

Did you disable the kxkb? It's the kde application you use to change languages by clicking the appropriate flag icon on the bottom right.

sepetar 01-04-2006 05:35 AM

i did this ->

i've changed /root/.kde/.../kxkbrc

USE=true into USE=false


after logging off (or after restart) nothing has changed

Did i disable kxkb? If not, what do i need to do?

bathory 01-04-2006 06:06 AM

Since I don't use KDE, I did a little search and found this.:
Quote:

It seems that kxkb (the "International Keyboard" KDE application that docks into the panel) overrides the xmodmap changes. So the best is to simply disable kxkb (there is a checkbox in its control module). Or run xmodmap ~/.Xmodmap from a terminal before use, but every keymap-switching in kxkb will lose this.
Hope that helps


All times are GMT -5. The time now is 04:22 AM.