LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   how to automatically power off after shutdown in redhat7.3(kernel 2.4.20) (http://www.linuxquestions.org/questions/linux-general-1/how-to-automatically-power-off-after-shutdown-in-redhat7-3-kernel-2-4-20-a-38719/)

prad 12-17-2002 11:42 PM

how to automatically power off after shutdown in redhat7.3(kernel 2.4.20)
 
I have updated my kernel from 2.4.18 to 2.4.20, now my redhat can't automatically poweroff after shutdown, what I should do?

nxny 12-18-2002 12:33 AM

How did you update your kernel? Did you compile it or use an rpm?

prad 12-18-2002 12:39 AM

Quote:

Originally posted by nxny
How did you update your kernel? Did you compile it or use an rpm?
I compile the kernel and select "Power Management support",what I should do next?

mcleodnine 12-18-2002 01:42 AM

Did you choose ACPI or APM for your kernel power support?

Is the APM module(if that's what you had before) loaded and do you have 'apmd' running?

If you're using ACPI is your BIOS capable and configured to support it?

prad 12-18-2002 02:17 AM

Quote:

Originally posted by mcleodnine
Did you choose ACPI or APM for your kernel power support?

Is the APM module(if that's what you had before) loaded and do you have 'apmd' running?

If you're using ACPI is your BIOS capable and configured to support it?

This is part of my kernal config file,could u tell me where is wrong?

CONFIG_APM=y
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
# CONFIG_APM_DO_ENABLE is not set
CONFIG_APM_CPU_IDLE=y
# CONFIG_APM_DISPLAY_BLANK is not set
CONFIG_APM_RTC_IS_GMT=y
# CONFIG_APM_ALLOW_INTS is not set
# CONFIG_APM_REAL_MODE_POWER_OFF is not set

mcleodnine 12-18-2002 04:13 AM

looks ok to me. Try 'ps -e | grep apm' and see what you get.

prad 12-18-2002 05:10 AM

Quote:

Originally posted by mcleodnine
looks ok to me. Try 'ps -e | grep apm' and see what you get.
root 495 1 0 17:04 ? 00:00:00 /usr/sbin/apmd -p 10 -w 5 -W -P

nxny 12-18-2002 03:30 PM

For some buggy bios-es you might have to turn on CONFIG_APM_REAL_MODE_POWER_OFF, I've heard. What are your ACPI config directives?

mcleodnine 12-18-2002 03:37 PM

If you're depending on APM the maybe we should be sure that ACPI hasn't assterted itself instead. 'lsmod | grep ospm'


All times are GMT -5. The time now is 01:36 AM.