LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-12-2004, 11:37 AM   #1
axess_denied
Member
 
Registered: Jun 2004
Location: DC Metro Area
Distribution: Ubuntu 8.10
Posts: 35

Rep: Reputation: 15
How do I get my kernel to support NTFS file systems?


I have tried to configure the kernel, no luck with the directions I used, so I am stuck... I have media on my secondary harddrive (Windows XP is the OS) and the file system that was installed is NTFS, okay. So, now what do I do?

# mount -t ntfs /dev/hdb1 /mnt/Windows
mount: fs type ntfs not supported by kernel

I have done
make
make modules_install
install
after configuring kernel... WHAT NOW... I am sooo lost, I just want my files
 
Old 06-12-2004, 12:03 PM   #2
crazyeddie740
Member
 
Registered: May 2004
Location: Sedalia, MO
Distribution: Debian, Mandrake
Posts: 50

Rep: Reputation: 15
You might try mounting it read-only (check the mount man page on how to do this). You might also want to see if Fedora calls ntfs something funky. NTFS read support is pretty standard these days, and Fedora 2 should support it out of the box. Write support is still *very* experimental though, and that could be what's doing you in.

For sharing files across the two OSs, I personally have about a 30GB ntfs partition for windows, 30GB ext2 for Linux, and vast expanses of FAT32 for actual data files. However, that might not be an option for you.

If you can backup your Windows data to another computer, you might want to try putting a 20GB Linux partition and a 20 GB Windows partition on the same drive, and use all 40 GB of the second drive as FAT32. Windows XP can't format more than 32 GB FAT 32, but it can mount it up to some very large number. So if you go that route, you'll have to format the drive from linux (Knoppix would probably be your best bet.) But it's worrisome that you can't read NTFS.
 
Old 06-12-2004, 01:12 PM   #3
John5788
Member
 
Registered: Feb 2004
Location: 127.0.0.1
Distribution: Gentoo
Posts: 129

Rep: Reputation: 15
maybe u have ntfs compiled as a module..
 
Old 06-12-2004, 02:28 PM   #4
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,850

Rep: Reputation: 736Reputation: 736Reputation: 736Reputation: 736Reputation: 736Reputation: 736Reputation: 736
Redhat does not provide NTFS support out of the box. See below
http://linux-ntfs.sourceforge.net/
 
Old 06-14-2004, 01:04 PM   #5
crazyeddie740
Member
 
Registered: May 2004
Location: Sedalia, MO
Distribution: Debian, Mandrake
Posts: 50

Rep: Reputation: 15
It doesn't? Not even read-only? huh. learn something new everyday.
 
Old 06-14-2004, 09:59 PM   #6
nanovirus
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
umm well im having the smae problem...is there a way to get ntfs support??
 
Old 06-15-2004, 08:03 AM   #7
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
NTFS suppoer it available in fedora core 2 kernel source, but it not compiled as default.
you will need to re-compile your kernel.

i know you tried this, but you obviously did it in--correctly.

cd into the kernel source.

then
Code:
make menuconfig
select "load configureation from file"
load the Config gile in your /boot/ directory.
navigate through the menu to the File system section.
find NTFS and enable NTFS Read Only support.
Save and exit.

now
Code:
make bzImage
make modules
make modules_install
make install
now open your /boot/grub/grub.conf file with kedit or gedit as root
if there is a line that looks like "kernel /vmlinuz-2.6.6 root=LABEL=/"

then replace the 'LABEL=/' with /dev/hda2 (or wherever your linux root partiton is.

/dev/hda1 = primart master partiton 1
/dev/hda2 = primary master parttion 2
/dev/hdb1 = primary slave partion 1
/dev/hdb2 = primary slave partiton 2

now reboot, and select your new kernel from the options.

try to mount with the disk as you did before... (as root)
if this fails with the driver error, then as root give the command
Code:
modprobe ntfs
now try to mount again.

if this works (which it will if you do it correctly, it did for me)
you can add the windows partiton to /etc/fstab.
and add the line "modprobe ntfs" to /etc/rc.d/rc.local" to automatically load the ntfs driver on bootup.

let us know if you get it all working.

okay ???

OR, you could try looking for a Fedora Core 2 NTFS driver in RPM form ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
NTFS vs Ext File Systems Ken Ju-On Linux - General 15 05-24-2009 11:47 PM
Which file systems does Solaris 10 support? Eerath Solaris / OpenSolaris 4 07-25-2005 07:19 AM
copying from NTFS file systems to USB cd burner sowboy Linux - Newbie 3 01-02-2005 08:18 AM
NTFS file system support zokter Linux - General 7 10-20-2003 11:17 AM
Mounting NTFS File Systems quorn Linux - General 7 10-09-2003 02:56 PM


All times are GMT -5. The time now is 03:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration