LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 07-20-2004, 02:51 PM   #1
steve_f60
Member
 
Registered: Jul 2004
Posts: 43

Rep: Reputation: 15
How do I disable the Right Click function on the mouse???


I am making a Kiosk set up using SuSE 9.0 & KDE 3.1. Is there a way to completely disable the Right Click function for the mouse? I only want the users to be able to left click on anything.

Thanks,

Steve
 
Old 07-20-2004, 04:29 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
open up KDE control center........click desktop> behavior
and you can configure mouse control all you like.........

Last edited by 320mb; 07-20-2004 at 04:35 PM.
 
Old 07-20-2004, 05:04 PM   #3
steve_f60
Member
 
Registered: Jul 2004
Posts: 43

Original Poster
Rep: Reputation: 15
Thanks for the response

I tried the optionin the Control Center, it only affects the right click on the DESKTOP, not for anything else like the kick panel or of you right click on an Icon.

Thanks Again,

Steve
 
Old 07-21-2004, 09:17 AM   #4
steve_f60
Member
 
Registered: Jul 2004
Posts: 43

Original Poster
Rep: Reputation: 15
ANyone ???
 
Old 07-21-2004, 09:28 AM   #5
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Rep: Reputation: 30
Look under the mouse section of your XF86Config (or xorgconfig if you're on a system using xorg)... IIRC, there's a spot where you tell X the number of buttons the mouse has... set it to "1".
 
Old 07-21-2004, 09:29 AM   #6
oot
Member
 
Registered: Dec 2002
Distribution: Slackware 12.0
Posts: 240

Rep: Reputation: 30
Oh, and if the line doesn't exist yet, just add in the section for your mouse device
Option "Buttons" "1"
 
Old 07-21-2004, 02:59 PM   #7
steve_f60
Member
 
Registered: Jul 2004
Posts: 43

Original Poster
Rep: Reputation: 15
You got it !!!!

I had tried different changes to the XF86 before but those changes didn't fix the problem & in some cases, changing the file for the pointer would prevent KDE from opening at all.

Just added the Button option & thats all I needed.

Thanks Very Much !

Steve
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How can I disable Mouse Right Click in KDE? steve_f60 Linux - Software 1 11-02-2005 01:48 PM
disable touchpad mouse-click paulwhalley Slackware 1 10-30-2005 08:07 AM
mouse: single-click becomes double-click kinzlaw Linux - Hardware 2 08-24-2005 07:55 PM
Trackpad taps to click easily on Dell laptop with SuSE; Knob-mouse does not function binarybase Linux - Newbie 4 08-07-2005 04:55 PM
how to disable right-click in konqueror? crewler Linux - Newbie 2 07-12-2004 02:47 PM


All times are GMT -5. The time now is 05:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration