LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-12-2002, 12:20 PM   #1
amp2000
Member
 
Registered: Oct 2001
Location: Dublin, Ireland
Distribution: Mandrake 9.0 mostly!
Posts: 303

Rep: Reputation: 30
Talking How do I disable proftpd on startup


I just re-installed Mandrake for the tenth time & it freezes on startup while trying to start proftpd.
Which file do I turn this off in so it dosent try & start when booting.
Help, Im in windows sending this
 
Old 02-12-2002, 12:22 PM   #2
lfslinux
LFS Maintainer
 
Registered: Jan 2002
Location: Canmore, Alberta, Canada
Distribution: Linux From Scratch
Posts: 372

Rep: Reputation: 30
Re: How do I disable proftpd on startup

Quote:
Originally posted by amp2000
I just re-installed Mandrake for the tenth time & it freezes on startup while trying to start proftpd.
Which file do I turn this off in so it dosent try & start when booting.
Help, Im in windows sending this
You can do this easiest by removing the symbolic link in the rc3.d directory (this assumes that runlevel 3 is your default runlevel, which it most likely is).

This directory is usually located as /etc/rc.d/rc3.d or /etc/rc3.d

In that directory you'll find a file called Sxxproftpd (xx is a two digit number). Remove that file (or rename it into something that doesn't start with an S) and proftpd shouldn't be starting anymore. You can always re-create the symbolic link later on when you need it again.
 
Old 02-12-2002, 12:24 PM   #3
amp2000
Member
 
Registered: Oct 2001
Location: Dublin, Ireland
Distribution: Mandrake 9.0 mostly!
Posts: 303

Original Poster
Rep: Reputation: 30
Shit you type fast, I posted this less than 2 mins ago.

Thanks, I'll try that
 
Old 02-12-2002, 12:31 PM   #4
lfslinux
LFS Maintainer
 
Registered: Jan 2002
Location: Canmore, Alberta, Canada
Distribution: Linux From Scratch
Posts: 372

Rep: Reputation: 30
Quote:
Originally posted by amp2000
Shit you type fast, I posted this less than 2 mins ago.

Thanks, I'll try that
Lol you make it sound that it's such a bad thing
 
Old 02-12-2002, 12:43 PM   #5
amp2000
Member
 
Registered: Oct 2001
Location: Dublin, Ireland
Distribution: Mandrake 9.0 mostly!
Posts: 303

Original Poster
Rep: Reputation: 30
I installed grub which I am not familiar with & I cant even get to runlevel3, I didnt set it as default when installing.
And yes I did click no the 10 times I was asked did I want to create a bootdisk when I was installing Mandrake never again

How can I get to a prompt where I can move around logged in as root & fix this mess.

Any ideas???

thanks in advance
 
Old 02-12-2002, 03:08 PM   #6
lfslinux
LFS Maintainer
 
Registered: Jan 2002
Location: Canmore, Alberta, Canada
Distribution: Linux From Scratch
Posts: 372

Rep: Reputation: 30
Quote:
Originally posted by amp2000
I installed grub which I am not familiar with & I cant even get to runlevel3, I didnt set it as default when installing.
And yes I did click no the 10 times I was asked did I want to create a bootdisk when I was installing Mandrake never again

How can I get to a prompt where I can move around logged in as root & fix this mess.

Any ideas???

thanks in advance
What exactly is working? Does Grub show you the GUI interface where you select which OS to boot?
 
Old 02-12-2002, 03:19 PM   #7
amp2000
Member
 
Registered: Oct 2001
Location: Dublin, Ireland
Distribution: Mandrake 9.0 mostly!
Posts: 303

Original Poster
Rep: Reputation: 30
Ye I have the GUI that is saying starting such & such
I managed to get into an interactive startup in grub & bypassed proftpd but locked up when mandrake was starting mouse console services.
I now cant remember how I got into that interactive startup.
I'm still trying to get back to that interactive startup where I confirm whet I do & dont want started.
Any help at all would be appreciated.
Thanks
 
Old 02-12-2002, 03:26 PM   #8
lfslinux
LFS Maintainer
 
Registered: Jan 2002
Location: Canmore, Alberta, Canada
Distribution: Linux From Scratch
Posts: 372

Rep: Reputation: 30
Quote:
Originally posted by amp2000
Ye I have the GUI that is saying starting such & such
I managed to get into an interactive startup in grub & bypassed proftpd but locked up when mandrake was starting mouse console services.
I now cant remember how I got into that interactive startup.
I'm still trying to get back to that interactive startup where I confirm whet I do & dont want started.
Any help at all would be appreciated.
Thanks
I don't use Mandrake so I can be of little assistance here. All I can tell you that it's not related to Grub. All Grub does is load your Linux kernel. Whatever the system does or doesn't do is determined by Mandrake's init system.

Perhaps it's a question of hitting some kind of key during the boot process? I recall Redhat having something to that effect (pressing the "I" key when asked for, it'll go in interactive mode)
 
Old 02-12-2002, 03:32 PM   #9
amp2000
Member
 
Registered: Oct 2001
Location: Dublin, Ireland
Distribution: Mandrake 9.0 mostly!
Posts: 303

Original Poster
Rep: Reputation: 30
Thanks lsflinux
I just copped on it's I to go interactive, I got it just before I got your reply.
I stil havent got my system up and running but I'm alot closer.
Thanks again lsflinux
 
Old 02-12-2002, 03:47 PM   #10
amp2000
Member
 
Registered: Oct 2001
Location: Dublin, Ireland
Distribution: Mandrake 9.0 mostly!
Posts: 303

Original Poster
Rep: Reputation: 30
I had to re-install but at least I'm back in Linux.
Now I just have to fix everything

Last edited by amp2000; 02-12-2002 at 04:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
proftpd: proftpd startup failed tumana Linux - Newbie 14 06-17-2012 11:06 AM
Disable PCMCIA on startup Peanutman Fedora 3 08-12-2005 04:58 AM
Disable Modules on startup Kane2002 Slackware 10 01-22-2005 04:26 PM
disable x in fc1 on startup ngophat Linux - Software 3 07-31-2004 06:12 PM
Disable XWindow on Startup Dijeeh Linux - Newbie 2 03-22-2003 02:47 PM


All times are GMT -5. The time now is 01:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration