LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 02-17-2007, 08:21 PM   #1
tallmtt
Member
 
Registered: Jun 2005
Location: Georgia, USA
Distribution: Arch, Gentoo, Ubuntu
Posts: 91

Rep: Reputation: 15
How do I disable "lock screen" in Gnome.


I am configuring a new remote for my MythTV box (running Ubuntu Edgy, Myth 0.20) and one of the buttons locks the screen! I have successfully attributed "Escape" button to it through xmodmap, and its keycode does not seem to be mapped to anything else!

I tried to change the key that locks the screen - in /etc/acpi/lockbtn.sh it says:
acpi_fakekey $KEY_COFFEE

and I commented it out without results

I then attempted to change the /usr/share/acpi-support/key-constants and put the keycode for the button I want to lock the screen instead of $KEY_COFFEE but that also failed to fix the issue

I am pulling out my hair!!!

The stupid button on the remote still locks the screen and the one I want for that function does nothing!

If I can't find the answer soon - I might just uninstall xscreensaver (I think that has the program to lock the screen - if not - please tell me ). I would rather not be able to lock the screen than to be unable to get this button to stop locking it.

Thanks for any reply and attempt for help.
 
Old 02-18-2007, 06:28 AM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
I may be way off base here, but in Gnome, if you go to System -> Preferences -> Keyboard Shortcuts, one of "keyboard shortcuts" you will find is for locking the screen. I was actually playing with that yesterday, and either I couldn't figure out which key that was mapped to (I wasn't sure I was reading it right) or it didn't work. But you might try disabling it (apparently by clicking on it and hitting backspace) and see if that helps.

Good luck. (A am still learning edgy/Gnome 2.x myself!)
 
Old 02-18-2007, 01:02 PM   #3
tallmtt
Member
 
Registered: Jun 2005
Location: Georgia, USA
Distribution: Arch, Gentoo, Ubuntu
Posts: 91

Original Poster
Rep: Reputation: 15
Thanks for your reply. I have tried that route, according to the Gnome Keyboard Shortcuts - the "lock screen" shortcut is disabled. Go figure, huh?


Thanks anyways for your help. Good luck learning Edgy - it is a great distro and very easy to use with lots of people to help out. Have fun with it.


I feel like the solution will be through the commandline - any other ideas people?
 
Old 06-28-2007, 07:14 AM   #4
alfayate
LQ Newbie
 
Registered: Jun 2007
Distribution: Debian and Ubuntu
Posts: 1

Rep: Reputation: 0
Disable lock screen

Quote:
Originally Posted by tallmtt
Thanks for your reply. I have tried that route, according to the Gnome Keyboard Shortcuts - the "lock screen" shortcut is disabled. Go figure, huh?


Thanks anyways for your help. Good luck learning Edgy - it is a great distro and very easy to use with lots of people to help out. Have fun with it.


I feel like the solution will be through the commandline - any other ideas people?
Hi.

I was trying to disable the "lock screen" button in Ubuntu. I managed to do that by entering this command as root:

chmod o-x /usr/bin/gnome-screensaver-command

I guess that will prevent users to use the "gnome-screensaver-command --lock" that is the command used in Gnome to launch and lock the screensaver.
 
Old 07-09-2007, 11:05 AM   #5
tallmtt
Member
 
Registered: Jun 2005
Location: Georgia, USA
Distribution: Arch, Gentoo, Ubuntu
Posts: 91

Original Poster
Rep: Reputation: 15
Thank you.
 
  


Reply

Tags
acpid, mythtv, ubuntu610


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GDM "Lock screen" item fails to lock down. Swan1 Suse/Novell 9 02-03-2009 12:00 AM
"Lock Screen" is not working on Fedora Core 5 jialin Fedora 2 04-05-2008 08:37 AM
"Lock Screen" in Gnome not working SlowCoder Linux - Newbie 0 05-27-2006 07:12 PM
Add "Lock Screen" to CtrlAltDel panel bill.ramby Linux - Software 4 04-05-2005 02:30 PM
"lock screen" locks whole system Cheechi Suse/Novell 0 02-11-2005 07:21 AM


All times are GMT -5. The time now is 11:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration