LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-10-2013, 04:31 AM   #1
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 275

Rep: Reputation: 14
Question How do I auto mount SD card with Thunar instead of Shotwell by default in Xfce?


Hi.

I'm using Linux Mint 13 Xfce. I want it to open an SD card with my file manager instead of Shotwell by default. How can I do that?

Thanks.
 
Old 06-10-2013, 02:53 PM   #2
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,021

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Hi there,

Quote:
Originally Posted by LinusStallman View Post
I'm using Linux Mint 13 Xfce. I want it to open an SD card with my file manager instead of Shotwell by default.
I'm not sure if I really understand your question. I'm also using Linux Mint 12 and 13, though not with Xfce, but MATE instead. But I know Xfce from Xubuntu.

However, when I plug in an SD card, it simply shows up as an additional media in whatever file manager I'm using, and it gets auto-mounted to a directory in /media. Therefore I've got some difficulty in imagining what you mean by the wording "open an SD card". I've never "opened an SD card", I rather open the files on it, and I do so with whatever application I consider fit for that purpose.

So ... what precisely is your concern?

[X] Doc CPU
 
Old 06-10-2013, 07:25 PM   #3
itsgregman
Member
 
Registered: Jan 2008
Location: North Carolina
Distribution: Pclinuxos, Slackware, salix
Posts: 146

Rep: Reputation: 37
I'm with doc on this one.
I can't envision what problem you could be having either.

With a quick look at the users manual at yorba.org , it appears Shotwell can be set to run automatically when a camera is connected to your system, possibly that is what is happening with you SD card. You can try looking in the Shotwell settings, sorry I can't give more on that as I don't have Shotwell.

If it's an issue with the picture files you can try changing the defualt app used for pictures, if that doesn't help you can always change it back.
 
Old 06-11-2013, 03:02 AM   #4
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 275

Original Poster
Rep: Reputation: 14
Hi Doc CPU and itsgregman.

Ok. When I insert the SD card into the card reader it automounts (which is fine). Previously I used to then get an option to 'Open with file manager', 'Open with Shotwell', 'Do nothing', etc. - but I accidentally chose Shotwell and had checked the option that said something like 'remember this or always do this'. I want my SD card automatically launched by Thunar.
 
Old 06-11-2013, 04:01 AM   #5
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,021

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Hi there,

Quote:
Originally Posted by LinusStallman View Post
Ok. When I insert the SD card into the card reader it automounts (which is fine). Previously I used to then get an option to 'Open with file manager', 'Open with Shotwell', 'Do nothing', etc. - but I accidentally chose Shotwell and had checked the option that said something like 'remember this or always do this'. I want my SD card automatically launched by Thunar.
ah, now I think I understand, you mean this "Auto-Run" feature, as they call it in Windows, which I disabled completely because I find it annoying. *g*

In Nautilus (GNOME) or Caja (its MATE counterpart) I just select Edit/Preferences, then click the "Media" tab. That's where I can choose what happens automatically when I attach or insert a particular media.

I don't currently have an Xfce or Thunar to lay hands on, but Google pointed me to this:
http://tillamookrage.blogspot.de/200...automount.html
The author of this blog entry admits that this is difficult to find in Xfce, though. But beware: It's is from 2008, but the only thing I could quickly find on the topic. Wording, appearance and one or the other detail may have changed since.

Good luck.

[X] Doc CPU
 
Old 06-11-2013, 05:55 AM   #6
itsgregman
Member
 
Registered: Jan 2008
Location: North Carolina
Distribution: Pclinuxos, Slackware, salix
Posts: 146

Rep: Reputation: 37
You could try going to the Xfce "settings manager" then choosing "removable drives and media", then on "storage" tab under "removable storage" make sure "autorun programs on new drives and media" is unchecked. You should also check under the "camera" tab and make sure "import digital photographs when connected" doesn't have shotwell as the command and if it does uncheck it also.
 
Old 06-11-2013, 12:39 PM   #7
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 275

Original Poster
Rep: Reputation: 14
Lightbulb

Quote:
Originally Posted by Doc CPU View Post
...In Nautilus (GNOME) or Caja (its MATE counterpart) I just select Edit/Preferences, then click the "Media" tab. That's where I can choose what happens automatically when I attach or insert a particular media...
In Caja, I changed the settings under the media tab. Done!

Although if I didn't have Caja, I would not know how to sort this out with Thunar.

Thanks guys.
 
Old 06-11-2013, 01:38 PM   #8
Doc CPU
Senior Member
 
Registered: Jun 2011
Location: Stuttgart, Germany
Distribution: Mint, Debian, Gentoo, Win 2k/XP
Posts: 1,021

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Hi there,

Quote:
Originally Posted by LinusStallman View Post
In Caja, I changed the settings under the media tab. Done!
that sounds like some success after all.

Quote:
Originally Posted by LinusStallman View Post
Although if I didn't have Caja, I would not know how to sort this out with Thunar.
You couldn't use the hints I offered you by means of a link? What was the problem? Stale, out of date information?

[X] Doc CPU
 
Old 06-12-2013, 02:23 AM   #9
LinusStallman
Member
 
Registered: Mar 2010
Location: Ireland
Distribution: Linux Mint 17 MATE
Posts: 275

Original Poster
Rep: Reputation: 14
Quote:
Originally Posted by Doc CPU View Post
...You couldn't use the hints I offered you by means of a link? What was the problem? Stale, out of date information?[X] Doc CPU
I couldn't find out how to auto mount the SD card contents with Thunar. Although if I had not Caja installed, Thunar may be fine.

Cheers Doc CPU.
 
  


Reply

Tags
mount, sd card, xfce


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
thunar service not started -- cygwin and xfce mtdew3q Linux - Desktop 2 02-25-2013 01:35 PM
Xfce's Thunar automount issue dunric Slackware 1 11-20-2012 05:01 PM
LXer: Shotwell 0.7.2 Released, How to Install Shotwell 0.7.2 in Ubuntu Lucid, Maverick LXer Syndicated Linux News 0 09-11-2010 11:51 PM
Thunar, FluxBox & auto mount CopyrightPhilly Linux - Software 1 05-14-2009 01:06 PM
Help on XFCE thunar-archive-plugin igorthinks Linux - Desktop 1 08-21-2008 09:58 AM


All times are GMT -5. The time now is 04:11 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration