LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 12-04-2003, 02:49 AM   #1
frankli
LQ Newbie
 
Registered: Dec 2003
Posts: 25

Rep: Reputation: 15
How can I get tftp server run on Redhat 9.0


I have installed tftp-0.32-4.rpm and tftp-server-0.32-4.rpm on my redhat9.0,and the tftp script in /etc/xinetd.d/tftp is like this.
service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -c -s /tftpboot
disable = no
per_source = 11
cps = 100 2
}
I have two network card.one ip is 10.5.25.91,one ip is 192.168.0.1.I made a bridge between the two cards which named br0,the ip address is 192.168.1.1.I can ping 192.168.1.1 in a win2000 machine.so I put 1.txt in /tftpboot.I typed the command like this in win2000 command line:
tftp 192.168.11get 1.txt
but it always says time out.
when I type command in my redhat 9.0
tftp 192.168.1.1
tftp> get 1.txt
Transfer timed out.
Does anybody can tell me why and how to get it run?
 
Old 12-04-2003, 05:14 AM   #2
iainr
Member
 
Registered: Nov 2002
Location: England
Distribution: Ubuntu 9.04
Posts: 631

Rep: Reputation: 30
Don't know, but here is my tftp file which works fine.

service tftp
{
disable = no
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -s /lts
per_source = 11
cps = 100 2
flags = IPv4
}
 
Old 12-04-2003, 06:40 PM   #3
frankli
LQ Newbie
 
Registered: Dec 2003
Posts: 25

Original Poster
Rep: Reputation: 15
I changed my file like yours but it still did not work.I close my firewall and try again, still time out.I can see the udp/69 tftp by using nmap .So why ?I can't understand.
 
Old 12-05-2003, 02:23 AM   #4
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
I've just tried this. My tftp config file is not radically different from yours. I got it to work, both from another Linux machine and my Win2000 machine.

After editing the config file to turn on tftp, did you remember to restart xinetd? (/etc/rc.d/init.d/xinetd restart)

And the obvious question; did you open the firewalls? Both on Linux and Windows? I know, cause I've tried to contact the tftp server on a Linux machine with the firewall closed. There, I admitted it first, now it won't feel as bad for you if you've done what I did

Regards
Martin
 
Old 12-05-2003, 02:33 AM   #5
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
One more comment, sorry if I bore you.

If the tftp server is running (started by xinetd) then you will see it in the listing of processes.
Code:
~> ps -aux | grep tftpd
root      1771  0.0  0.2  1800  492 ?        S    09:16   0:00 in.tftpd -s /tftpboot
root      1806  0.0  0.3  3580  628 pts/0    S    09:29   0:00 grep tftpd
Regards
Martin
 
Old 12-06-2003, 01:50 AM   #6
frankli
LQ Newbie
 
Registered: Dec 2003
Posts: 25

Original Poster
Rep: Reputation: 15
Thanks for your help.When I use a notebook to tftp my machines,I can see the lines like yours.So I'm sure that my tftpd is running.But when I use command "setup " to check my firewall,I saw something like this:
Security Level:High.I tried many times to change it to No firewall,but after I restart my machine I found it still High.So How can I close my firewall?

best regards
 
Old 12-06-2003, 03:58 AM   #7
frankli
LQ Newbie
 
Registered: Dec 2003
Posts: 25

Original Poster
Rep: Reputation: 15
Now I can get it run correctly.The only change is "server_args "
service tftp
{
socket_type = dgram
protocol = udp
wait = yes
user = root
server = /usr/sbin/in.tftpd
server_args = -c -s /tftphost
disable = no
per_source = 11
cps = 100 2
}
Thanks for your help!
 
Old 12-13-2003, 02:21 PM   #8
rjwright
LQ Newbie
 
Registered: Oct 2003
Distribution: debian
Posts: 29

Rep: Reputation: 15
I am having a similar problem, I su to root and run
# /etc/xinetd.d/tftp
get permission denied

why is this happening I should be able to start the process as root right?
I think I am missing somthing, I havent looked at the firewall yet, would this be caused by the fire wall?
 
Old 12-13-2003, 04:24 PM   #9
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
The tftp daemon is started by xinetd. You need a line in your /etc/xinetd.d/tftp that reads
disable = no
(see the example files above)
then the tftpd should be automatically started by xinetd.

Regards
Martin
 
Old 12-13-2003, 05:09 PM   #10
rjwright
LQ Newbie
 
Registered: Oct 2003
Distribution: debian
Posts: 29

Rep: Reputation: 15
I've gotten that far, but the tutorial I was reading (HOWTO Clone Disk Images on Linux Booted from a Network)
http://www.tldp.org/HOWTO/Clone-HOWTO/index.html
shows a cli
tftp>
it apears to be a command line interface and that is where I got lost,
I checked and it is running so how do I get this CLI?
 
Old 12-13-2003, 05:11 PM   #11
rjwright
LQ Newbie
 
Registered: Oct 2003
Distribution: debian
Posts: 29

Rep: Reputation: 15
I forgot to install the client I missed that part oops
sorry
 
Old 12-13-2003, 05:11 PM   #12
rjwright
LQ Newbie
 
Registered: Oct 2003
Distribution: debian
Posts: 29

Rep: Reputation: 15
I must be getting tired/ or lazy?
 
Old 12-13-2003, 10:23 PM   #13
rjwright
LQ Newbie
 
Registered: Oct 2003
Distribution: debian
Posts: 29

Rep: Reputation: 15
works fine now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
TFTP Server mattp Linux - Software 8 01-18-2010 04:28 PM
TFTP-Server Problem tomcat22 Slackware 1 11-17-2005 02:54 PM
inteligent tftp server truthbeliever Linux - Networking 0 10-31-2005 06:57 AM
tftp won't run jdraper Linux - Networking 3 07-27-2005 08:16 AM
Debian Tftp Server ac402 Linux - Software 0 12-27-2003 04:10 PM


All times are GMT -5. The time now is 03:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration