LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 11-07-2008, 02:39 PM   #1
JeffreyMoore
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Rep: Reputation: 0
How can I disable autocomplete or tab complete?


Using Linux in the bash shell with vi (or vim) as the keyboard editor, how can I disable the autocomplete or tab complete feature without disabling the keyboard editor?
 
Old 11-07-2008, 04:03 PM   #2
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
Have you tried to remove bash-completion with your package manager?

if you can not find it, it would be helpful to others to know your distro...use the control panel to show it like mine shows sidux please.
 
Old 11-08-2008, 06:15 PM   #3
JeffreyMoore
LQ Newbie
 
Registered: Nov 2008
Posts: 2

Original Poster
Rep: Reputation: 0
It's several machines, not just one. They all run Gentoo but they can only be reached via ssh, so I have no access to the control panel.

All of us use the same login ID, so I can't change the readline initialization script. Is there a way to turn tab completion off temporarily from the command line? Or, failing that, is there a way to have readline read a different initialization script after login?
 
Old 11-09-2008, 04:53 PM   #4
aus9
Guru
 
Registered: Oct 2003
Posts: 5,056

Rep: Reputation: Disabled
sorry do not use Gentoo. In Mandriva you could use a terminal to launch the control panel with command mcc. Maybe there is a command you can search for in /usr/bin called gentoo* ?

if no-one replies to help you could post in the www.gentoo.org forum on how to launch a control panel thru ssh?
 
Old 11-09-2008, 06:12 PM   #5
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,040

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
I depends on what exactly do you want to do.

If you just want to disable advanced autocompletion you can either use "complete -r" or remove /etc/bash_completion*

Reading the man page for "complete" might help here. It's a shell thing, it really doesn't have anything to do with a particular distro or another.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to disable autocomplete in KDE? kdingo00 Linux - Software 1 11-12-2006 01:05 PM
Tab autocomplete magic_ghost Linux - Software 1 03-17-2006 12:04 PM
Tab autocomplete like windows shell? lerceon Linux - Newbie 2 04-17-2005 09:25 PM
how can i disable autocomplete in firefox imagreg Linux - Software 3 06-12-2004 09:35 PM
openoffice spreadsheet questions: disable autocomplete, soft line-break and bugreport codec Linux - Software 0 04-28-2004 05:10 PM


All times are GMT -5. The time now is 10:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration