LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - General (http://www.linuxquestions.org/questions/linux-general-1/)
-   -   Higher Resolution (http://www.linuxquestions.org/questions/linux-general-1/higher-resolution-385580/)

muppski 11-22-2005 04:38 PM

Higher Resolution [Solved]
 
Hey , Im trying to set 1024x768 mode on the framebuffer once it boots up
up the monitor switches to 1024x768 then it switches back as its bootin up for some reason so im back to 640x480 anyways?!!?

Grub
Code:

kernel /boot/linux-2.6.14.2 root=/dev/hda1 video=vesafb vga=271
I tried without video=vesafb and tried alot of different vga=xxx
all ends up the same way

acid_kewpie 11-22-2005 05:06 PM

271 is not a valid mode, it'll be one of these...
Code:

Colours  640x480 800x600 1024x768 1280x1024 1600x1200
--------+--------------------------------------------
256    |  769    771      773      775      796
32,768  |  784    787      790      793      797
65,536  |  785    788      791      794      798
16.8M  |  786    789      792      795      799


muppski 11-22-2005 05:16 PM

Quote:

Originally posted by acid_kewpie
271 is not a valid mode, it'll be one of these...
Code:

Colours  640x480 800x600 1024x768 1280x1024 1600x1200
--------+--------------------------------------------
256    |  769    771      773      775      796
32,768  |  784    787      790      793      797
65,536  |  785    788      791      794      798
16.8M  |  786    789      792      795      799


it is when you run video=vesafb ;)

I tried without vesafb too as I said

I already tried those modes you posted too on vesafb and without vesafb so im pretty sure

http://www.antlinux.com/pmwiki/pmwik...owTos.VgaModes

acid_kewpie 11-22-2005 05:48 PM

no, it's not a valid mode, it's not in the chart you linked to for one... the range of the vga option will load vesafb extensions, there's no need to explicitly reference vesafb. personally my options are "vga=791 video=vesa:ywrap,mtrr"

muppski 11-22-2005 06:13 PM

Oki nevermind the mode 271
I tried many other modes 791 is the one I like to run
and it acts EXACTLY the same as if I do 271 or 771,787,773,790 etc

btw : the modes in the link you gotta convert to deciamal

0x317 - 1024x768x16 (317)
791 - 1024x768x16

I used all the modes in your table and it acts the same
are we clear on that? I also tried the 0x317 , and such

acid_kewpie 11-23-2005 02:42 PM

are you gonna stop telling me to do things wrongly? you do not need to convert those modes to Hex, if there is no leading 0x then it is taken as decimal, not hex.

so anyway... you've not said what distro you're using, and it'd also help if you define what the mode currently is.. you say it's 640x480, but is it really? are you not just describing a standard 80x25 character screen, without a framebuffer running at all?

muppski 11-25-2005 01:43 AM

I run LFS
The kernel is 2.6.14.2

I assume I have a framebuffer running beacuse some applications runs.
Like mame , zgv and such that requires a running framebuffer.( if im not wrong ) and that I selected framebuffer support in the kernel.

When I run Fbresolution it gives me
640x480

Otherwise is there other ways I can tell I'm running a framebuffer or not?
And if im not... why isent my framebuffer running?

muppski 11-30-2005 05:46 AM

I aquired a old PCI graphic card
(which is better then the i810 anyways)

The problem is gone , no matter res i set it stays now


All times are GMT -5. The time now is 04:55 AM.