Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 07-28-2006, 03:21 PM   #1
LQ Newbie
Registered: Jun 2005
Posts: 8

Rep: Reputation: 0
High loadavg, low CPU & iowait

I've got 4 servers, 2 of which are running Veritas Cluster Server (NFS only). The hardware on all 4 servers is identical. All 4 machines mount the NFS share exported by the active VCS node. The 2 machines running VCS (and VxVM) have LAs of 11+ (across 4 CPUs), whereas the other 2 have LAs of < 0.5. I can understand the active node having a high LA, but the inactive node should look more like the other 2 machines. The CPU utilization, swap utilization and iowait are almost 0.

Any ideas?
Old 07-28-2006, 03:44 PM   #2
Senior Member
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD
Posts: 2,114

Rep: Reputation: 330Reputation: 330Reputation: 330Reputation: 330
I've always wondered why I occassionally see higher load averages with low cpu utilization. As I understand it, load average is the number of processes waiting for a slot on the cpu (averaged over time). And if they're waiting for a slot it follows that this is because the cpu is busy. You'd think that if a process currently on the cpu was waiting on something else (io maybe), the kernel would turn the cpu over to a more deserving process ... but maybe not.

I'll be interested to see how others weigh in on this apparent paradox of high load average with high %idle and low %iowait (and low "everything else visible via 'top'"). The combination seems counterintuitive.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
CPU load high, top processes very low? Thinking Linux - Software 12 03-19-2007 12:59 AM
high iowait in RHES sklam Red Hat 20 12-14-2006 12:35 PM
nfsd & high system cpu % DotHQ Linux - General 3 06-06-2006 02:23 PM
CPUs in high IOwait state despite of lack of load kvsraju Linux - Enterprise 3 11-03-2005 03:34 PM
GKRELLM & CPU too High AceTech747 Linux - Hardware 8 01-04-2004 04:21 PM

All times are GMT -5. The time now is 11:28 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration