LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices



Reply
 
Search this Thread
Old 04-12-2009, 02:16 PM   #1
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Rep: Reputation: 45
HD4870 giving "Input Signal Out of Range" error


I am currently trying to install debian lenny. After the install process, it reboots and starts to load. When X loads, the screen flickers and eventually gives an Input Signal Out of Range error.

So I went about install the flgrx driver using Method 1.

But I still get the same message on my monitor.

xorg.conf
Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "ServerFlags"
	Option		"AIGLX" "off"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc104"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
EndSection

Section "Monitor"
	Identifier   "Configured Monitor"
	HorizSync    50.0 - 75.0
	VertRefresh  50.0 - 75.0
	Option	    "DPMS"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	Option	    "VendorName" "ATI Proprietary Driver"
	Option	    "ModelName" "Generic Autodetecting Monitor"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "Configured Video Device"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:2:0:0"
EndSection

Section "Screen"
	Identifier "Default Screen"
	Monitor    "Configured Monitor"
	Option	    "metamodes" "1280x1024_60 +0+0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Viewport   0 0
		Depth     24
	EndSubSection
EndSection

Section "Extensions"
	Option	"Composite" "Disable"
EndSection
The Monitor I am using

The Xorg.0.log file generates this
 
Old 04-13-2009, 09:37 AM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 372Reputation: 372Reputation: 372Reputation: 372
Thanks for the logs - they help.
Code:
(II) fglrx(0):  Display1: No EDID information from DDC.
(II) fglrx(0):  Display1: Failed to get EDID information.
So X doesn't know the capabilities of your monitor, and you'll have to supply H&V sync values and maybe more.

It is unusual for a monitor not to supply its EDID information, are you connecting to it with a standard VGA cable?

Starting X with
Code:
startx  --  -logverbose  6
will give you more information about why EDID is failing.

Also, you seem to have lots of double-entries in your xorg.conf

Try this as your xorg.conf (backup the old one)
Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
	Identifier     "aticonfig Layout"
	Screen      0  "aticonfig-Screen[0]-0" 0 0
	InputDevice    "Generic Keyboard" "CoreKeyboard"
	InputDevice    "Configured Mouse" "CorePointer"
EndSection

Section "ServerFlags"
	Option		"AIGLX" "off"
EndSection

Section "Files"
EndSection

Section "Module"
EndSection

Section "InputDevice"
	Identifier  "Generic Keyboard"
	Driver      "kbd"
	Option	    "XkbRules" "xorg"
	Option	    "XkbModel" "pc104"
	Option	    "XkbLayout" "us"
EndSection

Section "InputDevice"
	Identifier  "Configured Mouse"
	Driver      "mouse"
EndSection

Section "Monitor"
	Identifier   "aticonfig-Monitor[0]-0"
	HorizSync       24-80
	VertRefresh     49-75
	Option	    "VendorName" "AOpen"
	Option	    "ModelName" "F1713"
	Option	    "DPMS" "true"
EndSection

Section "Device"
	Identifier  "aticonfig-Device[0]-0"
	Driver      "fglrx"
	BusID       "PCI:2:0:0"
EndSection

Section "Screen"
	Identifier "aticonfig-Screen[0]-0"
	Device     "aticonfig-Device[0]-0"
	Monitor    "aticonfig-Monitor[0]-0"
	DefaultDepth     24
	SubSection "Display"
		Depth     24
		Modes     "1280x1024" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "Extensions"
	Option	"Composite" "Disable"
EndSection
And see how you get on.
You may need to supply additional information, but give it a try
.
 
Old 04-13-2009, 04:30 PM   #3
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Thanks for trying but that didn't help as well
 
Old 04-14-2009, 04:52 PM   #4
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
So this xorg.conf got vesa mode working

Code:
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Monitor		"Configured Monitor"
	Device		"Configured Video Device"
	Option		"metamodes" "1280x1024_60 +0+0"
	DefaultDepth	24
	SubSection "Display"
		Depth		24
		Modes		"1280x1024"
	EndSubSection
EndSection

Section "Module"
	Load	"glx"
EndSection

#Section "Device"
#	Identifier	"Configured Video Device"
#	Driver	"fglrx"
#	Driver	"radeon"
#EndSection

#Section "ServerFlags"
#	Option	"AIGLX"	"off"
#EndSection
When I enable fglrx, the svreen goes white and cat /var/log/Xorg.0.log | grep WW shows:
Code:
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11/100dpi/".
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11/75dpi/".
(WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11/100dpi".
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11/75dpi".
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
(WW) fglrx(0): Failed to open DRM connection
(WW) fglrx(0): board is an unknown third party board, chipset is supported
As an aside, the same xorg.conf worked with the latest Ubuntu beta when I used fglrx.

So is this likely some xserver-xorg issue (I am running testing btw)?

Quote:
It is unusual for a monitor not to supply its EDID information, are you connecting to it with a standard VGA cable?
I am using a VGA cable with a DVI adapter at the end that connects to the card.

Last edited by Jongi; 04-14-2009 at 04:54 PM.
 
Old 04-14-2009, 05:25 PM   #5
Jongi
Senior Member
 
Registered: Aug 2003
Distribution: Debian Sid 32/64-bit, F10 32/64-bit
Posts: 1,070

Original Poster
Rep: Reputation: 45
Here is the new Xorg.0.log

Some highlights

Code:
jongi@jongi-debian:~$ cat /root/Xorg.0.log | grep EE
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) fglrx(0): [FB] Can not get FB MC address range.
Code:
jongi@jongi-debian:~$ cat /root/Xorg.0.log | grep WW
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11/100dpi/".
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11/75dpi/".
(WW) The directory "/usr/share/fonts/X11/Type1" does not exist.
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11/100dpi".
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/X11/75dpi".
(WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
(WW) fglrx(0): Failed to open DRM connection
(WW) fglrx(0): board is an unknown third party board, chipset is supported
Code:
jongi@jongi-debian:~$ cat /root/Xorg.0.log | grep fglrx
(II) LoadModule: "fglrx"
(II) Loading /usr/lib/xorg/modules/drivers//fglrx_drv.so
(II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
(II) fglrx(0): pEnt->device->identifier=0xb2ca70
(II) fglrx(0): === [atiddxPreInit] === begin
(II) fglrx(0): PCI bus 2 card 0 func 0
(**) fglrx(0): Depth 24, (--) framebuffer bpp 32
(II) fglrx(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
(==) fglrx(0): Default visual is TrueColor
(II) fglrx(0): 10BitPixelFormat disabled by default
(==) fglrx(0): RGB weight 888
(II) fglrx(0): Using 8 bits per RGB (8 bit DAC)
(==) fglrx(0): Gamma Correction for I is 0x06419064
(==) fglrx(0): Gamma Correction for II is 0x06419064
(==) fglrx(0): Buffer Tiling is ON
(II) Loading sub module "fglrxdrm"
(II) LoadModule: "fglrxdrm"
(II) Loading /usr/lib/xorg/modules/linux//libfglrxdrm.so
(II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
(--) fglrx(0): Chipset: "ATI Radeon HD 4800 Series " (Chipset = 0x9440)
(--) fglrx(0): (PciSubVendor = 0x1043, PciSubDevice = 0x01fc)
(--) fglrx(0): board vendor info: third party graphics adapter - NOT original ATI
(--) fglrx(0): Linear framebuffer (phys) at 0xd0000000
(--) fglrx(0): MMIO registers at 0xf3be0000
(--) fglrx(0): I/O port at 0x0000ae00
(==) fglrx(0): ROM-BIOS at 0x000c0000
(II) fglrx(0): Primary V_BIOS segment is: 0xc000
(II) fglrx(0): VESA BIOS detected
(II) fglrx(0): VESA VBE Version 3.0
(II) fglrx(0): VESA VBE Total Mem: 16384 kB
(II) fglrx(0): VESA VBE OEM: ATI ATOMBIOS
(II) fglrx(0): VESA VBE OEM Software Rev: 11.7
(II) fglrx(0): VESA VBE OEM Vendor: (C) 1988-2005, ATI Technologies Inc. 
(II) fglrx(0): VESA VBE OEM Product: RV770
(II) fglrx(0): VESA VBE OEM Product Rev: 01.00
(II) fglrx(0): ATI Video BIOS revision 9 or later detected
(WW) fglrx(0): Failed to open DRM connection
(--) fglrx(0): Video RAM: 524288 kByte, Type: GDDR5
(EE) fglrx(0): [FB] Can not get FB MC address range.
(II) fglrx(0): PCIE card detected
(--) fglrx(0): Using per-process page tables (PPPT) as GART.
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(II) fglrx(0): RandR 1.2 support is enabled!
(II) fglrx(0): RandR 1.2 rotation support is enabled!
 
Old 04-14-2009, 05:59 PM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,038

Rep: Reputation: 372Reputation: 372Reputation: 372Reputation: 372
Quote:
So is this likely some xserver-xorg issue (I am running testing btw)?
I am not a developer, and you are running "testing".

You should search on "Failed to open DRM connection" debian
There are 112 matches

Quote:
I am using a VGA cable with a DVI adapter at the end that connects to the card.
That is possibly the cause of your problems because X is unable to read your monitor's EDID information.
 
  


Reply

Tags
input, range, signal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
switching from CRT to LCD get message "signal over range" dholling Linux - Hardware 4 03-19-2007 04:46 AM
Digimate 17" TFT with NVidia graphics - keep getting "signal out of range" vasudevadas Linux - Hardware 3 12-03-2006 07:22 PM
"Input signal out of range" where are the KDE settings stored? whoisdon Linux - Software 1 10-18-2006 01:44 AM
FC4 Doesn't boot error: Signal Frequency is out of Range" tillotso Fedora 11 11-23-2005 08:44 AM
9.2 error message "Signal frequency is out of range" ? What to do? A6Quattro Suse/Novell 8 09-30-2005 09:59 PM


All times are GMT -5. The time now is 01:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration