LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 09-18-2005, 11:46 AM   #1
mohtasham1983
Member
 
Registered: Apr 2005
Location: San Jose
Distribution: Fedora 3,4- Ubuntu 6.06 to 8.10, Gentoo and Arch
Posts: 408

Rep: Reputation: 30
having problem in installing glib2-2.6.4-1


when I want to install this version of glib i do so:
rpm -i glib2-2.6.4-1.i386.rpm
and I get the following error:
file /usr/lib/libglib-2.0.so.0 from install of glib2-2.6.4-1 conflicts with file from package glib2-2.4.7-1
file /usr/lib/libgmodule-2.0.so.0 from install of glib2-2.6.4-1 conflicts with file from package glib2-2.4.7-1
file /usr/lib/libgobject-2.0.so.0 from install of glib2-2.6.4-1 conflicts with file from package glib2-2.4.7-1
file /usr/lib/libgthread-2.0.so.0 from install of glib2-2.6.4-1 conflicts with file from package glib2-2.4.7-1


what s the problem?
 
Old 09-18-2005, 11:22 PM   #2
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
Whatever distro that is that you're using has glib2-2.4.7 installed already. If you want to upgrade the glib2 package try:
Code:
 rpm -Uvh glib2-2.6.4-1.i386.rpm
but I really wouldn't recommend it unless you have a good reason. What are you're trying to install that you need glib2 to be upgraded?
 
Old 09-19-2005, 07:37 AM   #3
mohtasham1983
Member
 
Registered: Apr 2005
Location: San Jose
Distribution: Fedora 3,4- Ubuntu 6.06 to 8.10, Gentoo and Arch
Posts: 408

Original Poster
Rep: Reputation: 30
I need to install gimpshop
why don't you recommend me upgrade glib?
 
Old 09-19-2005, 11:07 AM   #4
mohtasham1983
Member
 
Registered: Apr 2005
Location: San Jose
Distribution: Fedora 3,4- Ubuntu 6.06 to 8.10, Gentoo and Arch
Posts: 408

Original Poster
Rep: Reputation: 30
I wrote that command but I got the following error:
rpm -Uvh glib2-2.6.4-1.i386.rpm error: Failed dependencies:
glib2 = 2.4.7 is needed by (installed) glib2-devel-2.4.7-1.i386
 
Old 09-19-2005, 05:51 PM   #5
tkedwards
Senior Member
 
Registered: Aug 2004
Location: Munich, Germany
Distribution: Opensuse 11.2
Posts: 1,549

Rep: Reputation: 51
Quote:
why don't you recommend me upgrade glib?
It can affect a lot of things on the system. Still if there's no other way give it a try:

Quote:
glib2 = 2.4.7 is needed by (installed) glib2-devel-2.4.7-1.i386
Either get the updated glib2-devel-2.6.4 package from wherever you got the glib2-2.6.4 package or just uninstall glib2-devel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrading glib2 jrdioko Linux - Software 10 06-04-2005 05:40 PM
problem in installing glib2.0.0? gobi_dgm Linux - Software 1 06-02-2005 09:36 AM
Problems installing Glib2 eggoz Linux - Software 0 06-27-2004 06:28 PM
upgrade to glib2.3 wilsnyder Linux - Software 1 07-02-2003 05:07 PM
Cannot find glib after glib2 install spooge Linux - Newbie 0 06-04-2002 08:35 PM


All times are GMT -5. The time now is 04:21 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration