LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 05-26-2003, 10:59 AM   #1
hhegab
Member
 
Registered: Apr 2002
Location: IL, USA
Distribution: Fedora 13, Ubuntu 10.04 LTS
Posts: 162

Rep: Reputation: 30
having a write access


Hi All,

I would like to know how may I have a write access to my vfat partition.
I want to be able to transfer files from Linux to windows from my user account.
what is the command, or the steps I should follow?

hhegab
 
Old 05-26-2003, 11:07 AM   #2
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Rep: Reputation: 30
vfat partitions should have write access by default with the root user. login as root and you should be able to "read/write" with it.
 
Old 05-26-2003, 11:11 AM   #3
hhegab
Member
 
Registered: Apr 2002
Location: IL, USA
Distribution: Fedora 13, Ubuntu 10.04 LTS
Posts: 162

Original Poster
Rep: Reputation: 30
but can't it be done without being root?
I have a problem with my file manager in the su mode (RH 9.0)
when I try it, it asks for the root passwd, and flashes for a second.
I would like to know how may I access these partitions while a user, not a root.

hhegab
 
Old 05-26-2003, 11:35 AM   #4
kazuni
Member
 
Registered: May 2003
Location: Hong Kong
Distribution: Android on HTC Hero
Posts: 256

Rep: Reputation: 30
then u ahve to modify your /etc/fstab, in the entry for the mounted filesystems for your fat partitions, change it to rw instead of ro.
 
Old 05-26-2003, 12:16 PM   #5
hhegab
Member
 
Registered: Apr 2002
Location: IL, USA
Distribution: Fedora 13, Ubuntu 10.04 LTS
Posts: 162

Original Poster
Rep: Reputation: 30
i will try and tell you the results

hhegab
Thank you very much
 
Old 05-26-2003, 01:05 PM   #6
Korff
Member
 
Registered: May 2003
Location: Central Florida
Distribution: Gentoo
Posts: 103

Rep: Reputation: 15
I'd like to know this too.

My fstab line is:
/dev/hda1 /mnt/win vfat noauto,owner,users 0 0

when I, as root, right click the mounted drive and try to change permissions, it won't let me!

So I try doing chmod:

[root@dhcppc1 etc]# cd ../mnt
[root@dhcppc1 mnt]# chmod 777 win
chmod: changing permissions of `win' (requested: 0777, actual: 0755): Operation not permitted
[root@dhcppc1 mnt]#

So .. How can I change permissions? I assure you the hard drive is not read-only
 
Old 05-27-2003, 01:21 AM   #7
Ironica
Member
 
Registered: Jan 2003
Distribution: LFS
Posts: 64

Rep: Reputation: 15
I think you must have the umask option in your fstab:
umask=000
 
Old 05-27-2003, 10:32 AM   #8
hhegab
Member
 
Registered: Apr 2002
Location: IL, USA
Distribution: Fedora 13, Ubuntu 10.04 LTS
Posts: 162

Original Poster
Rep: Reputation: 30
But I was told that they should be 007 not 000
hhegab
 
Old 05-27-2003, 12:30 PM   #9
slightcrazed
Member
 
Registered: May 2003
Location: Lisbon Falls, Maine
Distribution: RH 8.0, 9.0, FC2 - 4, Slack 9.0 - 10.2, Knoppix 3.4 - 4.0, LFS,
Posts: 789

Rep: Reputation: 30
Forgive me if I am wrong, but I thought when mounting Vfat partitions that permissions could only be set on folders that were created as root from Linux. I.E. an already existing folder on your windoze drive will be accessable from Linux, but you can't change permissions on it because the format is different. You can create a folder on your windoze partition and then you can set the permissions on that folder, but not the other way around.

I could be (and have been known to be) wrong, but this is always what I thought.

slight
 
Old 05-27-2003, 01:09 PM   #10
hhegab
Member
 
Registered: Apr 2002
Location: IL, USA
Distribution: Fedora 13, Ubuntu 10.04 LTS
Posts: 162

Original Poster
Rep: Reputation: 30
you can do whaever you want on a windows partition from linux if you have the right permission,
you can even wipe it completely if you are a root.
Now, I think I still can't get my user account write and delete from this vfat partition, can any one help me?

I could figure out a solution, one can use the file manager in the su mode from the system tools menu, that way, one can do what he wants.

hhegab
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grip : no write access to write encoded file bidouilleur Linux - Software 5 10-09-2010 09:23 PM
Write access denied in Vi Hockeyfan Linux - Software 2 07-16-2005 11:03 PM
Getting write access to FAT32 wgself Red Hat 1 01-16-2004 08:48 AM
Grip- "no write access to write encoded file" Alvis Linux - Software 4 01-06-2004 04:18 PM
smartmedia write access wincen Linux - Hardware 1 11-19-2002 05:33 AM


All times are GMT -5. The time now is 09:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration