LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 01-18-2005, 06:50 PM   #1
gbkyle
Member
 
Registered: Sep 2004
Location: NJ USA
Distribution: Gentoo
Posts: 49

Rep: Reputation: 15
Hardware/Software clock lag?


Weird problem, but my clock seems to lag? It wont stay on time correctly and i keep having to do a ntpdate to update it.. i tried setting hwclock to local time hoping that would fix it, but no luck.. im running KDE if that is helpful..

P4 3.2GHZ
512 RAM

thx for any help
 
Old 01-18-2005, 09:57 PM   #2
jbstew32
Member
 
Registered: Feb 2003
Location: Atlanta, GA
Distribution: Debian 3.1
Posts: 149

Rep: Reputation: 15
it loses time while you are running it, or it does it seem to lose the time when you turn it off?
 
Old 01-19-2005, 02:30 AM   #3
gbkyle
Member
 
Registered: Sep 2004
Location: NJ USA
Distribution: Gentoo
Posts: 49

Original Poster
Rep: Reputation: 15
when its running. when its up for 2 days straight, ill lose an hour or so
 
Old 01-19-2005, 02:43 AM   #4
scuzzman
Senior Member
 
Registered: May 2004
Location: Hilliard, Ohio, USA
Distribution: Slackware, Kubuntu
Posts: 1,851

Rep: Reputation: 47
Try replacing your CMOS battery...
 
Old 01-19-2005, 04:07 AM   #5
oneandoneis2
Senior Member
 
Registered: Nov 2003
Location: West Sussex, England
Distribution: Gentoo
Posts: 1,457

Rep: Reputation: 45
I suspect you haven't got the enhanced realtime clock built into your kernel. It's under Character Devices, IIRC.

Compile it in (Not as a module, IMHO) and see if that fixes the problem.
 
Old 01-19-2005, 05:09 PM   #6
randon
Member
 
Registered: Sep 2003
Location: Phx, AZ
Distribution: Suse 9.3 Pro
Posts: 146

Rep: Reputation: 15
I'm having the same problem too, only when I turn it off though. If I boot only into windows for a couple days the clock stays the same (in winblows). But if I boot into Suse 9.1, it's like I lose about 8-10 hours in Linux, like turning the clock off when the PC shuts down. I don't know how to synch it with a server in Suse 9.1, I don't see an option, only to CHANGE the time. When I boot back to windows from Linux, the Clock is ALL messed up and the time difference is always variable, sometimes minutes apart, sometimes hours.
VERY STRANGE.......
Any way to fix this?
Thanks!
RANDON

Sorry to hijack the thread.........
 
Old 01-19-2005, 06:09 PM   #7
gbkyle
Member
 
Registered: Sep 2004
Location: NJ USA
Distribution: Gentoo
Posts: 49

Original Poster
Rep: Reputation: 15
Enhanced Realtime Clock

I already have this compiled into my kernel, so thats not the problem :\ any other suggestions?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 07:19 PM
system clock,hardware clock varunbihani Linux - Newbie 2 07-23-2005 09:04 AM
i can't set my hardware clock jogurt666 Linux - General 3 08-05-2004 10:22 AM
Hardware and System Clock GruiX Linux - Software 5 02-09-2004 01:28 PM
Hardware Clock... philfighter General 0 08-18-2001 10:26 PM


All times are GMT -5. The time now is 04:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration