LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 08-30-2003, 03:08 PM   #1
JevidL
LQ Newbie
 
Registered: Aug 2003
Location: Ann Arbor, MI
Distribution: Gentoo Linux
Posts: 14

Rep: Reputation: 0
GUI abruptly fails to load on restart


Alright, I restart my computer to burn some stuff off of my ntfs partitions on my dual boot system, and when I restart the GUI will not load for Mandrake 9.1. I come back to the forums and do a little searching and find the wonderful command startx, boot into linux, and login. I type in startx and get the following message:


xauth: Creating new authority file /root/.Xauthority
xauth: Creating new authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority
Using authority file /root/.Xauthority
Writing authority file /root/.Xauthority

execve failed for /stc/x11/x (errno 2)
giving up
xinit: no such file or directory (errno2) unable to connect to X server
xinit: no such process (errno 3): Server error


This happens as both root and my usual login. I am at a loss, any suggestions would be greatly appreciated.

Thanks,

- Jesse
 
Old 08-30-2003, 05:20 PM   #2
JevidL
LQ Newbie
 
Registered: Aug 2003
Location: Ann Arbor, MI
Distribution: Gentoo Linux
Posts: 14

Original Poster
Rep: Reputation: 0
Well, after a little bit of chatting in some Linux help rooms on IRC, I eventually stumbled across a command called XFdrake. By running this with the expert switch ["XFdrake --expert"] I wound up reinstalling XFree86 with version 4 (I think this is what was there before) and now all is good. Still don't know what caused the problem in the first place, however it is at least working now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Solution: ip-up fails to restart SuSEfirewall2 properly during PPTPD initialization Marc Linux - Networking 0 10-22-2005 12:00 PM
apache fails to restart nde Linux - Newbie 7 09-13-2005 04:26 PM
GUI fails to load eqisow Suse/Novell 2 06-13-2005 10:01 AM
Samba server ok at boot, later fails to bind to IP. smbd restart doesn't help. tisource Linux - Networking 1 04-09-2005 08:16 AM
Non Root Profile wont load after restart Fr0gg Linux - Newbie 4 04-08-2004 02:42 AM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration