LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 10-26-2002, 06:30 PM   #1
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Rep: Reputation: 30
Grub question


I've looked around here and elsewhere but cant find a satisfactory answer to this:
How can you change the default OS in Grub after installation? The default entry was changed from 0 to 3 and rebooted but it just booted back into Linux.with the default entry change staying set at 3.
The menu.lst looked like this before it was changed:
timeout 10
color black/cyan yellow/cyan
i18n (hd1,1)/boot/grub/messages
keytable (hd1,1)/boot/us.klt
altconfigfile (hd1,1)/boot/grub/menu.once
default 0

title linux
kernel (hd1,1)/boot/vmlinuz root=/dev/hdd2 devfs=mount hda=ide-scsi quiet vga=788
initrd (hd1,1)/boot/initrd.img

title linux-nonfb
kernel (hd1,1)/boot/vmlinuz root=/dev/hdd2 devfs=mount hda=ide-scsi
initrd (hd1,1)/boot/initrd.img

title failsafe
kernel (hd1,1)/boot/vmlinuz root=/dev/hdd2 devfs=nomount hda=ide-scsi failsafe
initrd (hd1,1)/boot/initrd.img

title windows
root (hd0,0)
makeactive
chainloader +1

title floppy
root (fd0)
chainloader +1
I havent used Grub since Mandrake 7.1 and then I never had to do any changes on it(other than the "amend' Mem=xxx" thing).
I have read where its best to choose the default os during installation but as I didnt install this(RH8) that never came into play.I'm sure I'm missing somthing simple or I'm trying to attempt the impossible.If anyone can help I"d surely appreciate it
lynch
 
Old 10-27-2002, 04:23 AM   #2
lynch
Member
 
Registered: Nov 2000
Location: A Mid-Atlantic state
Distribution: SuSE 8.1,Knoppix 3.2,Mandrake 9.1
Posts: 388

Original Poster
Rep: Reputation: 30
Update2: the newbie I was trying to help finally realized(as I should have sooner )that he was actually using Lilo and not Grub So the problem's fixed,he's happy to boot directly to windows, and I feel a little foolish- but not too much
lynch

Last edited by lynch; 10-31-2002 at 04:14 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
grub question...? matthewa Linux From Scratch 2 06-06-2005 03:08 PM
Not your regular GRUB question - just a short question for a fried MBR!! ziphem Linux - General 3 01-31-2005 01:51 PM
Grub question? BajaNick Linux - General 4 07-31-2003 11:35 PM
Grub question? BajaNick Linux - General 0 07-30-2003 07:58 PM
GRUB question malbo1 Linux - General 1 02-27-2003 05:23 PM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration