LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
LinkBack Search this Thread
Old 12-30-2004, 06:06 PM   #1
Gsee
Member
 
Registered: Mar 2004
Location: Australia
Distribution: FreeBSD, OpenBSD, Gentoo, Debian
Posts: 153

Rep: Reputation: 30
Grub only half works


Ok, here's my story.

I have a dual boot Windows XP and Gentoo Linux. Both OS's work perfectly, (as far as Windows possibly can) but I'm having a problem with grub.

My grub.conf is as follows:

#which listing to boot as default. 0 is the first, 1 the second etc.
default 1
# How many seconds to wait before the default listing is booted.
timeout 5
# Nice, fat splash-image to spice things up
# Comment out if you don't have a graphics card installed
splashimage=(hd0,2)/boot/splash.xpm.gz

# The next three lines are only if you dualboot with a Windows system.
# In this case, Windows is hosted on /dev/hda1.
title=Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1

#title=Gentoo Linux 2.6.10-rc1
# Partition where the kernel image (or operating system) is located
#root (hd0,2)
#kernel /kernel-2.4.26-gentoo-r6 root=/dev/hda8

title=Gentoo Linux 2.6.10-rc1
root (hd0,2)
kernel (hd0,2)/kernel-2.6.10-rc1

#title=Gentoo Linux 2.6.7-gentoo-r11
# Partition where the kernel image (or operating system) is located
#root (hd0,2)
#kernel /kernel-2.4.26-gentoo-r6 root=/dev/hda8

title=Gentoo Linux 2.6.7-gentoo-r11
root (hd0,2)
kernel (hd0,2)/kernel-2.6.7-gentoo-r11 root=/dev/hda8


#title=Gentoo Linux 2.4.26-r6
# Partition where the kernel image (or operating system) is located
#root (hd0,2)
#kernel /kernel-2.4.26-gentoo-r6 root=/dev/hda8

title=Gentoo Linux 2.6.9-rc3
root (hd0,2)
kernel (hd0,2)/kernel-2.6.9-rc3 root=/dev/hda8

Now, when I boot my computer grub loads with:

grub>

at which point for Windows I enter:

root (hd0,0)
makeactive
chainloader +1
boot

for Linux I enter:

root (hd0,2)
kernel /kernel-2.6.10-rc1
boot

I can't understand where grub is having a problem with the conf file. Any help would be greatly appreciated.

Gsee
 
Old 12-30-2004, 08:01 PM   #2
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Quote:
Now, when I boot my computer grub loads with:

grub>
Try this...
grub> root (hd0,2)
grub> setup (hd0)
grub>reboot
 
Old 12-30-2004, 08:13 PM   #3
Gsee
Member
 
Registered: Mar 2004
Location: Australia
Distribution: FreeBSD, OpenBSD, Gentoo, Debian
Posts: 153

Original Poster
Rep: Reputation: 30
Well... that looked pretty... but still didn't fix it.

I did:

grub>root (hd0,2)
grub>setup (hd0)
this printed a fair bit of text - everything seemed to be ok as there was a 'done' at the end of every line and the process finished with 'completed'
grub> reboot

but I still came back to
grub>

Thanks for your quick reply
Gsee
 
Old 12-30-2004, 08:42 PM   #4
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Do you know what the actual partition layout is? You seem to have Windows on partition 1 and the Linux root on partition 3 ( hd0,2 ) so what is on partition 2 ( hd0,1 ) ?
 
Old 12-30-2004, 09:36 PM   #5
Gsee
Member
 
Registered: Mar 2004
Location: Australia
Distribution: FreeBSD, OpenBSD, Gentoo, Debian
Posts: 153

Original Poster
Rep: Reputation: 30
I think from memory partition 2 (hd0,1) has another Windows Partition - I have 3 partitions for Windows - Windows, Temp, Data. Then Linux takes partition 3.

Gsee
 
Old 12-31-2004, 05:50 AM   #6
LinuxGeek
Member
 
Registered: Jun 2002
Posts: 302

Rep: Reputation: 31
Give us the output of:
Code:
fdisk -l /dev/hda
Also, do you have a dedicated boot partition or not? The contents of /etc/fstab would also be interesting...
 
Old 12-31-2004, 09:39 PM   #7
Gsee
Member
 
Registered: Mar 2004
Location: Australia
Distribution: FreeBSD, OpenBSD, Gentoo, Debian
Posts: 153

Original Poster
Rep: Reputation: 30
As per request:


/sbin/fdisk -l /dev/hda

Disk /dev/hda: 80.0 GB, 80026361856 bytes
255 heads, 63 sectors/track, 9729 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 637 5116671 7 HPFS/NTFS
/dev/hda2 638 7778 57360082+ f W95 Ext'd (LBA)
/dev/hda3 7779 7791 104422+ 83 Linux
/dev/hda5 638 892 2048256 7 HPFS/NTFS
/dev/hda6 893 2550 13317853+ 7 HPFS/NTFS
/dev/hda7 2551 2678 1028128+ 82 Linux swap / Solaris
/dev/hda8 2679 6503 30724281 83 Linux
/dev/hda9 6504 7778 10241406 83 Linux


cat /etc/fstab
# /etc/fstab: static file system information.
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/fstab,v 1.14 2003/10/13 20:03:38 azarah Exp $
#
# noatime turns off atimes for increased performance (atimes normally aren't
# needed; notail increases performance of ReiserFS (at the expense of storage
# efficiency). It's safe to drop the noatime options if you want and to
# switch between notail and tail freely.

# <fs> <mountpoint> <type> <opts> <dump/pass>

# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
/dev/hda3 /boot ext2 defaults,noatime,noauto 1 2
/dev/hda8 / ext2 noatime 0 1
/dev/hda7 none swap sw 0 0
/dev/cdroms/cdrom0 /mnt/cdrom iso9660 noauto,user 0 0
/dev/cdroms/cdrom1 /mnt/cdrom1 iso9660 noauto,user 0 0
/dev/fd0 /mnt/floppy auto noauto,user 0 0
none /proc/bus/usb usbfs defaults 0 0
/dev/uba1 /mnt/flash vfat
# Network shares
fileserver:/mnt/200Gig /mnt/network/fileserver nfs users,rw,rsize=8192,timeo=14,intr 0 0

# NOTE: The next line is critical for boot!
none /proc proc defaults 0 0

# glibc 2.2 and above expects tmpfs to be mounted at /dev/shm for
# POSIX shared memory (shm_open, shm_unlink).
# (tmpfs is a dynamically expandable/shrinkable ramdisk, and will
# use almost no memory if not populated with files)
# Adding the following line to /etc/fstab should take care of this:

none /dev/shm tmpfs defaults 0 0

Thanks for your help
Gsee
 
Old 12-31-2004, 09:47 PM   #8
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Ok, try this...
grub> root (hd0,7)
grub> setup (hd0,2)
grub>reboot
 
Old 01-01-2005, 05:18 PM   #9
Gsee
Member
 
Registered: Mar 2004
Location: Australia
Distribution: FreeBSD, OpenBSD, Gentoo, Debian
Posts: 153

Original Poster
Rep: Reputation: 30
I tried that:

grub> root (hd0,7)
grub> setup (hd0,2) <- this step complained that it couldn't find the two files it was after
grub> reboot
came back with the same grub prompt.

Any other ideas?
Gsee
 
Old 01-01-2005, 05:31 PM   #10
homey
Senior Member
 
Registered: Oct 2003
Posts: 3,057

Rep: Reputation: 56
Running out of options here.
grub> root (hd0,7)
grub> setup (hd0)
grub> reboot
 
Old 01-01-2005, 05:46 PM   #11
Gsee
Member
 
Registered: Mar 2004
Location: Australia
Distribution: FreeBSD, OpenBSD, Gentoo, Debian
Posts: 153

Original Poster
Rep: Reputation: 30
negative....

the setup (hd0) step still reported that it couldn't find the two files.

gsee
 
Old 01-02-2005, 01:37 PM   #12
LinuxGeek
Member
 
Registered: Jun 2002
Posts: 302

Rep: Reputation: 31
Okay. Try playing around with the find command found in grub. ex.

Code:
  grub> root (hd0,2)
  grub> find /<TAB>
And gives us what it lists. Also, what distro are you using?

Also, do:

Code:
  grub> root (hd0,7)
  grub> find /<TAB>
and tell us what it says.

Last edited by LinuxGeek; 01-02-2005 at 01:38 PM.
 
Old 01-02-2005, 03:38 PM   #13
Tim Retout
LQ Newbie
 
Registered: Dec 2004
Location: UK
Distribution: Debian
Posts: 21

Rep: Reputation: 15
Err... silly idea, but try renaming grub.conf to menu.lst - you never know.
 
Old 01-02-2005, 03:56 PM   #14
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
usually grub uses /boot/grub/menu.list not /etc/grub.conf I think Redhat started this.
 
Old 01-02-2005, 06:00 PM   #15
Gsee
Member
 
Registered: Mar 2004
Location: Australia
Distribution: FreeBSD, OpenBSD, Gentoo, Debian
Posts: 153

Original Poster
Rep: Reputation: 30
woah... LQ stopped Emailing when I got a reply so I didn't see that there were new posts.
I'm about to go and try to use the FIND command.

I also have the menu.lst file in the same location as my grub.conf file

I'm using Gentoo Linux.

Gsee
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lilo only half works... after Slack10.2 A.C. Helm Slackware 11 09-29-2005 11:46 AM
SB live with 10.1 - half works!? sharkzf6 Slackware 6 03-07-2005 03:35 PM
SB live with Slackware 10.1 - half works!? sharkzf6 Linux - Hardware 7 03-04-2005 05:05 AM
Steam problem: Half-Life works perfectly but can't create/join games with CS 1.6. pujolasdf Linux - Games 9 02-09-2005 11:20 AM
php works HALF on slackware tuxandme Linux - Software 1 02-04-2004 11:06 AM


All times are GMT -5. The time now is 11:36 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration