LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices

Reply
 
Search this Thread
Old 06-22-2003, 04:17 PM   #1
zokik
Member
 
Registered: Dec 2002
Distribution: SuSE 8.2
Posts: 58

Rep: Reputation: 15
GRUB multiboot


This is my menu.lst:
Code:
title SuSE 8.2
    kernel (hd0,10)/boot/vmlinuz root=/dev/hda11 vga=0x31a  hdd=ide-scsi hddlun=0 splash=silent showopts
    initrd (hd0,10)/boot/initrd
    acpi=off

title Vector 3.2 SOHO
    root (hd0,8)
    kernel (hd0,8)/boot/vmlinuz ro root=/dev/hda9 vga=791 hdd=ide-scsi

title Windows XP Pro
    root (hd0,6)/WINDOWS/
    chainloader +1

title Windows 98 SE
    root (hd0,0)
    chainloader +1

title floppy
    root (fd0)
    chainloader +1

title cdrom
    root (hd2)
    chainloader +1
I think it's pretty obvious what I want. Unfortunately it works fine only with linux systems and floppy. Problems:

windows xp won't boot at all. I get error:
Code:
filesystem type unknown
partition type 0x7
removing chainloader line doesn't help, tried also without "/WINDOWS/"

windows 98 gets me to my previous nt boot loader with vector, xp and 98, and then I can boot any of those 3 systems. Well, if I could boot to winxp directly from GRUB, fixing this to boot win98 right away would be no problem...

cdrom:
Code:
Error 21: selected disk does not exist
I tried also with hd1 and hd3, got same error message. My cdrom is /dev/hdc.

Oh, and about that vector section ... I just wrote that as I thought it should be. It boots ok, but if something is wrong, please tell me.
 
Old 06-22-2003, 09:50 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,528

Rep: Reputation: 177Reputation: 177
NTFS

According to the following web page a type 7 partition is a Windows NT NTFS partition. Shouldn't XP boot from a Windows NT NTFS partition? Is it possible that you have somehow overwritten part of the partition table?


http://www.win.tue.nl/~aeb/partition...n_types-1.html

Last edited by jailbait; 06-22-2003 at 10:04 PM.
 
Old 06-23-2003, 06:05 AM   #3
zokik
Member
 
Registered: Dec 2002
Distribution: SuSE 8.2
Posts: 58

Original Poster
Rep: Reputation: 15
Yes, it's a NTFS partition. Are you saying GRUB can't boot xp at all because it's on a ntfs partition?

Quote:
Is it possible that you have somehow overwritten part of the partition table?
I always checked everything thoroughly when I was working with partitions and besides win xp still boots ok from nt boot menu. So I think it's a grub issue.
 
Old 06-23-2003, 03:47 PM   #4
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,528

Rep: Reputation: 177Reputation: 177
What I was thinking.

Once upon a time I accidently installed lilo into the begining of a partition instead of the MBR. The OS residing on that partition failed to recognize its file system as a valid file system. So I asked you if you accidently installed some of your boot loader sequence in the wrong place.

"besides win xp still boots ok from nt boot menu"

So obviously the problem is not that the NTFS file system is clobbered which is what I was thinking.

I know that various parts of Linux has trouble dealing with NTFS, perhaps grub does also. I do not understand the Windows multiboot process but as I understand your configuration you are booting with grub first. Then if you want to boot a Windows OS grub hands control over to a Windows bootloader which decides which Windows to launch.

If my understanding is correct then I would try rearranging your bootloader sequence so that grub hands control over to a Windows bootloader which is not located on a NTFS partition. If necessary, you could create a small FAT32 partition which serves no purpose other than to be the one that grub hands the baton to.

Last edited by jailbait; 06-23-2003 at 03:56 PM.
 
Old 06-25-2003, 03:25 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,665

Rep: Reputation: Disabled
Have you checked your permissions? When your NTFS-partition is mounted from /etc/fstab it might lack the executable flag. (Sorry no syntax right here, try "man mount", the options section or google for examples. I seem to remember that you use something like chmod 022 ?? Any experts around here?).
 
Old 06-25-2003, 05:29 AM   #6
zokik
Member
 
Registered: Dec 2002
Distribution: SuSE 8.2
Posts: 58

Original Poster
Rep: Reputation: 15
I have this line in /etc/fstab to mount the win xp partition:

/dev/hda7 /mnt/winxp ntfs noexec,gid=prtwinxp,umask=0227,auto,ro 0 0

I just changed umask to 0222, rebooted, and stil got that
filesystem type unknown
partition type 0x7
when I chose to boot windows xp.

I could still simply reactivate nt boot and add a choice for suse, but I guess you just *have* to use either grub or lilo if you are a linux user
 
Old 06-25-2003, 05:40 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,665

Rep: Reputation: Disabled
Better do a man umask (I don't know, that it takes four digits...).

noexec sounds ominous to me, you do want to execute?!

Next candidate would be gid and its parameter, which I don't know.

What worries me too, is the "file system unknown". Have you ntfs support enabled in your linux ? (Do a search over this site, there is lots of information on this subject here).
 
Old 06-25-2003, 06:41 AM   #8
zokik
Member
 
Registered: Dec 2002
Distribution: SuSE 8.2
Posts: 58

Original Poster
Rep: Reputation: 15
I am not sure about the first digit, I think it's about set user id and set group id... anyway, according to http://linux-ntfs.sourceforge.net/info/ntfs.html#4.9 four digits should be ok.

I put noexec because there are no linux binaries on that partition and I just want to access some files. I didn't think about booting... I'll remove noexec and try again. EDIT: deleted "noexec" from /etc/fstab, doesn't help

gid is set to a group I created. Only users that are members of that group have access to /dev/hda7. Since changing permissions to "read and exec (allowing enter into directories) for everyone" didn't make a difference I don't think seting gid is causing any problems with booting windows xp

About ntfs support... I can read files on ntfs partition from linux, so I assume it is enabled. AFAIK the only (or at lest the only bigger) distro without ntfs support is redhat. On the other hand, it is strange that I get "file system unknown" message...

Last edited by zokik; 06-25-2003 at 06:56 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Poblem: Grub and Windows multiboot Paul L Linux - Newbie 6 07-19-2005 04:18 PM
Grub Multiboot question PacMansRancor Linux - Newbie 4 09-22-2004 12:40 AM
Grub ?????? [Multiboot] UsualTuxpect Linux - Software 4 09-13-2004 12:37 AM
multiboot (GRUB) problem GoK Linux - Newbie 15 07-24-2003 08:03 AM
Problems using grub to multiboot amp2000 Linux - General 2 10-18-2002 12:40 PM


All times are GMT -5. The time now is 06:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration